installing from KOTD fails due to "'kernel-default' not found" error

I am trying to install the latest kernel from KOTD, but it is not working. I did the same thing at home a few weeks ago on my laptop, and it worked fine there.

The 2 systems are slightly different. At home, it was installed with the LiveCD and btrfs, and here it was installed with the DVD and ext4.

Here are the instructions I followed: openSUSE:Kernel of the day - openSUSE

Here is what I tried, including listing everything found in the repository, which doesn’t include “kernel-default” (or any other kernel I can install). I can however see them from a web browser here.

# zypper ar KOTD
Adding repository 'KOTD' [done]
Repository 'KOTD' successfully added
Enabled: Yes
Autorefresh: No
GPG check: Yes

# zypper install -r KOTD kernel-default
Building repository 'KOTD' cache [done]
Loading repository data...
Reading installed packages...
'kernel-default' not found in package names. Trying capabilities.
No provider of 'kernel-default' found.
Resolving package dependencies...

Nothing to do.
# zypper refresh -f KOTD
Forcing raw metadata refresh
Retrieving repository 'KOTD' metadata [done]
Forcing building of repository cache
Building repository 'KOTD' cache [done]
Specified repositories have been refreshed.

# zypper install -r KOTD kernel-default
Loading repository data...
Reading installed packages...
'kernel-default' not found in package names. Trying capabilities.
No provider of 'kernel-default' found.
Resolving package dependencies...

Nothing to do.

# zypper search -r KOTD
Loading repository data...
Reading installed packages...

S | Name            | Summary                     | Type      
v | kernel-docs     | Kernel Documentation        | package   
  | kernel-docs     | Kernel Documentation        | srcpackage
v | kernel-firmware | Linux kernel firmware files | package   
  | kernel-firmware | Linux kernel firmware files | srcpackage

# uname -a
Linux peter 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) x86_64 x86_64 x86_64 GNU/Linux

Since then I ran

zypper update

but didn’t reboot.

Can someone tell me what is going on and how to fix it? Thanks.

And this system is x86_64, but at home it is a single core 32 bit.

Well another way is to compile your own and bypass the repository method. I have several scripts that can make the process very painless:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.71 - Blogs - openSUSE Forums

And to obtain ANY kernel version back to 2005 you can use this:

S.G.T.B. - SuSE Git Kernel Tarball Creator - Version 1.80 - Blogs - openSUSE Forums

Why not check these out and see if they help you out.

Thank You,

Thanks for the reply. Does SAKC add the SUSE patches also, or do you end up with a vanilla kernel in the end?

And since my posting, I have browsed the repository from a web browser, and installed the rpm I wanted, which worked fine. And I submitted a bug report about KOTD. And looking again at home, the repository looks the same as at work. So maybe the repo was broken since I installed it at home. Can you tell me how to figure out if it is really broken? I didn’t inspect it close enough before to compare it now. eg. I don’t know if the “kernel-default” package is some hack that doesn’t show up with search and info commands.

For example, if I look at the package at homoe, it fails to correctly tell me the repository, and instead says “@System”, so I don’t know if my current kernel here was installed from the repository while it looks like it does now, or if it was broken since. (This “@System” thing is likely a separate zypper bug, because it does this for any package, eg. konsole or amarok; someone on IRC told me it should only say “@System” for packages that didn’t come from any repo)

$ zypper info -r KOTD kernel-default
Loading repository data...
Reading installed packages...

Information for package kernel-default:

Repository: @System
Name: kernel-default
Version: 3.4.rc7-1.1
Arch: i586
Vendor: obs://
Installed: Yes
Status: up-to-date
Installed Size: 114.3 MiB
Summary: The Standard Kernel
The standard kernel for both uniprocessor and multiprocessor systems.
Source Timestamp: 2012-05-14 04:31:50 +0200                                                                                                                                         
GIT Revision: f554d8b2395ecf25c56e8c6ee80c45e3c6ddb9b3                                                                                                                              
GIT Branch: master

First its good to hear you solved your problem. That’s what we like to hear.

Second, SAKC uses your default active kernel configuration by default (with all current patches you have loaded from YaST), you can also select the original (distro released) kernel configuration to go back to start, you can modify and use any kernel configuration which gets saved before the compile starts, you have an option to use menuconfig on any selected kernel configuration, you can manually edit any .config file for use and you can go back in time and select any previously saved kernel configuration. I have the kernel config thing selectable six ways from Sunday though that does not some how make you an expert at configuring a kernel, but it gives as many options as I can think of.

Thank You,