Installing draftsight on Leap 42.1

SolidWorks/Dassault Systemes produce a good 2D design application called DraftSight which is available as a zero-cost download for Linux.
There are two versions one rpm for Fedora and one deb for Ubuntu. The rpm can be made to work on Leap.

Download the rpm file from the Dassault Systemes website. (Google solidworks and select “free tools” from products)
Let us call the file downloaded draftSight.rpm.

Make sure that you have the packman community repository in you repository selections. Use Yast to add it to your repositories, select it from the community repositories.
Install libaudio2 from packman repository.
Install libGLU1 from openSuse main repository (OSS)
Install rpmrebuild from openSuse main repository (OSS)

Edit the draftSight.rpm file:
>rpmrebuild -ep draftSight.rpm

This will bring up a “vi” based edit window.
Change “Requires:” to “Requires: libaudio2”
Change “Requires:” to “Requires: libGLU1”
Save the file and exit - this uses the ‘ZZ’ command.
You will be asked “Do you want to continue? (y/N)” respond with “y”.
You will then see many warnings which you can ignore and then a long pause (shorter if you have a very fast system) - be patient.
the result will be in:
or some such <filename> depending on the version that you downloaded.
Install this rpm with:
su -c “yum localinstall <filename>”

This worked for me.
Your comments will help and may improve other users chances of a good load.

Hope this helps.

Nice tip, hope a moderator will be kind to put this in the tips and tricks section or how to forums.

I only have one question. I use draftsight before in previous versions of openSUSE.
It is a good free cad application, but I find it to slow and have mouse problems dealing
with complex 2d drawings. I wonder if in openSUSE Leap 42.1 if it has improved.


Will be moved to Unreviewed Howto and FAQs.

CLOSED for the moment.

Moved from Applications and open again.

Yes, I have managed to follow instructions, no problem (thank you! pblewis), but have the same mouse problem as conram (mine is also 13.2 rather than 42.1) so I would love to know the answer to this question as well - is mouse action OK in 42.1?

I would

Draftsight gives me serious issues with the mouse pointer on Leap (it moves itself). It worked well on opensuse 13.2 instead.

As an alternative i’m running Qcad free.

Yes, quick search on interweb confirms the problems with mouse on (mostly) Linux versin.
It seems to be applicable to x64.
The old (x32) version appears to have been fine (it may explain why yours was working on 13.2 ??).

However much I’d like to have alternative to Autocad on Linux, DraftSight in it’s present condition is not a working proposition :(.
btw - I am running DraftSight on Win7 and AutoCad on XP. Qcad free might be OK for what you need, but it is not an alternative to AutoCad.

I think i was running the x64 version on 13.2.
Btw i agree with you, qcad is fine for my home needs but not a real alternative to Windows autocad.

I’ve used Draftsight on various linux and windows boxes and the issue with the mouse pointer lag is common on linux machines.
To improve the pointer speed disable Vertical Sync (or Wait for Vertical Refresh) in the graphics driver.
It seems that AMD cards have a very hard time with this, Nvidia not so much.

Draftsight is great when it works! It is truly a viable alternative to AutoCAD LT.

That would be BricsCAD, but you have to pay for it, although much less than you’d pay for AutoCAD.

I’ve been using it professionally since version 10 (it’s on 16 now). It improved markedly, and is a real alternative.

For 2D only there’s the classic version, for 2D/3D the Pro version. I’m running the Platinum version, that deals with 2D, 3D, sheet metal, 2D and 3D constraints, DB, BIM, PDF import/export and a lot of other features. The only thing it doesn’t have OOTB is foreign 3D model import/export (CATIA, STEP, IGES, etc.), that require the communicator plugin. And that one costs more than BricsCAD itself last time I checked.

In the last decade I tried all available CAD options, and still do occasionally. The best and professionally very usable one in linux is BricsCAD, hands down. The last time I had to use AutoCAD was in 2011 IINM.

Also, their current licensing scheme allows each license to be installed and used (concurrently if you wish) in two machines. Internet validation is required for registering only, after that you can use the software offline if you wish. With version 15, only for fun, I tried installing the windows version in a VM with my license and it worked (I uninstalled after testing, of course). What’s not to like?

Disclaimer: I’m not affiliated with BricSYS in any way, but I really value their product and support. I talk as much as possible about it as their linux user base is very small, and my feeling is that it’s not growing, unfortunately.

The pointer issues seem fixed with last version on Draftsight on Leap

Thank you for this thread, especially the tip to change the two packages with rpmbuild.
I am using Draftsight at work (on Windows) and now I can use it at home as well.
Didn’t notice the problems some people have with the mouse, here it works as it should.
Use it in a Virtualbox Virtual Machine.

Though I appreciate your sharing this here, IMHO it’s not the way to do things, i.e. it’s a hack. The best way to go would be to get packages in OBS
From what it looks like we already know what needs to be done to the spec file to build a proper rpm on OBS and have it available for everyone

just installed DraftSight 2017 beta, rpm for Fedora, on Leap 42.2. On the first try it seems to be working smoothly: no issues with the pointer using HD graphic 530.

The workaround proposed by pblewis is still ok.
I have installed the rebuilt rpm with su, zypper install “therebuiltfile”.rpm

It would be great indeed if the “proper” rpm was available for everyone… especially now, that 2017 version appears to have solved original problems with mouse control.

It seems that “proper” rpm will never be available (correct me if I am wrong?) because draftSight is not an open source…
So I have used the hack.
Yes it works fine, the only difference was that I have used:

zypper in draftsight-2017.0.0.1197-1.x86_64.rpm

to install the rpm

Old mouse problems are gone and I am satisfied customer - thank you pblewis

I am trying to install draftsight on my leap42.1, but I am unable to install libaudio2 from packman. Packman is in the repositories, but it seems libaudio2 is not on packman. I did refresh packman:

# zypper ar -f packman
Adding repository 'packman' ...................................................................................................[done]
Repository 'packman' successfully added
Enabled     : Yes                                            
Autorefresh : Yes                                            
GPG Check   : Yes                                            
Priority    : 99                                             
URI         :

# zypper in libaudio2
Loading repository data...
Reading installed packages...
'libaudio2' not found in package names. Trying capabilities.
No provider of 'libaudio2' found.
Resolving package dependencies.

Nothing to do.

Can somebody tell me what is wrong?

Thanks, Charles

Sorry, this is the wrong thread. I will repost.