Installer/Live CD kernel panics on boot

Hey everyone,

I’ve recently decided to (re) try OpenSUSE on my desktop. I’m using the ‘Live KDE’ ISO, which I have dd’d (Is that a term?) onto a USB thumb drive to install from.

My first attempt seemingly went alright. I booted off the USB stick, and chose the KDE Live environment - I figured if anything went wrong, I could open up Firefox and search for some solutions. So I sorted out my partitions (I have two drives in my PC - a smaller, 140GB (which currently houses a painfully-botched Arch Linux install) and a larger, 2TB (which has my /home on it, which I intend to keep). My plan was to allow Suse to overwrite the 140GB, and keep the 2TB as my /home.

Anyway, the installer got to 100% on the top line and about 64% on the bottom line, when it seemingly logged out to the login screen. I thought maybe that meant it was done, so I rebooted, removed my USB stick and crossed my fingers. Apparently it wasn’t done, as the GRUB completely failed to load up and instead dropped to a rescue prompt, with the error ‘unknown filesystem’.

Alright, so that was my first attempt (I’m sorry, I don’t intend for this to be a rant, just providing background!)

So I tried booting off the same USB stick again, and no matter which option I choose (Live KDE, straight-up installation, or check install media) it comes up with the loading kernel box, but then spews out lots of text on a black screen, giving itself 90 seconds after which it reboots.

This is about the only line I can reliably type out before the 90 minutes goes away:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I’ve also tried re-downloading the Live KDE (I really don’t want to install GNOME, ran it for a bit on Arch and fancy something new), and have used two different drives so far to boot it off. Both are now giving me this error, which is making me think something’s up on the computers end (Why else would it work once, and then fail afterwards?).

Is there anything else I can try here? Thanks all!

Alright, there’s another line that looked interesting here.

Right before my screen fills up with text, the first thing that pops up is:

Initramfs unpacking failed: uncompression error

The rest just floods past, and the next thing I see is in the first post.

Just a wild guess. I have known the installer on some system to want to install to the USB stick so did you double check the partitioning scheme?? This of course would have overwritten the installer and perhaps show the problem you report. In any case the USB was somehow modified which is not at all normal.

Well, I’ve re-written the .iso to a different USB stick and still get the same problem :slight_smile:

Plus the first install (IE. the one that actually almost-installed) appears to have overwritten my main 140GB drive (which is what I intended). I haven’t even managed to get into a live environment since then! :smiley:

Would it be worth trying to wipe the USB stick and then burning the .iso onto it? I’m putting the .iso onto the USB stick using dd by the way (Using another computer on which I am here typing to you!)

Don’t think it would help any to wipe the USB. Just be certain that all the partitions and grub are going to the correct drive. nothing should point to the USB in the scheme

Alright, I’ve sorted my issue - I re-downloaded the .iso, checksummed it, and re-baked it onto the USB stick. Installation went flawlessly (including my disk setup) and also took about 10 minutes total! :smiley:

Thanks for helping! and I apologise for the day-late reply, it was bedtime by the time I’d finnished messing with it last night.