Installation of lxd (with combustion) using btrfs driver fails

I am trying to install lxd in MicroOS.
Works fine if I select the ‘dir’ driver during lxd init.
If I select the btrfs driver the init procedure will complete without error. However, if I then try to launch a container I get an error:

Error: Failed instance creation: Failed creating instance from image: Failed to run: btrfs qgroup create 0/273 /var/lib/lxd/storage-pools/default/images/ed7509d7e83f29104ff6caa207140619a8b235f66b5997f1ed6c5e462617fb71: exit status 1 (ERROR: unable to create quota group: File exists)

For reference here is what I do to install lxd:

sudo transactional-update pkg install lxd attr
# after reboot
sudo usermod -aG lxd $USER
sudo systemctl enable --now lxd
sudo lxd init
# select btrfs as storage pool driver and keep the rest default

With sudo btrfs quota enable / I get the same result.
Also, if I create a second storage pool on a separate newly created subvolume.

I also tried to use combustion as per instructions from the microos wiki page.
Here my combustion file:

#Install lxd
zypper --non-interactive install lxd attr
#Enable lxd service
systemctl enable lxd
#Start lxd service
systemctl start lxd
#Configure lxd
cat <<EOF | lxd init --preseed
- name: lxdbr0
  type: bridge
    ipv4.address: auto
    ipv6.address: none
- config:
    source: /var/lib/lxd/storage-pools/rorqual
  description: ""
  name: rorqual
  driver: btrfs
#Leave a marker
echo "Configured with combustion" > /etc/issue.d/combustion

I mounted the combustion.iso in a second cdrom device during initial installation (microos.iso mounted as first cdrom device). Installation completes but lxd was not installed.

I guess, I do something probably quite obvious wrong…

Any advice or pointers in the right direction would be highly appreciated.



Normally qgroups are implicitly created when subvolume is created (if quota is enabled for btrfs). Sounds like an oversight in your application.