Installation of Leap 15.6 Beta. Experiences

Hi, I installed Leap 15.6 offline on an AMD Ryzen3-5300U laptop on the day of the beta release, the installation went well, the Gnome environment started correctly. I went to Yast and it had a list of amd-microcode programs to install, as always happens when you install offline. Once the programs proposed by Yast have been installed after an offline installation, this screen appears on the first reboot:

PD.: When I ran zypper up it told me that the backports repository had expired keys.

Yes, I got that screen – I think it was from GDM.

It was due to the packman packages that I have installed.

I used:

zypper dup --from oss-repo --allow-vendor-change

to switch them back to the main repo. And that solved this problem.

That’s not really a problem. That repo isn’t really being used yet.


I just upgraded on bare metal from a test Gnome Leap 15.4 (I know, not officially supported) and am currently up and running in 15.6 beta.
I disabled packman before the upgrade, had to solve a couple of problems uninstalling (the obsolete) Virtualbox and accepting conflicts from gstreamer and eventually used:

zypper --releasever=15.6 --allow-vendor-change --no-recommends

After successful reboot I ran:

zypper inr

which among other things enabled a Nvidia repo I didn’t want (and then I disabled).
I enabled the 15.6 packman and switched packages the usual way.
And … so far so good (but stay tuned, I didn’t test extensively yet).

1 Like

I’ve been using VM Leap 15.6 since October. already in alpha it was going very well and I always found it better than the 15.5 version. One problem I have often had is adding the packman repository. Now I only use essentials and avoid --allow-vendor-change. I’m just an amateur and don’t want too much trouble just for codecs

Packman don’t support the alpha phase usually, but by now they have caught up apparently.

I just tried again (switched to packman). There’s still something it does not like about packman – same error screen.

@OrsoBruno in October, since the 1st installation of Leap 15.6 alpha, the packman repository dedicated to it was already present. But I often had to resort to the ISO to restore a system that wouldn’t boot. Now I’ve learned my lesson…

@nrickert HI. I did some home tests in vm virtualbox. I have a host system with Windows 11 pro installed in an Intel NUC 12 PRO. Virtualbox as far as I know does not yet support my hardware. My top 2 systems, both with KDE, are Leap 15.6 and Slowroll. In my humble opinion, which I repeat am a neophyte, the Leap compared to the Slowroll just has a slightly too high RAM consumption. Otherwise, in terms of stability it is really excellent. I tried with many YouTube tabs open at the same time and other apps like gimp, hugin and others and the 2 OS always responded very well.

I also started with 15.6 alpha. In my case, I installed it in a KVM virtual machine. Using packman was fine at first. But at some update, it began to fail on the graphics. And I also have 15.6 installed in a spare partition directly on my desktop system.

I’m not noticing a problem with RAM consumption. But perhaps I haven’t checked carefully.

My main desktop system is using Leap 15.5, which has been working very well. But WiFi doesn’t work with 15.5 (it does work with 15.6).

On a fresh installation, unless the installer made a change I haven’t had occasion to notice, the reboot that follows announcement that installation has completed is not a full reboot like most of us know or expect. It doesn’t involve BIOS or POSTing. Instead, kexec is used to change to the new kernel and reinit from the new system. This can account for why different behavior sometimes occurs between first and second boots following installation. This behavior can be disabled, which I habitually do, by including kexec_reboot=0 on the installer kernel’s command line.

Hi, Is it possible to add the packman repository to Leap 15.6 beta or is it not possible yet?

Yes, it is active, but see the former comments by @nrickert

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.