Install program

Hello, I’m fairly new to Linux, but have been using it for some time. I downloaded a program called AMSN (got the .tar file) I saved it to my desktop, but when I try to install it, it says it’s not found on my system. I go to the command line to unpack it, then make etc… but it says it’s not found. Can anyone give me a hand with this? I’ve tried yast but no luck there either. I even click on the “install” program icon and that doesn’t work either. Thanks in advance!


amsn is in Packman
If you have that repo, which you should

Just do:

zypper in amsn

from a su terminal

or just click this

Thanks. I clicked on the link you gave, but I’m running Suse 11. I get this message: cannot install in this version of suse.

I still get the message: The install link or file you opened does not contain instructions for this version of open SuSe

I don’t know why I’m having this trouble…My version is 11.0 from the install DVD. How do I check if it’s been updated to say…11.2? Thanks.

You said 11.1
Now you say 11.0

What the heck

i wonder if maybe you are running SUSE Linux Enterprise Linux version
11 (also known as SLED 11), or maybe you are running openSUSE 11.0,
11.1, or 11.2

that is four possible systems…to learn which one you have, open a
terminal and type:

cat /etc/SuSE-release

if you are running SLED you should ask in as it is a
purchased system and has support there…

if you are running openSUSE come back and tell us exactly what OS you
use (from the code above), confirm you have packman enabled in your
YaST and then tell us exactly the error you get after trying to
install amsn with zypper or YaST…


Ok, it comes up no such file or directory. I know the /etc directory is there. When I look at the install DVD, the cover says “openSuse 11.0”

Here is the info when I look at the system monitor:

Kernel Linux
Gnome 2.22.1

PackMan :: Informationen zum Paket amsn

This gives a page with a one click install button that will add the Packman repo on the fly, select your openSUSE and 32/64bit and click it.

HooLeeO wrote:
> Ok, it comes up no such file or directory. I know the /etc directory is
> there. When I look at the install DVD, the cover says “openSuse 11.0”

as far as i can tell only one two things may have happend:

  1. you didn’t type carefully enough, it must be

cat /etc/SuSE-release

that is, none/zip/zero/nada of the following will work:

cat /etc/SUSE-release
cat /etc/suse-Release
cat /etc/suse-release
cat /Etc/SuSE-release
Cat /etc/SuSE-release
cat /etc/SuSE_release

  1. you have a horribly gone wrong install…otherwise it would have
    found that file!


Did you copy and paste that code?
Try again

Post the result of this:

zypper lr

I did type it wrong (the SuSE part)
It reads out:

openSUSE 11.0 (i586)
VERSION = 11.0

| Alias | Name | Enabled | Refresh

1 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
2 | openSUSE-retail 11.0 | openSUSE-retail 11.0 | Yes | No
3 | repo-oss | openSUSE-11.0-Oss | Yes | No
4 | repo-debug | openSUSE-11.0-Debug | No | No
5 | openSUSE-11.0-Updates | Updates for 11.0 | Yes | Yes

You do not have packman set up as a repository.

did you follow Knurph suggestion That should install the package you want ans also add the packman repo.

I did try his suggestion and clicked on the link he provided. I downloaded the file, then when trying to install, I get this message:
Package /home/julian/Desktop could not be installed.
Subprocess failed. Error rpm failed. warning /home/julian/Desktop/ Header V3 DSA signature: NOKEY, key ID 9a795806 error: failed dependencies:
libfarsight2_0 is needed by
gstreamer-0_10-plugins farsight0_10 is needed by amsn…
gstreamer-0_10-plugins-bad is needed by amsn…
tis is needed by amsn… is needed by amsn… is needed by amsn…

That is the whole of the error message. Am I missing some packages that I have on the DVD?

Just click this

First off, I would like to thank everyone who has helped me in this matter. I’m sorry for being such a newbie but I’m trying to learn. Now, I clicked on the link above, and it seemed to run ok (asked for the DVD). It created an icon in the applications list for me. I click on it and I get this message now:

There’s a problem loading a module of aMSN (TkCximage):

Loading TkCximage failed. This module is needed to run aMSN. Please compile aMSN first, instructions on how to compile are located in the file install.

Now, would this be the instructions that I saw which included make? The author referenced the amsn-0.98.1.tar.gz file.

This is a bug in the amsn package.
Reboot your computer
And try it again.

Is there any reason you need amsn?
Can’t you use kopete? or Pidgin?

FYI: You should disable the DVD as a source in Yast - Software - Repositories
It is better to use online only if you have a decent internet.

If the problem persists and your really want amsn, you should report the issue to Packman. I can show you how if you want.

Does PackMan have a bug tracker? Someone was asking me about that the other day.