install kernel module tuxedo-keyboard on my TUXEDO InfinityBook Pro 15 v4

It’s better to open a new thread :slight_smile:
on this thread
I asked this:
on my TUXEDO InfinityBook Pro 15 v4, processor= Intel Core i7-8565U, RAM=32Gb, 2TB SSD disk running KDE:
I cannot install tuxedo-keyboard kernel module
I written to tuxedo
my last email to tuxedo said this:
"maybe the kernel module is not loaded?
Please try adding the module with:

sudo modprobe tuxedo-keyboard

Or as a permanent solution:

sudo echo tuxedo_keyboard >> /etc/modules

Does that work?"
but it didn’t worked. and they didn’t replyed.
in the thread]( malcolmlewis]( gently answered me this:

That’s not the way it’s done on openSUSE, that looks like Ub* speak?

Create a /etc/modules-load.d/tuxedo-keyboard.conf file and in that file have one line with tuxedo-keyboard in it.

I did but it didn’t worked.
I also did this:

pla4-TW:/home/pla # modprobe tuxedo-keyboard
modprobe: FATAL: Module tuxedo-keyboard not found in directory /lib/modules/5.4.13-1-default
pla4-TW:/home/pla # 

how can I solve and install the tuxedo-keyboard module?

From which source did you install tuxedo-keyboard?



Tuxedo doesn’t sell laptops with TW, only with 15.1, so no use to ask for support on a platform you removed. You could however ask them for the source code and build the module yourself.
And as long as you do not provide any info about what’s working and what’s not, it’s kind of hard to help you.

I probably misunderstood your post. You have not yet installed tuxedo-keyboard?

I use tuxedo-keyboard form here:

It works fine on my Tuxedo-Book XC with openSUSE Tumbleweed.

However the installation instructions given on the site need to be modified as malcolmlewis]( already described.



Let me have a look and build a KMP rpm tonight sometime… :wink:

Here you go;

When built, you need to download and install both packages;

Download from here (please don’t add the repository);

The second one contains the two configuration files, now with an rpm the load modules one is not in /etc it’s in /usr/lib/modules-load.d/

Once downloaded and installed, run mkinitrd.

See how that goes…

Kernel has updated, it’s at 5.4.14 now, module has been rebuilt.

Maaanythanks malcolmlol!, I installed the ones you gave me yesterday
for kernel 5.4.13-1-default, I installed and run mkinitrd and

modprobe tuxedo-keyboard

now seems ok
it works like before but with another color, but I cannot succeed to change the color of keyboard modifying /etc/modprobe.d/tuxedo_keyboard.conf
as this

options tuxedo_keyboard mode=0 brightness=200 color_left=0x008000 color_center=0x008000 color_right=0x008000

but color doesn’t change

…but, this means that every kernel change I have to reinstall these two rpms??:open_mouth:

Just the kmp one… but should populate weak-updates for a little while, or configure dracut…

You need to remove the module and then reload it for that to work (or reboot).

yeaaahhhhhhrotfl! it works!!! my keyboard is green now, manythanks!!

pla4-TW:/home/pla # modprobe -r tuxedo-keyboard
pla4-TW:/home/pla # modprobe -v tuxedo-keyboard
insmod /lib/modules/5.4.13-1-default/updates/src/tuxedo_keyboard.ko mode=0 brightness=220 color_left=0x008000 color_center=0x008000 color_right=0x008000 
pla4-TW:/home/pla # 

about dracut, as I understood you compiled the module for me :shame: , I downloaded and installed, …so if I configure dracut it will compile the module or what other?

Well dkms, there is a config that would need adapting at tuxedo-keyboard/dkms.conf at master · tuxedocomputers/tuxedo-keyboard · GitHub

Else, just use the rpm…

As “root” all parameters can be changed (with immediate effect) without un-/loading the module, e.g.

# echo 100 > /sys/devices/platform/tuxedo_keyboard/brightness



fantastic!!! maaanythanks :slight_smile:

Dear all, after tumbleweed upgrade tuxedo keyboard backlight doesn’t works anymore :frowning:
malcolmlewis did some operations to build something

…Let me have a look and build a KMP rpm tonight sometime.

…now I have more time cause coronavirus, so, please teach me to do the same operation to have the tuxedo keyboard working againlol!

Install the updated rpm to match your running kernel…

maaaanythanks malcolmlol! now everything works
…what I have to study to do the same thing you did for me?lol!