Install Gnome Desktop after KDE Install (11.2)

Hi Folks,

I installed KDE from a CD. Then decided I wanted to have Gnome has an option. I installed “gnome-desktop” via software manager (as per some other instructions on the forum) but I still have no option to choose Gnome when logging in.

What all do I choose to get the complete Gnome environment? Or is it better (& easier?) to reinstall with a DVD?

Can we assume you checked the Session option at the bottom right of the login screen and did not find Gnome as a selection? You can not auto log into openSUSE and change the Session type. If you did check the Sessions and found no Gnome option then; Open up YaST>Software Management. Pick View > Patterns. You should see GNOME Desktop Environment and GNOME Base System check blocks. Check them if not checked and allow the Gnome System files to Load.

Thank You,

Yes, you can assume that I checked the Session option. :slight_smile:

However, I didn’t choose patterns “view” when I chose gnome-desktop. That was my mistake.

But now I’m running into the same issue that others have had:pattern:gnome-11.2-20.22.1.i586 requires patterns-openSuse-gnome, but this requirement cannot be provided
uninstallable providers: patterns-openSUSE-gnome-11.2-20.22.1.i586[repo-oss]

It then offers me several Conflict Resolution possibilities:

1.deinstallation of patterns-openSUSE-kde4_pure-11.3-1.1.1.i586 not install…
3.break gnome…

I haven’t updated KDE, other than to accept the post-install recommendations.

Can you post the output of this:

zypper lr -d

Here it is. (I noticed the previous poster with this issue reinstalled OpenSuse. Sigh…)

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | |
2 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
3 | X11:XGL | X11:XGL | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.2 |
4 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
7 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
8 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2

So I did pick de-installation of patterns-openSUSE-kde4_pure-11.3-1.1.1.i586, though I use the 64 bit version and GNOME installed just fine for me. You never break or ignore any requirements. However, removing the kde4_pure pattern should not be a problem. You have already installed KDE and with both KDE and GNOME installed, you do not have a single major desktop installed. It worked for me just fine and I am running Firefox under GNOME even as we speak.

Thank You,

Update: It worked “ok”. It’s ok in the sense that KDE works fine. Gnome, however, is missing it’s network app - or can’t start it. I’ll try to get more details but this a heads-up in case anyone knows what the problem is without the details. Also, I don’t care for the OpenSuse Gome Menu. I tried to revert to the older Gnome menu using the “Add” feature, but I can’t manage to find the right option (though I did it once before?). Would appreciate any reminders?

OK… when Gnome first starts it states that Network Manager is missing “required sources”. Weirdly, a little message pops up where the connection icon “should” be stating that wireless networks are available - and that’s the last I see of that. It’s just a bubble without an icon. If I try to configure the network under gnome, Yast informs me that the the network app is being controlled by the Network Manager and that all configuration needs to be done through the network manager.

I’m guessing there is some kind of conflict between KDE & Gnome?

In KDE, did you change the network setup from the default ifup to Network Manager by chance? You might switch back to KDE and in your Network Hardware, change the management back to ifup and see what that does when you go back Gnome.

Thank You,

I solved the problem but I don’t know how. I ran package manager in KDE and looked for gnome related network apps that hadn’t been installed. I chose some along with some other items (can’t remember). When I logged back into Gname - “it just worked”. The Display Settings Icon also displayed correctly (instead of having a little red cross in it). The network manager connected effortlessly and a whole slew of programs showed up (which YAST previously claimed as “unisntalled”).

I don’t know whether I installed something crucial or if something else changed coincidentally. Anyway… it all works now. I wish I had a better explanation?

You can not argue with success, however it might occur. Happy to hear you got GNOME up and running.

Thank You,