Install from USB, can't find USB source?

I installed Leap 15.1 by USB on my old Lenovo T420 a while ago, which worked with no problem. Today, I wanted to upgrade to Tumbleweed.

I downloaded the full ISO and created a bootable USB stick, and the BIOS boots from the USB without problems. The graphical intro screen appears and I can select “Installation” or “Upgrade” from there. But then (after what looks like hardware detection) it wants me to give the source of the repository - offering hd:, cd:, Network and a Tumbleweed URL. I was expecting the repository to come from the USB, but that option isn’t available. It is also suspicious that the installer is using a basic text interface rather than the GUI.

I tried plugging the same USB into a more modern machine, with the same result.

There is a “Source (F4)” option in the installer intro screen, but again that does not offer me a USB option.

Am I doing something wrong? :frowning:

Very likely. But you have not told us what you did, so we cannot tell what went wrong.

So how did you create that USB installer?

NOTE: I have experimented with various ideas for a multi-boot USB. And it always ran into the problem that you describe when I included the installer DVD iso in that multi-boot setup. But when I directly copy the iso to the USB, I never run into that problem.

Thanks for the reply.

I directly copied the ISO directly to the unmounted device with “dd”, which I think I did before for Leap 15.1

dd if=openSUSE-Tumbleweed-DVD-x86_64-Snapshot20211227-Media.iso of=/dev/sdb bs=512 status=progress && sync

I always use SUSE Studio image writer (install it from standard repos) for writing the image to USB-stick for Leap/TW images. Checksum should be checked after download…

I forgot to mention that I did verify the checksum on the ISO.

Thanks for the idea. I’ll give that a try…

That should have worked.

I normally use “dd_rescue”, which does about the same but with a larger blocksize so better buffering.

I install using the NET installer by downloading only linux and initrd from and loading them with Grub, appending network configuration according to to the grub linu line, e.g.:

install= hostname=myhost ifcfg=*=",,,"

This way if there is a network issue, I haven’t lost a lot of time on downloading, finding an available stick to burn to, and burning, plus booting starts fast, almost like a normal boot, and only the latest packages get installed. I don’t download 20211224 only to find 20211227 is already on the mirrors by the time I’m ready to install.

I’m afraid writing the USB with that tool gives exactly the same result.

Might the problem be with the USB stick I’m using? It’s a TDK 8Gb that I’ve had for a while. I’ll try another, if I have one large enough(!)

I used bs=512 because I noticed that fdisk listed this as the max/optimal block size for the device.

I’ve just tried “studio imagewriter” to re-write the USB, but it’s the same behaviour.

I’m not sure what else I can try :frowning:

Thanks - I may yet be forced to use a network installation, but it’s a pity we can’t get a USB stick to work.

I’m downloading the iso right now. I will give it a try soon.

Using dd as you did is fine. From all other methods you may hope that they do the same as dd (which is often the case with the correct parameters, etc.) but why using them when dd is fine.
And you report that it boots, thus I doubt very much that you copied it the wrong way.

So we should concentrate on the detail of what happens then, like the message you reported.
Or we give up and point you to e.g. the net installer. But that is in fact giving up without knowing what is going wrong.

OK, that will be an interesting test, thanks. Mine has the following checksum:

> cat openSUSE-Tumbleweed-DVD-x86_64-Snapshot20211227-Media.iso.sha256
ca9b0b3daae8f2148687bb934d4deaed3ab6f81f571d6f1ee4b525c4111280f2 openSUSE-Tumbleweed-DVD-x86_64-Snapshot20211227-Media.iso

I’m currently trying to use a different USB stick (taking a while… doing a backup).

Some good news!

I just copied the ISO image to a different USB stick (a Verbatim stick, if it matters), using the SUSE imagewriter again, and this time it worked perfectly. It didn’t offer “USB” or anything like that as the source on the intro page (ie. the F4 menu), but when it reached the end of the first stage of the kernel booting (I think) it correctly detected the screen resolution, flipped into a nicer (green) mode and completed the hardware detection with a progress bar. Then it switched to the usual SUSE installer GUI in the normal way.

Very strange. Maybe the TDK stick is faulty in some way? Or perhaps some sticks are more bootable than others?

So many thanks for the suggestions. I’ll confirm when Tumbleweed is installed fully (probably tomorrow though).

It might also be a limitation of your BIOS. I remember, some time in the past, that I had an older computer where I always had to tell it where to find the source.

For my own test: I downloaded the iso, and used “dd_rescue” to copy it to a USB drive (San Disk 8G).

I booted into the installer. I did not actually install, but I went far enough to be sure that it found the onboard repo. (I went to the software selection part to be sure of that).

Everything worked. This was with UEFI booting. I then tried with legacy booting, and again, it worked.

As an experiment, with legacy booting, I used F4 to tell it the source. I told it “/dev/sdb” (and, and a separate try, “/dev/sdb2”). And that ended up with an installer internal error. So it looks as if there is a bug. I will file a bug report shortly, and post the bug number here.

Filed a bug report: Bug 1194147

I assume a strange combination of USB-port and USB-stick as the source of this problem, which can not be reproduced/resolved easily. I saw strange things in this regard.

((Most recently I tried to boot a raspi from USB-stick, which worked fine with Raspi OS, but with TW I tried several time (5-7 times, fresh downloads and re-writing the USB-stick included) I managed only once to get it to boot, logged in via ssh, changed some settings and subsequently the USB never booted again.))

I tried the same stick on a much more modern machine/BIOS, but it was the same. And the working stick worked perfectly on both (at least as far as getting to the GUI). But yes, the T420 BIOS is quite old.

I’ll try a full TW install today.

Thanks again for the time you’ve spent on this. I saw the bug, so hopefully some good will come of the investigation.

And perhaps a change between the drivers on an older Leap 15.1, which were able to boot from the stick, and the new TW which cannot?

If there are any diagnostics or detailed description of a stick, once connected, it would be interesting to look for a difference between the two sticks? But I don’t know enough about USB drivers and tools to know what is available.