Initrd stops boot

I am trying to install 11.4 into my “lifeline”, which is no big
shakes. CPU is an intel dual core 64 bit, video is a slow Intel 945G
chipset. I’ve been using, happily, 11.2 since it came out and 11.4
loaded fine. However when I try to restart it after playing on the
desktop, it seems to boot through grub (btw, Suse is the only thing on
it) and I get hung up as follows:

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
Kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-
-19HBC0_WD-WMAL72990746-part2 resume=/dev/disk/by-id/ata-
-WMAL72990746-part1 splash=silent quiet vga=0x31a
[Linux-bzImage, setup=0x3800, size=0x454060
Initrd /boot/initrd-
[Linux-initrd @ 0x37522000, 0xacd3cd bytes]

And there it hangs in the wind. Now I am not the sophisticated Linux
user, and I hope someone on this forum is, because anybody’s advice is
appreciated before the fact.

At first I thought it might be video, but it looks like its already
there. Then I thought it might be multiple kernels or
something…whatever, I am not sure how to fix this, and my life is
on that computer right now.TIA


Did you check the integrity of the media you used before installation? How did you prepared the partitions ?

Yes, sorry I didn’t add that. I verified the media twice and used two seperate installation disks. ISO downloaded directly from this site. I’ve installed several times with the same result. Both desktops have also been chosen with the same result.

Do you have RAID in your system ? Did you use the custom partitioning option when you installed it?

I do not have a RAID, and on the only disk I have I did use the suggested partioning, not the custom.