Incorrect display of the desktop on the monitor


I installed openSuse Tumbleweed, KDE on my laptop. I connected the external monitor via VGA. In the system settings, I chose - the external monitor is the Main, the laptop monitor was turned off. The bottom panel is not displayed on the monitor screen. In Arch linux, with the same problem, I created a file: ~ / .xprofile in which I wrote the following:

xrandr --output VGA1 --mode 1920x1080 --primary
xrandr --output LVDS1 --off

and the problem was solved.

Here I also created this file, wrote:

xrandr --output VGA1 --mode 1920x1080 --primary
xrandr --output LVDS1 --off

but the problem is not solved. Launching from the console also does not produce a normal result. The laptop screen is off, the external monitor has a blank desktop with no bottom panel.

What could be the problem?

Thanks in advance


I don’t know if it is relevant, but KDE settings under Wayland does not have a primary monitor checkbox. And under Wayland the only current way to force the panel onto a particular monitor is to find ScreenConnectors definitions in $HOME/.config/plasmashellrc and then find panel in $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc and change the panel’s lastScreen= to the desired value from the ScreenConnectors definitions. Perhaps that might help with X11 too. Originally discussed here:

Another thought is that under X11 I set my primary monitor via KDE System Settings with all screens enabled and that works, the panel is on the correct screen (I am using a desktop PC with two fixed monitors, so perhaps that works differently).

Wayland+KDE is a work in progress use X

The two config files mentioned in relation to Wayland also seem to be applicable for X11, they might be worth looking at if similar problems are encountered for X11.

While Wayland is arguably “not ready”, neither KDE X11 or KDE Wayland seem completely ready for monitors of different resolutions, nor for monitors that may be physically on/off/removed on the fly.

Can depend on the GPU. Is this an Optimus machine Intel+Nvidia??Не-правильное-отображение-рабочего-стола-на-мониторе

inxi -Gxxxz

Device-1: Intel 3rd Gen Core processor Graphics vendor: Acer Incorporated ALI
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GF108M [GeForce GT 620M/630M/635M/640M LE]
vendor: Acer Incorporated ALI driver: nouveau v: kernel bus-ID: 01:00.0
chip-ID: 10de:0de9 class-ID: 0300
Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-4:4
chip-ID: 04f2:b335 class-ID: 0e02
Display: x11 server: 1.20.13 compositor: kwin_x11 driver:
loaded: intel,nouveau unloaded: fbdev,modesetting,nv,vesa alternate: nvidia
resolution: <missing: xdpyinfo>
**OpenGL:**renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.1.6
compat-v: 3.0 direct render: Yes

Laptop model is requested.

Use code tags: # button.

Try this:

In Plasma session,

goto systemsettings5 (Personal Settings/Configure Desktop) →

	Startup & Shutdown →

		Background Services →

			Deselect KScreen 2 →

				click Apply

This should stop Plasma from messing with screen/display setup.

Next, log out of Plasma, then from any other type of login:

  • rm ~/.cache/*
  • remove any directory whose name contains the string “kscreen” from ~/.local/share/
  • put your xrandr script in /etc/X11/xinit/xinitrc.d/, if you want it to apply to all users and all X session types
    *]try Plasma