Incessant Software Repository issues

I’ve installed openSUSE 10.3, 11.1 and 11.2 and 11.1 server many times in the last 3 months and consistently have the following problems both during the initial installation and/or after the installation:

  1. Registering for the updates in the advanced option often fails with a retry request.
  2. The initial updates during installation constantly require retries requiring constant interaction. Thus, I no longer perform updates during the install. However, once I perform the updates after the installation, the retries are often numerous. I do have good network connectivity and name resolution, plus all other distos I have tested easily update. Often, the retry does work and the update refreshes. I am not sure what enable vs enable-autorefresh provides. Should autorefresh be checked?
  3. I often cannot install new software.
  4. I have removed the ending slash of the url’s which seems to help - sometimes (found this in one of my searches). However, every time a slash is removed, yast tries to reconnect to the repository, slowing the url edit operations. This is particulary annoying with an ssh connection to 11.1 server without X using yast instead of yast2. At the moment I was totally unable to get software to build a kernel on 11.1 server.
  5. I have often abandoned openSUSE multiboot lab testing environment to use different distros.
  6. I disable use of the CD/DVD as the installation DVD is usually not in the server.

I presume there is a configuration file for the software repositories where we can edit the repositories outside of yast or yast2 in order to avoid the timeouts when yast cannot reach the repository files while editing the repositories. I cannot find this file, though my searches indicate it may be an xml file.

I am about to totally abandon openSUSE because of this problem. When it is working, suse is my favorite distro. However, I have wasted many many many hours on this issue.

I would suggest that someone create a sticky post that remains at the very top of the application forum providing a step by step way to alter the repositories, if this is what is needed. I suspect that the repository mirrors, etc may be part of the problem.



openSUSE online updates suck beyond belief. What the heck is the problem. I finally got them to work, but I believe it is because the repositories started working about 8:00 PM. Read on before you decide to ditch Windows or another distro for openSUSE. openSUSE rocks without the update and software management problems. But, heck without software management, what good is it.

I finally got my Dell T300 with openSUSE 11.1 Server to update using yast via ssh. Once I removed all the repositories and then reinstalled them, I was able to perform online updates. I did have to remove the “/” at the end of the url’s. Even so, I had to perform 53 retries during about 80 updates over a period of nearly two hours. That doesn’t include 6 hours of fooling with yast, not yast2. At the 50% download which was at 8:00 PM Central Time, the updates progressed quickly without any additional retries required. I believe the problem is with the repositories.

Below is a description of my trials and tribulations with openSUSE Online Updates.

This is the list of default repositories, after I had removed the last “/” from them about 2 weeks ago. Notice the two identical update repositories. One was named “Update” and the other “Updates”:

Index of /debug/distribution/11.1/repo/oss yast
Index of /distribution/11.1/repo/non-oss yast
Index of /distribution/11.1/repo/oss yast
Index of /source/distribution/11.1/repo/oss yast
Index of /update/11.1 yum
Index of /update/11.1 yum

Here’s what you can do to duplicate my efforts:
ssh to the server and log in
open a terminal and resize the terminal window larger either now or later after starting yast.
su -
Start yast, select Software in the Yast Control Center if it is not already selected. Then hit tab or right arrow to get to the right window. Then use the down arrow to select Software Repositories and hit enter to go to “Configured Software Repositories”.

If you haven’t already done so, resize the terminal window after getting to the repository window, so that you can see the entire url of the repository when the repository is selected, and also so that you can see the OK button in the bottom right. Otherwise you will not be able to save the configuration without the OK button as the F (function) keys often don’t work via ssh. The contents of Yast will expand in the enlarged terminal window as soon as you tab or click the up or down arrow.

At this point I disabled repositories and autorefresh, planning to just re-add them in case they consisted of invisible characters, etc. However, it appeared that they still tried to refresh when I added the new ones by copying and pasting from the repository web pages. So, I just remove all of them, except the DVD drive.

Go to Package Repositories - openSUSE
Midway down page are the Official Repositories for 11.1, 11.0 and 10.3 for Oss, Non-oss, Update, Src-oss, Src-non-oss, Debug, Contrib, KDE, GNOME, JAVA. I went to each page in a browser and then copied the url from the address bar.

In Configured Software Repositories, tab to add,
Select http
Uncheck “Download repository description files”. I had problems until I unchecked this.
Tab to [Next] and press enter
On “Server and Directory” page, tab to “Edit Complete URL” and press space bar.
Tab to “URL of the Repository” and then copy and paste the URL from the browser on the local machine.
Tab back and name the repository the same as the last directory in the URL such as “Oss” I tested with and without the end “/” and determined that it should be removed.
Click next.
I would often get “Cannot access installation media.” at this point. I then clicked “retry” several times. When this doesn’t work, which was often, I’d click “Abort”. Oddly, this occasionally worked, or at least the repository was added to the list. Clicking “Details” will show something like “Download (curl) error for 'http://download.opens”. You will not be able to see the entire url via ssh and yast. The next line will be “Error code: Connection failed” and a third line “Error message: Couldn’t resolve host 'download.o” Clicking “Abort” will bring up a “downloading” window just like the “retry”. It is as if “abort” does exactly the same a “retry”. If you have to click on “Skip”, the repository will show up in the Yast list of repositories in the “Configure Software Repositories”
I had no problem with the “Contrib” repository, but I did with the others.
After installing all the repositories I wanted, I enabled all of them. I then set one to autorefresh and then tabbed to refresh and selected “Refresh all autorefreshed”. This way I was only refreshing one repository at a time, making it easier to troubleshoot. I then “retried” until the refresh appeared to be successful. I then disabled Autorefresh for the successfully refreshed repository, set another repository to Autorefresh and then tabbed to “refresh” and again selected “Refresh all autorefreshed”

After each repository gets added properly, exit yast so it gets saved. If yast is aborted while adding addition repositories and you haven’t exited since adding previous repositories, the previous repositories will not be saved and will be lost.
Uncheck enable and Automatically Refresh of the most recently added repository before adding another repository because the previous repositories will try to refresh which is time consuming.

After all repositories were added and refreshed individually, I set them all to enable and to “not” autorefresh.

I then ran “Online updates”. There were about 80 of them. I had to retry numerous times, but each time the percent went up. Had to retry several times for these two"

I then had problems with many retries: Each entry below includes the number of reties:
6 - Downloading delta RPM ./rpm/x86_64/
9 - Downloading delta RPM ./rpm/x86_64/
Then got the message: “Packages for package management were updated. Finishing and restarting now.” Click ok.
Then got the message: “At least one of the updates installed requires restart of the session. Relogin into your system as soon as possible.”
Restarted and updated again - about 70 more updates or only 10 of previous updated.
9 retries for various updates
8 - Downloading delta RPM ./rpm/x86_64/libtalloc1-3.2.4_3.2.7-5.2_11.3.2.x86─
6 - Downloading delta RPM ./rpm/x86_64/xorg-x11-libxcb-7.4-1.28_1.29.1.x86_6─
43 retries at 28%
At 47% updates proceeded quickly from about 8:30PM Central Time to 8:36 (6 min) without any further retries. Started about 7:00

Message: “At least one of the updates installed requires a system reboot to function properly. Reboot the system.”

Finally the following worked which didn’t about 10:00 AM today:
yast -i ncurses-devel

Now I can try a kernel rebuild after a whole day. Note the time of this post 10:20 PM compared to my starting post this morning.

I have a very good Internet connection. Software downloads are flawless and fast including many ISO downloads. One variable, I have a wireless bridge between the server and the access point. I have had no problems with other distro software management on this multboot server.

In which country are you currently ?

I am in China and sometimes experience timeouts for OBS repositories (not the main ones), especially for big installs and big files, and need to retry many times.
My workaround is that I found a mirror from Taiwan and set it up as default.

In fact, the default URL,, will redirect you to a nearest mirror. Have a look at this page: openSUSE Download Mirrors - 11.1

Then click on an HTTP/FTP link, then navigate until you get an URL that end with “/distribution/11.1/repo/oss/”.

You can then go to yast and add that URL as OSS repository, and disable the original OSS repository one. This way yast will only use the repository mirror you provided instead of redirecting you each time.

If your having issues like that don;t use the redirector just find a
mirror that is close and change for the mirror.

Have a read here
For the full list see here

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 Milestone 6 (i586) Kernel 2.6.31-rc7-4-desktop
up 8:09, 2 users, load average: 0.01, 0.02, 0.01
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I was typing my answer while you sent your second post.
What I mentionned will work for the base repositories. For the secondary repositories like Java and KDE, they might not be present on all the mirrors. I was lucky to find a mirror that has them.

You need to look at the OBS (openSUSE Build Service) list then

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 Milestone 6 (i586) Kernel 2.6.31-rc7-4-desktop
up 8:39, 2 users, load average: 0.28, 0.13, 0.10
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

> I would suggest that someone create a sticky post that remains at the
> very top of the application forum providing a step by step way to alter
> the repositories, if this is what is needed.

good suggestion…

except it is already there as post #5 in the comprehensive but compact
getting started thread which is number one
sticky in the Install/Boot/Login forum…

and, available via reference in discussions a few hundred times in
these fora–easily found with either the forums search engine or Google…


I also wonder if this is country and/or ISP dependent. I do not see such issues here in Germany.

One thing you could try, during your install, is to DISABLE ipv6 when given that selection offering. That “might” reduce the number of interactions/retries.

Thanks for the replies. ipv6 was enabled. On systems with X Window I do disable it, if I forget during installation. This server doesn’t have X Windows, so I had to search how to disable ipv6. Is Linux system administration possible without Internet connectivity and search engines?

I first determined if it was enabled.

#lsmod | grep ipv6
ipv6 292488 26

Found this cute script which worked:

-f /proc/net/if_inet6 ] && echo ‘IPv6 ready system!’ || echo ‘No IPv6 support found! Compile the kernel!!’
IPv6 ready system!

I then disabled ipv6 per:
SDB:Disabling IPv6 completely - openSUSE

I now have to restart my server via ssh while in the local cafe in St. Louis, MO USA. The restart will be a while, as I have the MBR grub menu.lst set to a long default timer before selecting openSUSE 11.1 server via chainloader.

In the mean time I’ll check Platinum’s links. My searches on this issue found thousands of hits with many suggestions. Apparently I need to further refine my searches. I’ll use Platinum’s link to reverse engineer a search criteria that may help me with future searches. From my long posts, you can tell I worked hard to solve this problem. I copied and pasted my 10 hour operation into gedit on the local machine running CentOS release 5.3 and then copied the entire document into this forum. That’s why it was a bit unreadable. My laptop has nine distros and I just happen to be testing Centos these last few days. Wireless rocks on all linux distros I’ve tested.

Well, my server is up and running again.

t300:~ # -f /proc/net/if_inet6 ] && echo ‘IPv6 ready system!’ || echo ‘No IPv6 support found! Compile the kernel!!’
No IPv6 support found! Compile the kernel!!
t300:~ #

Maybe I’ll reinstall two more openSUSE 11.1 servers in two additional partitions, one with and one without ipv6, and see how the online updates work here in St Louis via Charter Cable. Perhaps I should just use the update repository when testing. From what I interpreted from what I’ve read, we should only use one repository for online updates. It is difficult remembering which operations apply to which distos.

Hey, this forum interface works so well. During all my long posts, the Preview and Submit action works so smoothly. It is so frustrating on some other forums that I have time out issues, etc, and I have to be sure (I do anyway) copy and paste my writing before submitting out of fear I may loose all my work.

Keep in mind that all I did between about 6:30 and 8:00 PM CDT was hit enter at “ok” and “retry” while watching cable TV and then suddenly at 8:00 PM within a minute or two, the last 50% of the updates proceeded to complete in less than 6 minutes without requiring any retries.


  1. My wireless - maybe, but in the past 3 months openSUSE updates were always problematic, especially during installation with many “retry” responses. I didn’t have this problem with other distro updates, nor with many iso downloads via linux and Windows using Firefox and wget. I probably installed SUSE a dozen times the last 3 months, as I like its documentation and GNOME interface the best. I also like the server install without X Window. It just those darn software repositories, or so it appears.

  2. Charter Cable - ditto

  3. Repositories - Probably, but not definitive. Is openSUSE more popular than Fedora, Centos, Debian, Mandriva, Ubuntu (I can’t include Gentoo as it wouldn’t even install on my Dell Latitude D600, Slackware because it doesn’t have online updates from what my seaches turn up, and freeBSD because I can’t figure out how to use its partitioning software “slices” such that is doesn’t destroy my other 13 distro partitions)? So, is openSUSE/Novell dealing with much more update and software installation traffic? By the way, Slackware’s virtual terminal freezes both my Dell T300 and D600 and I haven’t even searched this issue along with dozens of other linux things I’ve encountered.

openSUSE repositories are known to grind to a crawl when the GM version of a new openSUSE version is released, … and they can be slow for a few days to a week after that.

This is not the case now.

On occasion the automatic transfer to mirrors can fail. But I have not seen that for a while.

Did the disabling of ipv6 help?

I don’t know if I will know right away if disabling ipv6 will help. Last night after 8:00 PM with ipv6 enabled, I was able to download gcc and other software along with a kernel package, so I could build a kernel the “SUSE way”. I may install two partitions of SUSE 11.2 Server. Then I’ll update one of them and then quickly reboot and update the other to see if ipv6 is the issue. I’ll remove all repositories except the update repositories, as I suspect this may be the problem repository.

I still think a good stickey at the top of the “Install/Boot/Login” topic and the “Applications” topic on discussing this issue would be advisable. I would think anyone installing any openSUSE version will encounter this for one reason or another, and if not during installation, then later during future updates and software installations. Just removing the “/” at the end each link is frustratingly slow, as some kind of refresh/download begins, then a long time out period, then a “retry” or two, an “abort” or two and a “skip” to be repeated all over again with the removal of the next “/”. I’m still not sure we have to remove the “/”, but it did seemed to help. The step by step stickey guide could include yast and yast2 as well as command line operations and/or file editting to accomplish all this during installation and/or after installation.

Excuse the off topic point, but try this out if you’re using firefox.

I have the " / " in place, and here in Germany (where there are MANY mirrors) I obtain incredibly fast downloads. The downloads typically max out right at the peak of my high speed download of 16.0 Mb/sec.

I installed 11.1 in partition sda12 with ipv6 disabled and in sda13 with ipv6 enabled. I disabled the firewall on both installs and used the “Traditional method with ifup” network setup method, the default.

I tried using static ip, subnet, gw, dns with the sda12 install, but the “Test Internet Connection” failed. I tried several times.

So, I tried dhcp for just the ip leaving gw and dns static. This time “Test Internet Connection” succeeded. It’s possible there is a arp cache problem with, because I use this same ip address for all the distros on this multiboot system. However, I don’t think that is the problem based on the sda13 installation, plus the time it takes to install a server would time out an arp cache entry, etc.

After the “Test Internet Connection” succeeded, I had to “skip autorefresh” to get passed the “refreshing repository” with a message "Cannot access installation media (medium 1) Index of /update/11.1. At this point I could edit the link, so I removed the end “/” but that didn’t help.

I then installed on sda13 leaving IPv6 enabled. This time I allowed DHCP to assign everything. The “Test Internet Connection” required three retries before success.

I then got the Cannot access installation media (medium 1) message with Refreshing repository repo-oss. I performed 11 retries before selecting “skip autorefresh”. This time I got a screen giving me the option to “Run online updates”. I did not get this screen on the sda12 install. I selected “skip updates”

This last install took only 31 minutes to get this far. I am going to configure both servers for static ip, edit the grub menu.lst with chainloader and test booting the systems, use yast to remove all the repositories except the update repository, and then click “ok” and “retry” for sda12 and then immediately reboot to sda13 and do the same. I’ll submit my results.

captain0 wrote:
> Is Linux system administration possible without Internet
> connectivity and search engines?

silly question! :wink: the internet is always available and search
engines are a Gawd Given Right!

or so we could wish…

happy you found/fixed the problem…and HEY! if you have some time to
burn, check in from time to time and lend a hand/help out…yours is
the kind of REAL WORLD experience which could prove very helpful for
the more advanced Qs which sometimes come (most problems here are from
new guys and therefore common/repetitive–you should probably skip
those…but,) we often need the depth of understanding you obviously

you might consider peeking in via nntp, which makes it MUCH
easier/faster to scan subject lines for interesting, challenging,
educational hunts…

more on hitting the forum via nntp at:
come back often…welcome!

ps: i think the naked truth is that in the Linux Administration World
no man is an island fully self-sufficient [just FAR too much to know,
especially since the set of “required to know” is infinitely &
incessantly expanding]…

if it hasn’t yet it will happen to Island-Man that lacking net access
and/or google the administrative task at hand just has to wait…then,
wait, it will.



The two new openSUSE installations in partitions sda12 and sda12 are ready for the online update test. I thought I would wait until about 9 or 10 AM Tuesday to test the updates, when the online update repository is busier. All repositories are removed from yast, except the update repository. IPv6 is disabled in sda12, and it is enabled in sda13.

If possible I want to duplicate the problem I had Friday morning and early evening. I may go as far as installing Wireshark, if I know I can duplicate the problem. I’ll use Wireshark when I add back the default repositories, one at a time. I haven’t used Wireshark with Linux yet, though often in Windows.

As soon as the hardware arrives, I am building a production Web server for a client and will have a few weeks to tinker with it. We will move their web content from the test web server on Windows XP with Apache and Tomcat to the new hardware. I plan to install an evaluation edition of Windows 2008 Std Edition with Hyper-V. I also plan to install one Linux distro for dual booting with Windows 2008, also with virtualization software. So far I have only tested Sun’s Virtualbox on Linux but have a good deal of experience with Hyper-V and Virtual Server. I plan to create numerous VM’s for testing in both environments. I have come to appreciate ssh command line administration which would negate the remote desktop problems that occur with VM’s.

I would be happy to share my experience with this, as well as get advice in this forum. Initially I’ll be posting a lot of questions, such as will Apache Tomcat web content on XP function without problems on Linux Apache Tomcat. If you think it would be a good idea and helpful to everyone, how would you suggest I begin the posts. Of course, we still don’t know how well the XP Win32 Apache Tomcat will function on Windows 2008 x64.



The system that I had problems with Friday has been working great since 8:30 that evening. I have installed a considerable amount of software since 8:00 on Saturday and Sunday without issue. However, it has been a Labor Day weekend here in the USA, with probably much less Internet traffic for the repositories.

captain0 wrote:
> However, it has been a Labor Day weekend here in the USA, with
> probably much less Internet traffic for the repositories.

you may not realize that many of the repos live on university,
government and benefactor hardware…

remember, this is free openSUSE…we have practacly no any big
corporate servers dedicated to holding and dispensing softwared,
updates, etc…

see the list of repos/mirrors here:
and, don’t miss the chance to scroll down…

and one other thing some/many/all of those schools/governments and
benefactors throttle down our access to the repos to give their own
folks needs higher priority…which make sense, since they are GIVING
us the space and bandwidth…

they probably removed the chokes over the long weekend…

Give a hacker a fish and you feed him for a day.
Teach man and you feed him for a lifetime.

Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

This is now my favorite link concerning repositories:
Add Package Repositories to YaST - openSUSE

This is probably the most useful tip from that web page for an openSUSE server without X Window:

You can add repositories to YaST with the Zypper command line interface.
The syntax is:
zypper ar <URL> <alias>

I’ll try this later today. I am hoping this is a solution to the “retry” situation that occurs based on the next point below.

This quote from that web page may explain my biggest problems with installing openSUSE, adding and editing repositories, and maybe even starting the yast software application.

Package metadata will be downloaded and parsed - this takes time depending on mirror speed, your bandwidth, the size of the repository, the speed of your system.

For instance, when I removed the end “/”, I often got a downloading message and then the “retry” option. Same whenever I re-added each repository after deleting all of them. I assume this was do to package metadata. I don’t recall the downloading message indicating it was metadata. I presume metadata downloading and refreshing may be different operations

One thing about linux mirrors in general, they often don’t provide anything but the name of the university or other organization. In the USA, it is not easy to determine which one is closest, requiring web searches and then probably running traceroute. It would be nice if more included names of cities and states.

Of course, when someone installs their first openSUSE during the day in the middle of the week, they won’t know about all this. That is why I suggested a well written sticky. I realize it is easy to suggest, not so easy to write.

I my previous posts, I stated “yast not yast2” trying to distinguish yast without and yast with X Window. From this web page, I realize I should have written “YaST-ncurses”

I’ve been testing several distros. I am not sure which one recommended not using mirrors for “online updates”, as the mirrors may not have the most current updates. This would seem like good advice for all the distros.

Just before sending this post at 10:00 AM DTC, I ran online updates and reregistered my original server that had been updated Friday with great difficulty. It went very smoothly just now. I’ve yet to run the first updates on the two new installs which I plan to do shortly.