Impossible to Install VMware Player 16.1.2 in Tumbleweed - Kernel 5.12.4-1-default

Hi everybody,
I have a serious issue when I try to install the new VMware Player 16.1.2 yesterday morning.

The installer uninstall my 16.1.1 version then try to install the new and fail… Just with this message :

Extracting VMware Installer...done.
Installing VMware Installer 3.0.0
Copying files...
Installing VMware Player Setup 16.1.2
Copying files...
Installing VMware USB Arbitrator 19.9.1
Copying files...
Rolling back VMware USB Arbitrator 19.9.1
Removing files...
Uninstalling VMware Player Setup 16.1.2
Removing files...
Uninstalling VMware Installer 3.0.0
Removing files...
Installation was unsuccessful.

I’m running OpenSuse Tumbleweed with the 5.12.4-1-default kernel

Seems to “stop” the process on installing the USB arbitrator … I don’t know “who is” this USB Arbitrator…
Do you have any idea ?
Actually I’m in pain because the previous VM was uninstalled by installator…

I have posted this message on the VMware Workstation Forum ( and I have seen at least one guy in the same situation.

His message with a lot of informations in console is visible here :

He also answer me he had same problem of USB detections previous of this problem.

One hint I suspect is that the new update of OpenSUSE eliminates the legacy ‘chkconfig’ for installing startup services, in which VMWARE still relies, So I had to start manually the vmware.service and before starting the virtual machines. Then the USB periferics worked well.

So, I’m here because I don’t know how to inform the Kernel’s developpers of Tumbleweed about this serious problem…

Thank you very much for the help
Best regards

Philippe (From France … So apologize for my Frenchglish language…)

That really is a vmware player issue (it’s not like systemd is new…), ask the poster to provide the systemd service files they used and implement on your system?

As I have posted numerous times over the years,
The most common cause of any VMware product installation on Tumbleweed has been VMware’s stable code compiled with Tumbleweed’s bleeding edge compiler.
This is easily addressed by installing an older C compiler and then setting up an Alternatives to easily switch between the compilers (When you install additional compilers, they are side by side but by default you have to manually create the links to use or if you’re compiling your own code you can specify the compiler in your manifest. Since the VMware install doesn’t allow the User to modify the install manifest or otherwise specify a compiler, this option is not available).

I’ve accordingly posted an easy solution to set up Alternatives for gcc

Should fix this and any other similar problems.


Its an problem with checkconfig:
There is also an workaround mentioned.

Hi All,

Seems there is not one but more problem with VMWare 16…

Before update from 16.1.1 to 16.1.2 I had a problem with the USB unrecognized.
Run in root the commands below fixe the problem but it’s labile and I have to do that every time I start VMWare

systemctl start vmware-USBArbitrator 

The, with the update came a major problem because I can’t install the new version and the Installer uninstall the “old” VMware (16.1.1) … Result the VMware was gone…

I have found on another forum the workaround below :

./VMware-Workstation-Full-16.1.2-17966106.x86_64.bundle --ignore-errors

Add the option : --ignore-errors make the installer to run and finally the new version of VMware install succeffuly.
But… The problem with USB still here and I have always to run the command : systemctl start vmware-USBArbitrator

I have no competency to understand and explain what occur, I think mean be there is two problems, one coming from OpenSuse TW (compilation) one may be VMware ? or again some lib or dependency missing … ??

Actually with all this workaround I can use my VMware when I need but it is not “elegant”…

Hope this will help
Best regards

Have you tried this one:

Yes, and also on VMWare Forum
And I just posted the summary in the 3 forum may be it’s can help


Since I’m considering migrating to Tumbleweed from Gentoo in my laptop, I need VMware Workstation for my work. Seeing in Gentoo that there’s a vmware workstation ebuild (package) from a third party repository, I am wondering if there’s something similar in Tumbleweed. From the little I’ve read so far, I understand that no such package exists, so the user must manually install it. Is there a guide somewhere for this? Is manually installing the software trouble free for Tumbleweed?

Hi GoofyX,

I don’t know about Gentoo but seems to be very different from Opensuse that’s own package system use rpm.
It is not really difficult to install RPM packages, just one command in root… Like “rpm -ivh name-of-the-package.rpm” (just an exemple…)
So, I don’t know the reasons why you want to migrate to Tumbleweed but you have to know before that Tumbleweed is a rolling release and despite it’s stable you have to solve regurlaly some problems with third party softwares like Nvidia proprietary drivers or VMware.
If you want to migrate to an Opensuse stable version you have to choose Leap and normally you will decrease dramatically the third party softwares problems.


Hi Philippe,

Thank you for your answer. Yes, I already know about rpm and the package manager that OpenSUSE uses (and I know Tumbleweed is a rolling distro, Gentoo is one of these too and that’s why I chose Tumbleweed as a replacement), I already have a Tumbleweed installation in a VM that I play with. From what I know, VMware workstation is provided with a .bundle package, which is not rpm, so, it’s outside OpenSUSE’s package management system. So, you have to install VMware workstation with what VMware gives you. Comparing with Gentoo, you just do a

emerge -v vmware-workstation

which takes care of installing the executable files and compiling the necessary kernel modules in one step (and checking of course the dependencies before all that). That’s why I asked about the existence of a OpenSUSE specific package (rpm) for VMware workstation, one that takes care of everything.

1 Like

Yesterday I installed Tumbleweed in my laptop, migrating from Gentoo. I will try to install VMware Workstation using the package they provide, but I don’t know if this will work or not.

Hi GoofiX,

At this time I have Tumbleweed with the 5.14.14 kernel and the Vmware Player 16.2.0 build-18760230 version.
After upgrading Kernel, I had (as usually and as demanded by VMWare) compiled the VMON et VMNET …
First start it’s always OK but after shut down the host end/or VMware, the next time I want want to start VMware I get an error :

Could not open /dev/vmmon: Aucun fichier ou dossier de ce type.
Please make sure that the kernel module `vmmon’ is loaded.


Failed to initialize monitor device.

But there is a workaround…
This is not very “elegant” but you can apply the code below and it’s working (great thanks to Mkubecek) :
tar -xzf vmware-host-modules-workstation-16.2.0.tar.gz
cd vmware-host-modules-workstation-16.2.0
sudo make install
/etc/init.d/vmware restart
systemctl start vmware-USBArbitrator

For more convenience I have downloaded the modified modules into a directory and as long as the VMware version don’t change I can apply the “patch”.

Of course, after this, VMware work fine

Hope this will help you


Part of the problem for systemd users is that the workstation package does not provide service unit files. The Arch wiki page has a few service unit files which I guess can be used in our case here.

When I have more time, I will try them.

I have installed Workstation 16.2.0 from the bundle package that VMware provides. I’ve also found the Github repository maintained by mkubecek, cloned it locally and using the w16.2.0-k5.14 tag I compiled vmmon and vmnet modules. I installed them (make install) inside /lib/modules, but when I try to modprobe them, I get the error that they are not signed and fail verification:

   27.909935] vmmon: loading out-of-tree module taints kernel.
   27.909985] vmmon: module verification failed: signature and/or required key missing - tainting kernel

From a little search, I understand that I have to somehow sign the modules. How can I do this?

1 Like

I run

vmware-modconfig --install-all

from Workstation and it works fine. It compiles the modules provided by Workstation, although they differ in size from the ones from the mkubecek repository (top is VMware, bottom is mkubecek):

xxxx:/lib/modules/5.14.14-1-default/misc # ll
total 7380
-rw-r--r-- 1 root root 3832352 Nov  4 20:39 vmmon.ko
-rw-r--r-- 1 root root 3719968 Nov  4 20:39 vmnet.ko

xxxx:/lib/modules/5.14.14-1-default/misc # ll
total 328
-rwxr-xr-x 1 root root 215808 Nov  4 20:45 vmmon.ko
-rwxr-xr-x 1 root root 118032 Nov  4 20:45 vmnet.ko

I still can’t get any of those loaded…

I’m really disappointed, since VMware Workstation is a package I need desperately.

I’m not sure what happened today, but I updated the system (zypper dup), run

vmware-modconfig --console --install-all

and all worked fine…


1 Like