iFolder

Hi all.

Anyone out there having expirience with iFolder.
I’ve used the following tutorial: http://www.daniellench.com/2010/08/ifolder-on-opensuse-11-3/
to install it.
I used libflaim as a database (no LDAP).
All web interfaces work well (admin, ifolder).
I can create users and make folders.

But when I try to login with a desktop client (windows or linux) I get an error message invalid credentials and this message in Simias.log:

2011-02-08 09:31:24,744 -1320158352] DEBUG Simias.Security.Web.AuthenticationModule - In verify[rincipalfromrequest: soapmethod is GetDomainID
2011-02-08 09:31:27,804 [-1255158928] DEBUG Simias.DomainProvider - domainID 6d1d72d0-a102-41a8-80f4-ae47b8e9e3cf
2011-02-08 09:31:27,805 -1255158928] DEBUG Simias.Server.Authentication - Authenticate called
2011-02-08 09:31:27,807 -1255158928] DEBUG Simias.Server.Authentication - q?( is not member of simias
2011-02-08 09:31:27,826 -1238144144] DEBUG Simias.DomainProvider - domainID 6d1d72d0-a102-41a8-80f4-ae47b8e9e3cf
2011-02-08 09:31:27,827 -1238144144] DEBUG Simias.Server.Authentication - Authenticate called
2011-02-08 09:31:27,828 -1238144144] DEBUG Simias.Server.Authentication - q?( is not member of simias

Is there a tool to connect to the flaim database and view the records ?
I could find one.

Tnx.

Thanks for checking out my tutorial.

Does your username/password have 8 char? try 7 or 9, anything but 8

Can you check the exact version of the client in windows?
C:\Program Files\iFolder
RT click on iFolderApp.exe > properties >details tab
Make sure its 3.8.0.3 or higher
If its 3.8.0.0 you need to uninstall it, delete the simias directory in %appdata% in winxp or %localappdata% in vista/7

I have not seen a tool to browse the flaim DB and I really don’t want to.

On the server to enable debug logs, edit /etc/simias/Simias.log4net and change ‘INFO’ to ‘DEBUG’
Logs are found in /var/simias/log/Simias.log (or your path)

The same goes for the client, change the %appdata%\simias\Simias.log4net or %localappdata%\simias\Simias.log4net to ‘DEBUG’ and read the logs at %appdata%\simias\Simias.log (all windows versions)

best,
dan

Yep it is a client version problem.

Hi,

I need help installing iFolder. I recently installed OpenSUSE 11.3 (x86_64).

I am using this tutorial too: iFolder on OpenSuSE 11.3 full install walkthrough » daniel lench

one thing i noticed is that I don’t have a “simias” directory anywhere. Am I missing something? Anyway, I’m not finished installing yet. Just curious though. I’m quite new to this, so there may be some things I have to understand. Can anyone give me a tip or something about what to do and what NOT to do in installing iFolder?

Thank you.

I’ll post again here if somethings goes wrong. =)

-jhared

Hi again,

I got this following error after following the instructions under iFolder server setup.

I ran (in my browser): https://localhost/simias10 and got this errors:

System.DllNotFoundException: /usr/lib64/simias/web/bin/FlaimWrapper.so
at (wrapper managed-to-native) Simias.Storage.Provider.Flaim.Flaim4:FWCreateStore (string,intptr&,intptr&)
at Simias.Storage.Provider.Flaim.Flaim4.CreateStore () [0x00000] in <filename unknown>:0
at Simias.Storage.Provider.Flaim.FlaimServer.CreateStore () [0x00000] in <filename unknown>:0
at Simias.Storage.Provider.Flaim.FlaimProvider.CreateStore () [0x00000] in <filename unknown>:0
at Simias.Storage.Provider.Provider.Connect (Simias.Storage.Provider.ProviderConfig conf, System.Boolean& created) [0x00000] in <filename unknown>:0
at Simias.Storage.Store…ctor () [0x00000] in <filename unknown>:0
at Simias.Storage.Store.GetStore () [0x00000] in <filename unknown>:0
at Simias.Security.Web.AuthenticationModule.get_StoreReference () [0x00000] in <filename unknown>:0
at Simias.Security.Web.AuthenticationModule.VerifyPrincipalFromRequest (System.Web.HttpContext context) [0x00000] in <filename unknown>:0
at Simias.Security.Web.AuthenticationModule.OnAcquireRequestState (System.Object source, System.EventArgs eventArgs) [0x00000] in <filename unknown>:0
at System.Web.HttpApplication+<RunHooks>c__Iterator1.MoveNext () [0x00000] in <filename unknown>:0
at System.Web.HttpApplication+<Pipeline>c__Iterator2.MoveNext () [0x00000] in <filename unknown>:0
at System.Web.HttpApplication.Tick () [0x00000] in <filename unknown>:0

I ran https://localhost/iFolder and got this error:

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
Fri Mar 25 12:21:37 2011
Apache/2.2.15 (Linux/SUSE)

any help on how to install this succesfully?

Hi again,

Ok, so i successfully installed the iFolder sever, and when i ran https://localhost/ifolder, its bringing me to the login page, but as I logged in as admin, it says: The username or password you entered is incorrect. Please log in.

How can i set my username and password?

have you logged into the localhost/admin and created a new user? you also need to set the user’s home server and click save. after that you can login to the localhost/ifolder with the new user.

the user created in the simias-server-setup is the super user and can only login to the /admin side

best,
dan