icedtea-web

Long story short, I attempted to install oracle’s JRE and then tried to revert back to openjdk and have managed to hose up icedtea-web. If I try to open the settings I get the following:


/usr/bin/itweb-settings.itweb: line 42: : /usr/bin/itweb: integer expression expected
/usr/bin/itweb-settings.itweb: line 45: : /usr/bin/itweb: integer expression expected
/usr/bin/itweb-settings.itweb: line 204: /usr/lib64/jvm/jre/bin/java: No such file or directory

I guess it is still looking for the oracle version? What’s the easiest way to update everything to get all the settings back to where they should be? Not sure what else may have gotten messed up.

Thanks.

@z2:

Assuming that, the Oracle JRE has been installed via RPM (Zypper) and not, Flatpak, you’ll need to check the RPM consistency –

  • “rpm --rebuilddb”
  • “zypper verify”
  • “rpm --verify --all”

If you installed it via Flatpak then, you’ll have to walk through the Flatpak repairs –

  • “flatpak list”
  • “flatpak repair”
  • “flatpak uninstall «Oracle JRE
    »”

And, search for orphaned packages – “zypper packages --orphaned” …

That all looks fine. The main problem seems to be that it can’t find:

/usr/lib64/jvm/jre/bin/java

I currently have installed java-11-openjdk, although it is not in my PATH. Is it supposed to be in the above path, or somewhere else?

no java in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)

Update: all the rpm consistency checks have come back ok. Zypper thinks it’s installed, but I don’t have it in /usr/bin/java which I think is where it’s supposed to be?

Nevermind, I think I fixed it.

You can switch your java:

update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                       Priority   Status
------------------------------------------------------------
* 0            /usr/lib64/jvm/jre-11-openjdk/bin/java      2105      auto mode
  1            /usr/lib64/jvm/jre-1.8.0-openjdk/bin/java   1805      manual mode
  2            /usr/lib64/jvm/jre-11-openjdk/bin/java      2105      manual mode

Press <enter> to keep the current choice[li], or type selection number:[/li]```

Thanks. One more question: why is there no javaws with the icedtea-web package?

Which “IcedTea-Web” package did you install?


 > rpm -ql icedtea-web | grep 'javaws'
/etc/bash_completion.d/javaws.bash
/usr/bin/javaws.itweb
/usr/share/applications/javaws.desktop
/usr/share/icedtea-web/javaws_splash.png
/usr/share/man/man1/javaws.itweb.1.gz
/usr/share/pixmaps/javaws.png
 > 

Java Web Start was distributed as part of the Java Platform, and included in downloads of the JRE and JDK. It was deprecated by Oracle in Java SE 9 and removed in Java SE 11. The code for Java Web Start was not released by Oracle as part of OpenJDK, and thus OpenJDK originally did not support it. IcedTea-Web provides an independent open source implementation of Java Web Start that is currently developed by the AdoptOpenJDK community, RedHat and Karakun AG, and which is bundled in the official OpenJDK installer.[1]](Java Web Start - Wikipedia) Next to this OpenWebStart provides an open source based implementation that is based on IcedTea-Web but offers more features and commercial support options.