I want OpenSuSe to run smoothly! I need advice


I have an HP Pavilion dv5035nr Laptop with the following specs:

  • AMD Turion 64 ML-40 2.2 GHz
  • 80 Gb hard drive
  • 1 Gb PC2700 RAM
  • ATI Radeon Express 200M
  • Broadcom’s 4318 chipset for wireless.

I tried ubuntu before. The 32 bit version ran very well on my computer, in terms of speed and driver conflicts. Since my processor is 64 bits, I tried that version, but it was dramatically sloooow! so I chose the 32 bits. From that experience, I installed OpenSuSe 11.1 32-bits on my computer. But it runs dramatically slower (not just overall, but it times out my wireless connection all the time…it’s really annoying) than Ubuntu 8.10 32 bits. Of course this is the bloated dvd version. I know there exists the live cd, but it is only for 64 bits…should I try it? Advice me on what I should install on my computer.



My hardware is slower then yours (although i do have more RAM) and things are running smoothly here. Your HD is quite small though, is it very full? Having an HD that is too full can affect performance.

Yes, my hard drive is small, but I have tons of free space, don’t worry about that. That is the least of my concerns.

Do you have the 64 bit version? did you use the live cd’s or the dvd ?

What are you running? KDE of GNOME?
I’m using GNOME, I read somewhere that KDE is a little more demanding. In fact I tried KDE4 before GNOME and it was even slower.
Also I’ve been checking off and on the system monitor and my RAM is never really fully used. But my CPU, on the other hand is put to work to the max whenever I open any application.

I installed from the DVD (that should not make a difference though) and have the 32 bit version.
Using KDE4.2 here, which is a lot better then the piece of crud that came on the 11.1 DVD.

Is that a temporary spike or does the CPU usage stay at 100%? Either way does not sound normal. When i open, say, openoffice CPU usage spikes to about 60% but then it drops to between 20% and 30% again. And that is with several other programs running besides (Opera, Kaffeine, Okular, Amarok and Yast)

How exactly do you know this? I don’t recall what the Gnome process monitor will display, but htop (you can install it from the repository) is excellent and will show cpu consumption by thread. If you run “any application” and the cpu remains pegged at 100%, there is a fundamental problem. If the cpu just spikes for a moment, that just indicates the cpu is throttling (the Turion throttles the power to the cpu based upon demand).

So if the cpu is being pegged, first check to see if it is particular but not all programs doing that. It is also possible that there is a program running in the background that is struggling, e.g., running/failing/re-running. Or a “runaway” process. Another possible culprit is a indexing program running in the background, e.g., Beagle will gobble system resources while it is still building its index database, the demand usually drops to very little once this is completed (but you can see this for a while just after installation).

It is also possible that there is something tying up the kernel. Take a look at /var/log/messages to see if the kernel is throwing a lot of errors. There could be a problem between the kernel and the throttling. Try booting into Failsafe mode to see if the problem still occurs.

Also check /var/log/Xorg.0.log to see if the X server (the graphics layer) is throwing errors.

I get high spikes (over 80% for simpler programs than openoffice, I tried openoffice just now and I got a spike to 100%! but it quickly died down) when I open programs, even if I don’t have other programs opened. This is probably why my OpenSuSe is running so slow… I don’t know what to do to fix this… I’ve installed OpenSuSe 11.1 3 times already… and it’s the same all the time.

With only firefox and gnome’s system monitor I’m getting CPU readings between 20% and 50% which is quite high!

I found this thread: b43 driver high CPU usage - openSUSE Forums

I’m afraid I’m using the b43 old firmware to make my wireless work, because it won’t work with the newer one… maybe that’s the problem…how do I know which process is consuming the most CPU?

Run top from the command line and it’ll display the processes list. Also, either Ctrl+Alt+Esc or Ctrl+Esc will display a gui with the processes list.

How are you installing your b43 firmare? Are you running install_bcm43xx_firmware or manually loading a firmware you downloaded? The firmware version installed by install_bcm43xx_firmware works without any unusual cpu hogging on my laptop.

I have 11.1 KDE4.1.3 x86-64 (now upgrade to 4.2) on my Compaq notebook,see my spec below in signature. I format partition as xfs,everything is smooth. :slight_smile:

Thanks. I fixed it. I reinstalled and checked everything you guys suggested. Now it’s running fast (I disabled a dual-head mode option for my graphics card during installation. Also, I removed pulseaudio).