I seem to have no monitor settings or Display Settings

I have a brand new installation of Leap 15.0 Gnome desktop on my 64bit computer using an ATI graphics card with multiple display ports.

All application software seems to have installed correctly - I have only needed to install more codecs to get the videos and GIFs to work on Facebook (with any browser).

I am now trying to set up dual monitors. The 2 monitors come up fine in extended mode but I want to switch the primary and secondary display over. I have searched everywhere for the settings to change the display and can find nothing. The “openSuse Leap 15.0 Gnome User Guide” says I must right click the desktop and choose Display Settings.
Well, I don’t have a Display Settings in the options. All I have is New Folder, Paste, Select All, Keep Aligned, Organize Desktop By Name, Change Background, Open Terminal.
In YAST under Hardware I can’t see Monitors either.
Is there a module that should have been loaded that I can install from YAST?

Are you running Gnome on Wayland perhaps? (You can select the desired session at the login prompt)

echo $DESKTOP_SESSION
echo $XDG_SESSION_TYPE

I don’t think so. I don’t know what Wayland is.

Well, that could easily be confirmed by running the commands I gave (and reporting back here with the output) :wink:

garth@linux-juo5:~> echo $DESKTOP_SESSION
gnome
garth@linux-juo5:~> echo $DESKTOP_SESSION
gnome
garth@linux-juo5:~>

Yes, I just run a basic Gnome installation

Sorry I see I repeated the 1st command. I do have Wayland as you suggested

garth@linux-juo5:~> echo $XDG_SESSION_TYPE
wayland
garth@linux-juo5:~>

There’s your answer :wink:

Have a read of the following…

Ok, but please excuse my lack of expertise on these commands. Must I use the second command to set the default display manager to default-waylandsession.desktopfrom :
sudo update-alternatives --set default-displaymanager
/usr/lib/X11/displaymanagers/xdm

to:
sudo update-alternatives --set default-waylandsession.desktop
/usr/lib/X11/displaymanagers/xdm

Running the fist command gives the following:

garth@linux-juo5:~> sudo update-alternatives --display default-displaymanager
[sudo] password for root:
default-displaymanager - auto mode
link best version is /usr/lib/X11/displaymanagers/gdm
link currently points to /usr/lib/X11/displaymanagers/gdm
link default-displaymanager is /usr/lib/X11/displaymanagers/default-displaymanager
/usr/lib/X11/displaymanagers/console - priority 5
/usr/lib/X11/displaymanagers/gdm - priority 25
/usr/lib/X11/displaymanagers/lightdm - priority 15
/usr/lib/X11/displaymanagers/xdm - priority 10
garth@linux-juo5:~>

Why can’t the normal installation automatically provide the means to change the display setup graphically
with the right click on the desktop? The facility is needed by so many people.

Ok, but please excuse my lack of expertise on these commands. Must I use the second command to set the default display manager to default-waylandsession.desktop

from :
sudo update-alternatives --set default-displaymanager
/usr/lib/X11/displaymanagers/xdm

to:
sudo update-alternatives --set default-waylandsession.desktop
/usr/lib/X11/displaymanagers/xdm

Running the fist command gives the following:

garth@linux-juo5:~> sudo update-alternatives --display default-displaymanager
[sudo] password for root:
default-displaymanager - auto mode
link best version is /usr/lib/X11/displaymanagers/gdm
link currently points to /usr/lib/X11/displaymanagers/gdm
link default-displaymanager is /usr/lib/X11/displaymanagers/default-displaymanager
/usr/lib/X11/displaymanagers/console - priority 5
/usr/lib/X11/displaymanagers/gdm - priority 25
/usr/lib/X11/displaymanagers/lightdm - priority 15
/usr/lib/X11/displaymanagers/xdm - priority 10
garth@linux-juo5:~>

Why can’t the normal installation automatically provide the means to change the display setup graphically
with the right click on the desktop? The facility is needed by so many people.

I think you need to set X desktop session: default-xsession.desktop

Check with…

update-alternatives --query default-xsession.desktop

Why can’t the normal installation automatically provide the means to change the display setup graphically
with the right click on the desktop? The facility is needed by so many people.

Well, I use KDE with ssdm as display manager, and that does offer a choice of sessions at the login screen. I’m not familiar with gdm though.

I hate trying things and find they don’t work but have added extras to my system. If I try this xsessions desktop can I undo it again if it doesn’t give the display setings?

Yes, you can. (The respective settings are located in the /etc/alternatives directory. You could create a copy of that if desired - that would make for an easy roll-back.

Ok. I’ve tried the command and get the following error :

 garth@linux-juo5:~> sudo update-alternatives --set default-xsession.desktop \
>  /usr/lib/X11/displaymanagers/xdm
update-alternatives: error: alternative /usr/lib/X11/displaymanagers/xdm for default-xsession.desktop not registered; not setting
garth@linux-juo5:~>


You don’t want to be setting the xdm display manager. Anyway, I’ve now found time to install Gnome and the gdm display manager. I note that the gdm login screen also gives session choices after the user is selected. There you can select Gnome Xorg if desired.

I don’t get an option for Gnome Xorg.
After the GRUB boot I get:

openSuse Leap 15.0
Advanced option for openSuse Leap 15.0

If I go into the 2nd option I get 2 options which read the same:

openSuse Leap 15.0 with Linux 4.12.14-lp150.12.4-defal (note the missing text as the line seems too long - this must be a bug)
openSuse Leap 15.0 with Linux 4.12.14-lp150.12.4-defal

If I choose the 1st of these I go through the normal boot up
If I choose the 2nd option of these I get the boot up log displayed as it completes the boot.

Now I have another problem that has developed with this testing (what I was saying earlier - I end up with these unwanted extras):
At the end of the boot up, just before the desktop is displayed, I get this grey screen with very large text :

Welcome at lunix-juo5
Login

I then have to enter my user name and the root password

How do I get rid of this and get back to my normal boot up?

I understand that the KDE users like to work with the command line but why can’t the Gnome developers just leave these normal tools, like Display Settings, in the basics. The fact that the Gnome User guide says that a right click on the desktop will list the Display settings in the menu should be what it does.

How do I get rid of this and get back to my normal boot up?

Run

update-alternatives --config default-displaymanager

Make sure that you set gdm, then reboot.

I understand that the KDE users like to work with the command line but why can’t the Gnome developers just leave these normal tools, like Display Settings, in the basics. The fact that the Gnome User guide says that a right click on the desktop will list the Display settings in the menu should be what it does.

It works that way on KDE and Gnome actually - but only when running with an X-server. Wayland is still work in progress to be fair, so some features may be missing.

Just clarify a bit further, I had originally thought that setting Wayland or Xorg server was done via ‘update-alternatives’. However, from reading the release notes (for login and desktop session) I see it is more about setting the display manager. Both GDM and SDDM allow selection of the session type at the login screen, so that is all that’s needed.

Ok. I can run the “update-alternatives” in a terminal but how do I set gdm? I don’t understand that.

I really need to get at the display setup so that I can switch my monitors around. I have an older Dell 20" and a newer Asus monitor and I’ve tried reversing the cables and it always picks up the Asus as the primary. I want the Dell as the primary. I guess I’ll have to live with it until Gnome is fixed.

That will provide a list of numbered options. Look for the appropriate entry (/usr/lib/X11/displaymanagers/gdm) and enter that. It will take effect at next boot.

I really need to get at the display setup so that I can switch my monitors around. I have an older Dell 20" and a newer Asus monitor and I’ve tried reversing the cables and it always picks up the Asus as the primary. I want the Dell as the primary. I guess I’ll have to live with it until Gnome is fixed.

It’s not a question of Gnome getting fixed. It’s as a direct consequence of Gnome running with Wayland. You can choose to run Gnome on Xorg at the login screen.

Sorry I have been away from this for a while.
I still can find no Display settings. I’ve tried all the login alternatives and they seem to be the same
It looks like I have to live with this problem. Thanks for all the help