I messed up the Konsole settings in Tumbleweed

Operating System: openSUSE Tumbleweed 20240704
KDE Plasma Version: 6.1.2
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.7-1-default (64-bit)
Graphics Platform: X11
Processors: 16 x AMD Ryzen 9 5900HX with Radeon Graphics
Memory: 30.7 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: ASUSTeK COMPUTER INC.
Product Name: MINIPC PN52
  1. when I open Konsole from the bottom bar, then Konsole Terminal starts, but it has white text on a black background and I would like it to be black text on a white background (as it has been before). image konsole.png
  2. when I open Terminal - Super User Mode, the text is way too small. image super_user_mode.png
  3. if I open Terminal - Super User Mode first, I can no longer open Konsole, because when I click on the Konsole bottom bar icon, another window Terminal - Super User Mode starts. image double.png


1a. I can make a new profile with the colors as I want them to be, but I don’t know how to start it, and I don’t want to change the profile every time.
How can I start the profile I modified by default?

2a. I can enlarge the fonts (=ctrl+++++++), but I want the fonts already big enough in this profile and I can make a new profile, but I can’t make it the default profile.
How can I start the profile I modified by default?

@raijar:

There is a default Konsole profile for the “Root Shell” located in ‘/usr/share/konsole/’ – which is why you, as a normal user (and, as the user “root” also,) usually need to create a private copy of that Konsole profile.

The default user profile is “Built-in [Read-only]” – which is why a normal user has to create a new profile and set that profile to the default profile if, something else is needed …

Documentation is here – <The Konsole Handbook – Profiles>

I don’t understand what I should do. I created two new profiles and set the dot to default, but when I close the console and restart it, the same situation occurs again, i.e. the one set to default does not start.
Sure, I can switch to the new profile I made, but that’s not how I want this to work.
Opensuse leap 15.6 seems to work better…
opesuse_leap_15_6

@raijar:

Choose the “Manage Profiles” setting – either from here –

Or, here –

Then –

Choose the profile you’ve saved – it should be stored in ‘~/.local/share/konsole/’ – and, hit the “Set as Default” button.


Please check –

  • Your directory permissions in the ‘~/.local/share/’ directory tree and, in particular, those for ‘~/.local/share/konsole/’ directory.
  • Whether or not profile files – with the filename extension “.profile” – exist in the ‘~/.local/share/konsole/’ directory.
  • Whether or not, the names of the Konsole profiles are proper non-empty alphanumeric strings.

Thank you!

I finally got the consoles working, but still not quite the way I’d like.
I copied the Root Shell.profile from the .kde directory because the settings there seemed to be ok. I do not understand why they were there and why the information was not retrieved from the share directory.

kone1:~ # cp /home/raija/.kde/share/apps/konsole/Root\ Shell.profile /usr/share/konsole/

I do not understand why, you have a ‘~/.kde/’ directory tree – that user directory disappeared more than a few KDE versions ago …


 > rpm --query --whatprovides /usr/share/konsole/Root\ Shell.profile 
konsole-part-23.08.5-bp156.1.2.x86_64
 >

At the next patch or update to the “konsole-part” package, your customisations of the “Root Shell” profile will be lost.


Copy the “Root Shell” profile provided by the “konsole-part” package – forcibly re-install the package to restore the «supplied by the» distribution file – to ‘~/.local/share/konsole/’ and rename it – and then, make your local changes to that profile and, save your changes.

I must have a lot of old files in my directories because the oldest file was from 2014.
I have done the installation so that I copy the home directory to the external hard drive and after the new installation I copied the home directory back.

I didn’t understand your instructions again. Couldn’t the instructions be written in easier English? Of course, this is not your fault but my bad English.

I couldn’t get that command to go through.

Information for package konsole-part:
-------------------------------------
Repository     : Pääasennuslähde (OSS)
Name           : konsole-part
Version        : 24.05.2-1.1
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 2.4 MiB
Installed      : Yes
Status         : up-to-date
Source package : konsole-24.05.2-1.1.src
Upstream URL   : https://apps.kde.org/konsole
Summary        : KDE Terminal
Description    : 
    Konsole is a terminal emulator for the K Desktop Environment.
    This package provides KPart of the Konsole application.

kone1:~ # 
kone1:~ # 
kone1:~ # 
kone1:~ # rpm --query --whatprovides /usr/share/konsole/Root\ Shell.profile konsole-part-24.05.2-1.1.x86_64
konsole-part-24.05.2-1.1.x86_64
no package provides konsole-part-24.05.2-1.1.x86_64
kone1:~ # 

The command is –

> rpm --query --whatprovides /usr/share/konsole/Root\ Shell.profile

If you type “rpm --query --whatpr” and than hit the Tab key, the “whatprovides” will automatically be completed.
If you then add “/usr/share/konsole/Roo” to the command and hit the Tab key again, the filename will be automatically completed.
Then hit the “Return” key and, the command will execute.

@raijar:

  1. Everything in the “/usr/” directory tree is SYSTEM.
    Same for everything in “/lib/” and “/bin/” and “/sbin/” and “/lib64/” …
    Everything in those directories may be changed when the system is either patched or, updated.
    The only SYSTEM directory where administrators are allowed to make site-specific modifications is “/etc/” – and then, only in specific “???.d/” sub-directories as defined by the system application’s “man” page.

  2. If you were to setup a clean test user with a home directory containing only the files supplied in ‘/etc/skel/’ and then, if you logged into that new user with a KDE Plasma session, you would notice that, the ‘~/.kde/’ user directory is neither created nor used.

  3. All user defined KDE Plasma Konsole profiles are stored in the user’s ‘~/.local/share/konsole/’ directory.

Thanks for the information!

I have deleted old .directories/.files (eg .KDE), which I have apparently not used for years. I also cleared the .cache directory and give the command “Shut Down”.
Tumbleweed fully booted.

But what I want is that when I click on the bottom panel
1 “Terminal - Super User Model”, so ko. the program starts. This uses root password.
2 “Konsole”, then the respective program is started. No password needed.
And the aforementioned programs do not interfere with each other in any way.

I am using Leap 15.5. But this seems normal to me (already for numerous years). Isn’t that the case with you?

In the user’s profile for the Root Shell, the command the profile uses could be either the very correct form –

/usr/bin/su --login

or the form used in the ‘/usr/share/konsole/Root Shell.profile’ file –

su -

For a normal user, the Konsole profile should be using the command –

/usr/bin/bash

or, whatever shell that user uses.