I can't login :(

I’m using openSuse 11.2, KDE, x64 and, all of a sudden, my user accounts stop working!
My first acc, ‘bidu’ stopped at login. It asked for the pass of kWallet, and then nothing! The screen freezes. So I created another user, ‘biduzido’. It worked fine until yesterday -.- Today I can’t login with it. I type the pass, the screens turns black and then it shows the login screen again. I can login with the root.

Does anyone have any clue?

Thx ^^

Do this to get a console login

You get this kind of screen to login at

Login with your username and password, then do this:

mv .kde4 .kde4-old

Now type: startx

I saw that tip of yours at another thread and tried it.
Well, the command executes but when I type startx, it shows a message saying that the temp dir is full @_@.
Well, I checked the .tmp dir using the root acc, it has over 12 gb O_o.
Can I just delete it all?

It is probably ok to delete most of it, maybe you have made some dvd copies with k3b or something, it leaves the file in there.

A safer way would be to do this:
Level 3 Boot and Yast - Windows Live

In yast go to etc/Sysconfig and do the equivalent of this, though this is the full UI view
Clear Temp Files at Boot - openSUSE Forums

Otherwise, if you can’t figure that. Boot a live CD and delete the biggest files, probably in /tmp/kde/username*

Did it! It’s working now. Thanks

Well done. :wink: