I can't get M.A..M.E to see my roms

I have some experience with mame ( Multiple Arcade Machine Emulator), been using it for years now. Many years ago on windows xp, these days on a real O.S. :wink:

On my previous pc, I had it working just fine. Leap 42.3 , mame 0.185 wih rom pack 0.183

I am typing this from my new pc, and am using tumbleweed now.

Copied the roms from my old pc to my new pc, but mame does not see the roms. mame 0.211

Because roms might or mght not work with every mame version I also redownloaded a 60 gig rom pack. Version 0.197

Both roms packs don’t work.

What I did find was this, a site with a few 100% legal roms. My mame does not see this one either.
I downloaded star fire.

Link to my older topic, were I got mame woring on leap 42.3

I had some issues on leap 42.3, but that was solved by installing libutf8proc1 - Library for processing UTF-8 encoded Unicode strings.

So on tumble weed I made sure I had a file like that, and found libutf8proc2 - Library for processing UTF-8 encoded Unicode strings.

The Xbox one controller I ordered is in. It has two joysticks which I need for Robotron 2084 ( safe the last human family ) :stuck_out_tongue:
This controller is supported on Linux,and has a usb connection to hook it up to our pc,

Does anybody have mame working on tumbleweed?

I have no idea on how to fix this, and hope somebody can help me.

MAME seems to work fine, when I start it from the command line, I don’t get any errors. But as I said it does not see my roms.
I did add in mame a link to my rom folder, and restarted mame.
Mame does remember the link.

One thing I notice and remember from before, if there is a problem with the roms, mame will tell you this, but as far as I can tell mame does not see the roms at all.
(The rom files are zip files and are copies from the original arcade machines rom)

Pacman Space invaders, Galaga, Galaxian, Mr do and Robotron are some of my favourites.

I am totally stuck. I also registered to the mame devs forum.

What I am gonna try is to install the debugging tools.

Maybe then when I start mame from the commandline, I get some use full errors / info.

I found version 0.193, that was the one I had working, but that was on leap.

Already tried to install the leap 15.2 version, just to see what files it wants to install, and then cancel before actual install would start, but yast wont let me. :slight_smile:

Why not create a bug report, easiest way to get the 0.220 version fixed? openSUSE:Submitting bug reports - openSUSE

Thank you and will do.

Last night before I went to bed, I suddenly remembered something about debugging tools.

( assuming most of them to work alike)

I need to start the debugging tools, and then the debugging tools need to start the application. (mame)
So besides filing a bug report, I am gonna search for some read me files, which explains on how to use them.

Also need to find what the debugging program is called, because then I probably can do man debugging tools. :slight_smile:

There is gdb and strace…

gdb <some_app>

(gdb) run <enter>

https://bugzilla.opensuse.org/show_bug.cgi?id=1177963 :slight_smile:

I got an email, about the bug.

It says the problem is, also what Malcom already said, with the Tumbleweed mame package.
It was suggested, I contact the maintainer, but he did not know who that is.

I am gonna search for the package maintainer, in the email was also a link to a page, which shows what people have worked on the mame package.

To be continued. :slight_smile:

Thank you I did install the mame debugging tools.
Will give it a try if those works with gdb.

Found something:

Somebody asked me to assign the bug to somebody.

I have no idea on how to do this though. Been looking for over an hour but can’t find it.

I did add his name, to the cc email list of the bug. Does any body know how to assign a bug to somebody?
Wonder if the maintainer of mame is maybe on a vacation, he does not reply to my email. :slight_smile:

Talked to another package builder and he did confirm the person I had emailed is the maintainer.

For now while I wait…
Will do an an attempt to compile mame myself. I already downloaded the source and had a look at the mame compile page.
Used the dependencies list for fedora, because opensuse is not listed.

Lets hope I get lucky. :slight_smile:

Typing this with fingers crossed , while I am compiling MAME.

In theory its beyond simple, download source, install the dependencies listed for fedora, unpack the zip file. Then from the command-line go in to the master mame folder, and type make. :open_mouth:

Should have used the -j6 option because it takes quite some time to compile. rotfl!

Since it’s developed in Emulators, you can see the bugowner as well…

Have a look here for how it’s built: https://build.opensuse.org/package/show/Emulators/mame especially the spec file.

When you see a constraints file, it can take some resources to build (looks like RAM, but limited to 4 cores, likely for debugging)! An hour to build with 4 cores, expect your will be at least 4 if successful.

Thank you, I think I recognize one name of the maintainers.
Will try to contact them.

About the compile, I defenilty need the j- option. amd ryzen 6 cores 12 threads, lets google if -j12 should work.

I was almost happy it failed, will continue tomorrow and then use -j .

This fail already took over 2 hours.
Might be better to start compile then leave pc alone for a bit.
Not worried yet

Compiling src/osd/modules/input/input_x11.cpp... 
**../../../../../src/osd/modules/input/input_x11.cpp:18:10:****fatal error: **X11/extensions/XInput.h: No such file or directory 
   18 | #include **<X11/extensions/XInput.h>**
      |          **^~~~~~~~~~~~~~~~~~~~~~~~~**
compilation terminated. 
make[2]: *** [osd_sdl.make:1011: ../../../../linux_gcc/obj/x64/Release/osd_sdl/src/osd/modules/input/input_x11.o] Error 1 
make[1]: *** [Makefile:19: osd_sdl] Error 2 
make: *** [makefile:1365: linux_x64] Error 2 

Will see tomorrow what I can find with google to fix this. :slight_smile:

(the simple solution, search in yast for XInput.h did not work)

Although when using the search option, file list, it does find libxcb-devel

So why is make complaining ? lol
Stupid make,

For now optimistic this can be fixed, I already found more people who had this error.

You need libXI-devel install, look at the build spec file for the build requires…

I feel stupid, but can’t find a build spec file any were.

Were do you see this ? :slight_smile:

It’s here, in your case pkgconfig(xi) = libXi-devel;

BuildRequires:  pkgconfig(xi)

Is this what you mean ? :slight_smile:

That literately took me a long time, until I started using cntrl+f on that page lol.
When I searched in yast for rpm provides and pkgconfig(xi) libXi-devel did pop up :slight_smile:
And I installed it.

I will have to check some more dependencies, build requirements called there, I am not sure if I already have all build requirements, but I do have most.
Using an dependencies list for Fedora though, I did expect some missing stuff.

Also got a reply on my bug report. This opensuse user says it works for him (the mame package)
For now I am totally confused why it works for him but not for me.

My folder is in a different location, but he also states it does not matter were that rom folder is.
The weird part, when I add that folder in MAME , it seems like mame accepts it, it reacts different to folders were there are no roms.

To be continued…

Although I will probably continue the compile ( newer version of mame) , I have the official package working.

One of the replies on the bug trigger made me wonder.
This should make at least some smile.

Now what was the problem, and although I don’t get it, the folder structure was causing the problem.

What I had was a folder called mame roms. In there was the actual rom folder with the roms in it.
It seems you can’t do that.

After I had changed this, I deleted in mame the path to the rom folder.
Then again (this was about the 10th time) I set the rom folder.

And boom, Robotron 2084 (blue label what ever that means) started a hardware test, and told me the machine was fine.
Like that about mame and the original roms, how is does exactly what the arcade machine did when you turned it on.

Now I can finally safe the last human family, if I can get the Xbox one controller working in MAME.

Baby steps, I can confirm X box one controller is working in mame.

I do not yet understand what knobs to use, but I can navigate the menu a bit in mame with the controller.

For now lost on how to set up the controller for robotron but almost certain this will be easy.

While typing this I might have an idea were to do this, in the arcade machine settings.

I have the same problem as the author.
OpenSUSE Tumbleweed, 1.5 years ago mame 0.210 worked fine, but now on 0.226 when starting mame does not see any available rom.
When launching mame with the absolute rom path parameter, it doesn’t write that it doesn’t find files that are all in this archive.

P.S. I solved the problem.
In menu mame you need to go into the directory settings and specify the location of the directory with roms.