I can not install the CUPS packages

I am using OpenSuse 13.1 and KDE

When I try to install CUPS packages the following message appears:


linux-a49v:/home/sergio # LANG=C zypper in -f cups
Loading repository data...
Reading installed packages...
Forcing installation of 'cups-1.5.4-144.1.i586' from repository 'Printing'.
Resolving package dependencies...

The following 2 NEW packages are going to be installed:
  cups cups-client 

2 new packages to install.
Overall download size: 7.3 MiB. After the operation, additional 11.2 MiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package cups-client-1.5.4-144.1.i586                                                           (1/2), 135.6 KiB (319.6 KiB unpacked)
Retrieving: cups-client-1.5.4-144.1.i586.rpm ...........................................................................................[error]
File './i586/cups-client-1.5.4-144.1.i586.rpm' not found on medium 'http://download.opensuse.org/repositories/Printing/openSUSE_13.1/'

Abort, retry, ignore? [a/r/i/? shows all options] (a): 

What can I do to solve this problem ?

Thanks in advance

The repository is out of date. Run zypper ref first.

Sorry, but do not know how I do it.

You could show me how it would be on the command line?

zypper ref

That is the command, it means “zypper refresh” which downloads the repository information and up to date file and version listings.

Then run your

zypper in cups

This should not happen however unless the repository has been marked “do not refresh”, you should look at the results of: zypper lr and see if the repository has “No” under the Refresh.

On 2014-07-24 21:06, sergelli wrote:
>
> Miuku;2655672 Wrote:
>> The repository is out of date. Run zypper ref first.
>
> Sorry, but do not know how I do it.
>
> You could show me how it would be on the command line?

zypper help?

But… why did you disable automatic refresh?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

It’s looking that worked well?

Thanks, Miuku


linux-a49v:/home/sergio # LANG=C zypper ref
Repository 'Packman Repository' is up to date.
Repository 'Printing' is up to date.
Repository 'libdvdcss repository' is up to date.
Repository 'openSUSE-13.1-1.10' is up to date.
Repository 'openSUSE-13.1-Non-Oss' is up to date.
Repository 'openSUSE-13.1-Oss' is up to date.
Repository 'openSUSE-13.1-Update' is up to date.
All repositories have been refreshed.

I do not remember having disabled the automatic reflesh .
How do I fix this?

Two ways, either

The graphical way:
Launch YAST and go to Software Repositories, on the “Printing” repository make sure there is a checkmark on “Automatically refresh”

The terminal way:
zypper lr

then look at which repository has “Refresh” Disabled and:
zypper mr -r X

Where X is the number of the repository you wish to turn auto refresh on.

Like this:

mariposa:/home/miuku # zypper lr 

#| Alias               | Name                         | Enabled | Refresh
--+---------------------+------------------------------+---------+--------
1 | ftp.gwdg.de-suse    | Packman Repository           | Yes     | No     
2 | repo-non-oss        | openSUSE-13.1-Non-Oss        | Yes     | Yes    
3 | repo-oss            | openSUSE-13.1-Oss            | Yes     | Yes    
4 | repo-update         | openSUSE-13.1-Update         | Yes     | Yes    
5 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes     | Yes    

mariposa:/home/miuku # zypper mr -r 1

Autorefresh has been enabled for repository 'ftp.gwdg.de-suse'.

--> 

mariposa:/home/miuku # zypper lr


# | Alias               | Name                         | Enabled | Refresh
--+---------------------+------------------------------+---------+--------
1 | ftp.gwdg.de-suse    | Packman Repository           | Yes     | Yes    
2 | repo-non-oss        | openSUSE-13.1-Non-Oss        | Yes     | Yes    
3 | repo-oss            | openSUSE-13.1-Oss            | Yes     | Yes    
4 | repo-update         | openSUSE-13.1-Update         | Yes     | Yes    
5 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes     | Yes    

As you can see, ftp.gwdg.de was changed from Refresh No to Refresh Yes! :slight_smile:

So, for me to have automatic CUPS updates I just put “YES” on the line “Printing” and column “Refresh” ?

The other lines are correct?

    
linux-a49v:/home/sergio # LANG=C zypper lr
#  | Alias                     | Name                               | Enabled | Refresh
---+---------------------------+------------------------------------+---------+--------
 1 | Packman Repository        | Packman Repository                 | Yes     | Yes    
 2 | Printing                  | Printing                           | Yes     | No     
 3 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes    
 4 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Yes     | No     
 5 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes    
 6 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes    
 7 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes    
 8 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes    
 9 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes    
10 | repo-source               | openSUSE-13.1-Source               | No      | Yes    
11 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes    

Yes, you’ll want to have “Refresh on” for all repositories that may get updated software - like Update, Printing etc etc.

Otherwise you’ll run into a situation where you are trying to install a file but the version has changed to a newer one and the old one is no longer available on the server.

Thank you Miuku

Now CUPS is installed on my PC. :slight_smile: