I accidentally installed "RegataOS" - how to back to OpenSUSE ?

Hello,
I today installed WPS Office from this One-Click Install: https://software.opensuse.org/ymp/home:regataos/openSUSE_Leap_15.0/wps-office.ymp?base=openSUSE%3ALeap%3A15.0&query=wps-office
After reboot I see, that GRUB shows me “RegataOS 19” intead of “OpenSuse”. In RegataOS are different theme, font, Brazilian language as default and other strange things. I want to back to openSuse.
I removed home:regataos repository in Yast but after reboot still it’s “RagataOS”.
https://i.imgur.com/Z39MUw0.png

It’s any way to unistall this **** to go back to openSuse Leap 15 without format? Please help me.

I did not understand how RegataOS appeared to you … did you try to update the grub?


su - -c 'grub2-mkconfig -o /boot/grub2/grub.cfg'

Hi
Ensure the ‘home’ user repo is gone, then do a zypper dup --from repo-oss to restore all the files…

The wps-office is closed source binary file, just go to their website and grab the tarball, extract and use as your user.

I intalled WPS Office from this page -> openSUSE Software
but I chose by mistake this version:
https://i.imgur.com/RGTw96w.png

After restarting, openSuse has been changed to RegataOS :confused:

Not works, still “RegataOS”.

Now I understand … not to have understood

Delete the repository and zypper dup

I removed home:regataOS repository and I did “zypper dup”. Some parts of this system have been removed, but it is still RegataOS


There is list of all my repositories in YaST:

Hi
Do a search with zypper for any regata left over packages…


zypper se -i regata

Or use YaST software and select the @System ones to see if any are still from that repository and remove as required. This time, watch what the system is telling you about what it is going to do :wink:

You also need to disable the Tumbleweed packman repository, that’s just asking for further trouble.

In Yast Software @System I have not found any RegataOS repositores

zypper se -i regata:

This is as “product”, not “package”, so I don’t know how to remove it.

A product is just a group of packages.

Did you already try “sudo zypper remove regata”? That should work.

sudo zypper remove regata
regata not found :confused:

I tried to find name of this by clicking TAB, but there is no result


sudo zypper rm Regata*

linux is case sensitive.

But I think you need more than just that. F.e. running YaST’s bootloader module.

“Regata” is also not found. I tried Tab with “re” or “Re” and there is no result.

Ehh… Who created this RegataOS…

Ah, I missed it’s a product, not a package, So, use the YaST Bootloader module. It should regenerate a new bootloader config.

Hi
This user: Profile of regataos - openSUSE Build Service

You might need to review the list of packages (179) here;

If they are installed and an openSUSE release equivalent exists, re-install, any outliers remove completely.

Okay, I opened YaST Bootloader and what should I do?https://i.imgur.com/qzlDwR7.png

I think, that it’s not problem with bootloader but in system because I still have themes, fonts and other things from RegataOS.

AFAIK the product info package is still the wrong one. Do a forced reinstall of the openSUSE-realase package.

This may help with grub2 (which takes its version string from /etc/os-release by default). This will probably leave a lot of modifications in KDE (including funny “Version 19.0.27” and URL in KSysInfo) which are taken from KDE rc files that are directly manipulated by scripts and so are most likely left even after removing packages that include these scripts.

There are so many places that are touched during installation from this repo that I would really consider either reverting to snapshot before installation or (if this is not possible) to reinstall.

I concur. Even if you save it now, it will always be a factor to include in future trouble.