Huion Graphics Tablet H610PRO

I have a HUION H610PRO that works ok when connected to the computer. I have a dual screen setup and I am trying to lock the graphics tablet to a single screen. When I go to the tablet settings, nothing is detected. so I can not change any settings. Not sure where to start, so any help is greatly appreciated.

Bus 002 Device 049: ID 256c:006e HUION PenTablet

the other items on the list no related to the table have been omitted.

I’m not sure about your tablet and I am also not expert with this. Anyhow is it like similar to a wacom tablet ?
Please try this command and post the output as a reply.


Command not found

Ok, so it’s not installed in your machine.

Do in terminal

cnf xinput

If it’s in the repo install it. When you get it running fire it in a terminal and post the output.
If it yield something good about your tablet, we will try to map it in your desired monitor.

No protocol specified 
⎡ Virtual core pointer                          id=2    [master pointer  (3)] 
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)] 
⎜   ↳ Logitech Wireless Mouse                   id=13   [slave  pointer  (2)] 
⎜   ↳ Logitech Wireless Keyboard PID:4075       id=14   [slave  pointer  (2)] 
⎜   ↳ SINOWEALTH Game Mouse                     id=11   [slave  pointer  (2)] 
⎜   ↳ HUION PenTablet Consumer Control          id=16   [slave  pointer  (2)] 
⎜   ↳ HUION PenTablet Pad                       id=18   [slave  pointer  (2)] 
⎣ Virtual core keyboard                         id=3    [master keyboard (2)] 
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)] 
    ↳ Power Button                              id=6    [slave  keyboard (3)] 
    ↳ Power Button                              id=7    [slave  keyboard (3)] 
    ↳ Logitech Z Cinéma Consumer Control        id=8    [slave  keyboard (3)] 
    ↳ Logitech Z Cinéma Keyboard                id=9    [slave  keyboard (3)] 
    ↳ sonixj                                    id=12   [slave  keyboard (3)] 
    ↳ Logitech Wireless Keyboard PID:4075       id=15   [slave  keyboard (3)] 
    ↳ SINOWEALTH Game Mouse Keyboard            id=10   [slave  keyboard (3)] 
    ↳ HUION PenTablet Consumer Control          id=17   [slave  keyboard (3)] 
    ↳ HUION PenTablet Pen                       id=19   [slave  keyboard (3)]

My guess is you don’t need to include the keyboard, it’s just the pen, do you?
I’m not sure but perhaps you may include it if only pen is map will not work.

So you have to find out now your connected monitors.

In the terminal do:

xrandr --query

or do:

xrandr --query | grep '\bconnected\b'

and post it back.

What DE are you using? Here I am using xfce 4.16 and I find it easier mapping my wacom tablet.

KDE Plasma 5.18.6
KDE Framnework 5.76.0

So which monitor is the one that you want to map the tablet?
Is it the HDMI-0 or DVI-D-0?

Either one. as long as its mapped to one, i am good

You may create a small script, probably save it in your/home/user.
We are going to use the HDMI-0.

First you have to make an empty file and name it with a name you want.
Then copy and paste this:

#! /bin/bash
xinput map-to-output 16 HDMI-0
xinput map-to-output 18 HDMI-0      
xinput map-to-output 17 HDMI-0
xinput map-to-output 19 HDMI-0

Save the above to your created empty file with a name

Then make it executable.
Just open dolphin find that file you created, right click on the file click properties and in permissions put a check on the box “is executable”.
Then close it.

In the directory where you save that file i.e.
open a terminal and do


Cross your fingers and see if the outcome is positive.
You will know if it worked because the pen will be limited to the left and right side edge of your display.
And if you draw a circle it will be a circle not an eggshape like.
Hope this help, if not we need some other contributor to chime in and help.

Best regards.

did not work

Can you explain how did you did do it.
and the error when you run the script please.

So I login to a plasma desktop and mine works.
However I guess you don’t need it in plasma(your using plasma right?)
I opened the systemsettings5 and there I saw that if your tablet is detected you can choose to map
it in the screen you desired.

So in systemsettings5 go to input devices-graphic tablet down at the bottom there are choices
where to map your tablet.
The choices are as follows:
Map to fullscreen, map to screen 1 and map to screen 2.
You just need to press the keyboard assigned to your different screens. eg: Meta+Ctrl+1 for screen1 and so fort.
Hope you find it there. if not please reply the script error in script I did for you.

Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyX Error of failed request:  BadMatch (invalid parameter attributes) 
  Major opcode of failed request:  131 (XInputExtension) 
  Minor opcode of failed request:  57 () 
  Serial number of failed request:  30 
  Current serial number in output stream:  31 
Invalid MIT-MAGIC-COOKIE-1 keyX Error of failed request:  BadMatch (invalid parameter attributes) 
  Major opcode of failed request:  131 (XInputExtension) 
  Minor opcode of failed request:  57 () 
  Serial number of failed request:  30 
  Current serial number in output stream:  31

I use Plasma. the issue is that when I go to the system settings it appears as no tablet is detected, and if I click to manually register a tablet there is a refresh button that does not detect it either.

So the settings are not detected. I googled a bit and find this link. might be the case on your tablet. You might need some workaround as stated in the link.
read the whole article and take note of the part with the “xsetwacom --list”
You have to do some digging and rolling your sleeves up for a bit.

Best regards and please re-post kindly if you’re successful for future reference.

Thanks for the info. I tried doing this but I could not figure our how to install the kernel drivers. They have instructions for Debian and Fedora. I tried following fedora instructions but first command did not work (should I do this?). I am afraid to break the system.

Not so sure but I think the kernel-header is going to be installed when you install the


Thank you for all the help.
Finally was able to complete all the steps. The issue is the same. My tablet is working, but I can not configure it because it is not recognized under wacom settings.
If I read correctly all those steps were to be able to have the tablet working, which it was in the first place.

Back to square 1

What if you try xinput again.

Do command:

xinput map-to-output 18 HDMI-0


xinput map-to-output 19 HDMI-0

Do it in the terminal each one. It’s just for the pen and pad.