huawei ec1260??

Is it possible to connect this usb modem in linux?? HUAWEI-EC1260

Hi All,

I have been trying to get the EC1260 working on OpenSuse 11.0 64bit.
When pluging in the stuck it recognizes it as a usb-storage.

I tried using rmmod usb-storage && modprobe usbserial product=0x12d1 vendor=0x140b only works partial and only for that moment.
when I try to configure with wvdialconf it still doesn’t recognize i as a modem.
When I unplug and replug the stick it is back as a storage device.

All the help is welcome.


Here is my output of messages when plugin the EC1260

Aug 6 10:09:32 johan kernel: usb 4-1: new full speed USB device using uhci_hcd and address 4
Aug 6 10:09:32 johan kernel: usb 4-1: configuration #1 chosen from 1 choice
Aug 6 10:09:33 johan kernel: scsi10 : SCSI emulation for USB Mass Storage devices
Aug 6 10:09:33 johan kernel: usb-storage: device found at 4
Aug 6 10:09:33 johan kernel: usb-storage: waiting for device to settle before scanning
Aug 6 10:09:33 johan kernel: usb 4-1: New USB device found, idVendor=12d1, idProduct=140b
Aug 6 10:09:33 johan kernel: usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=4
Aug 6 10:09:33 johan kernel: usb 4-1: Product: HUAWEI Mobile
Aug 6 10:09:33 johan kernel: usb 4-1: Manufacturer: HUA�WEI TECHNOLOGIES
Aug 6 10:09:33 johan kernel: usb 4-1: SerialNumber: �������������������
Aug 6 10:09:34 johan kernel: scsi 10:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 0
Aug 6 10:09:34 johan kernel: sr1: scsi-1 drive
Aug 6 10:09:34 johan kernel: sr 10:0:0:0: Attached scsi CD-ROM sr1
Aug 6 10:09:34 johan kernel: sr 10:0:0:0: Attached scsi generic sg3 type 5
Aug 6 10:09:34 johan kernel: usb-storage: device scan complete

output of uname -an

Linux johan #1 SMP 2009-06-01 09:57:12 +0200 x86_64 x86_64 x86_64 GNU/Linux

This part of dmesg is relevant

Aug 6 10:09:34 johan kernel: sr 10:0:0:0: Attached scsi CD-ROM sr1
Aug 6 10:09:34 johan kernel: sr 10:0:0:0: Attached scsi generic sg3 type 5

The device behaves like a cdrom, until you type

eject /dev/sr1

Then the device should now look like a modem to your system. Type

ls -l /dev/ttyU*

You should now see something like this

dean@linux:~> ls /dev/ttyU*
/dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2

Now try dialing.

For a more permanent solution, have a look at /etc/udev/rules.d directory. There is a file called 70-persistent-cd.rules (or similar) containing some rules for devices that have been plugged in previously like your Huawei device. New rules get added here, as new ‘cdrom-type’ devices are plugged in. For example, in my case, I have just inherited a sierra 597 modem, which resulted in udev adding this line

TRU-Install (pci-0000:00:1d.0-usb-0:1:1.0-scsi-0:0:0:0)

ENV{ID_CDROM}=="?*", ENV{ID_SERIAL}==“Aircard_TRU-Install_SWOC22905731-0:0”, SYMLINK+=“cdrom4”, ENV{GENERATED}=“1”

I modified it to include ‘/bin/eject %k’

TRU-Install (pci-0000:00:1d.0-usb-0:1:1.0-scsi-0:0:0:0)

ENV{ID_CDROM}=="?*", ENV{ID_SERIAL}==“Aircard_TRU-Install_SWOC22905731-0:0”, SYMLINK+=“cdrom4”, ENV{GENERATED}=“1”, RUN+="/bin/eject %k"

Now when the device is plugged in, it is ready to use as a modem.

Many Huawei models can be controlled via NetworkManager, but the key to the device being recognised lies with


If you take a look at this hal config file, you will see it contains entries for many different modem models. With any luck your model may already be supported, but if not you can often edit this so that it contains your vendor ID as well. Then NM should recognise the device.

Have a look at post #7 for the basic idea here.

Hope this is enough to get you started.

Hi Deano,

I have tried your steps but it’s not working.
After ejecting /dev/sr1 there is no device ttyU*

johan:/etc/udev/rules.d # mount
/dev/sda6 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda7 on /home type ext3 (rw,acl,user_xattr)
/dev/sda2 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
securityfs on /sys/kernel/security type securityfs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sdb1 on /media/Music type ext3 (rw,nosuid,nodev,data=ordered)

johan:/etc/udev/rules.d # ls -l /dev/ttyU*
ls: cannot access /dev/ttyU*: No such file or directory
johan:/etc/udev/rules.d #

I also made the changes in the 70-persistent-cd.rules file

johan:/etc/udev/rules.d # cat 70-persistent-cd.rules

This file was automatically generated by the /lib/udev/write_cd_rules

program, probably run by the cd-aliases-generator.rules rules file.

You can modify it, as long as you keep each rule on a single line

and set the $GENERATED variable.

DVD±RW_DS-8W2S (pci-0000:00:1f.2-scsi-1:0:0:0)

ENV{ID_CDROM}=="?", ENV{ID_PATH}==“pci-0000:00:1f.2-scsi-1:0:0:0”, SYMLINK+=“cdrom”, ENV{GENERATED}=“1”
", ENV{ID_PATH}==“pci-0000:00:1f.2-scsi-1:0:0:0”, SYMLINK+=“cdrw”, ENV{GENERATED}=“1”
ENV{ID_CDROM}=="?", ENV{ID_PATH}==“pci-0000:00:1f.2-scsi-1:0:0:0”, SYMLINK+=“dvd”, ENV{GENERATED}=“1”
", ENV{ID_PATH}==“pci-0000:00:1f.2-scsi-1:0:0:0”, SYMLINK+=“dvdrw”, ENV{GENERATED}=“1”

Mass_Storage (pci-0000:00:1d.0-usb-0:1:1.0-scsi-0:0:0:0)

ENV{ID_CDROM}=="?*", ENV{ID_SERIAL}==“HUAWEI_Mass_Storage-0:0”, SYMLINK+=“cdrom1”, ENV{GENERATED}=“1”,RUN+="/bin/eject %k"

Mass_Storage (pci-0000:00:1d.0-usb-0:1:1.0-scsi-0:0:0:0)

ENV{ID_CDROM}=="?*", ENV{ID_PATH}==“pci-0000:00:1d.0-usb-0:1:1.0-scsi-0:0:0:0”, SYMLINK+=“cdrom2”, ENV{GENERATED}=“1”,RUN+="/bin/eject %k"
johan:/etc/udev/rules.d #

I even gave the 2nd line also the addition of eject

What next now?

thx in advance


VasanG wrote:
> Is it possible to connect this usb modem in linux?? HUAWEI-EC1260

i found this in a Danish usenet posting…have NO idea if it will be
useful…but have a close look—and report back on your success, please:

Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

Hi jneyens

You can try the usb_modeswitch and vodafone-mobile-connect utilities, although it is pure speculation as to whether it will work for your model. The key to many of these devices is disabling the usb_storage (cdrom device) and enabling the serial modem device (connected to same physical usb port). Searches including the product and vendor IDs may yield helpful info.

Keep us posted. :slight_smile:

Sorry, don’t know any real solution to get
this working with your kernel (OS) version.

But it seem that it is possible
to get this modem working in Linux.

This is screenshot from Ubuntu 9.04
(which seems to be newer, than your openSUSE installation:
as long as I know it has kernel 2.6.28.*):

Relieance Netconnect Broadband+ Huawei EC1260 Modem on Ubuntu 9.04 – 2 | Person @ CREATIVEDESK

Also, this link may be somewhat helpful:
Living at high speeds - Platonic

jnjayster and VasanG:

can I suggest you try downloading one of the Ubuntu variants of linux; and see how they go at configuring the huawei for you?

eg easy peasy; or, if the name of easy peasy puts you off; eeebuntu; eg their base version at about 350MB is quite light;

we are still running 11.0 OpenSuse here; and for our netbooks, I have used ep:

I notice there (Ubuntu variants) that if I plug a Huawei 220 (or the Huawei 160);
that if I right-click on network manager; there is a really nice menu: I click on mobile broadband; and it has the providers in many countries: I select what I want, and I am on-line in about 3 secs;

I tried our OpenSuse 11.0 last night, and I think it was offering me wvdial; for manual configuration;

this morning I booted one of the other boxes with the liveCD of OpenSuse 11.1 and again I was offered a laborious manual configuration;

so if you want to get your huawei ec1260 going, can you tell us if you can configure it on … eg … easy peasy or eeebuntu or just plain old Ubuntu if you have any live CDs eg from linux magazines …