Hplip slow printing.

Hi! :slight_smile:

Today I tried to print some text pages, only to realize that printing on my printer (HP Deskjet 1.000) is painfully slooow! >:(
It takes an average ~1min48sec per page, while the same printer used to print a page at ~ 9secs.

Seems like there are known problems with slow hplip printing, but it’s the first time I encountered it.
Here is a probably related unresolved bug: https://bugs.launchpad.net/hplip/+bug/516238, but a google search reveals a lot of similar issues.

My system is OpenSUSE 13.1 x64 KDE and I have the Hplip driver from repositories.
hp-check indicates that everything is OK.

If someone knows something related to this issue, please tell us.
TIA! :slight_smile:

On 2014-09-01 17:56, Thalassius wrote:
>
> Hi! :slight_smile:
>
> Today I tried to print some text pages, only to realize that printing on
> my printer (HP Deskjet 1.000) is painfully slooow! >:(
> It takes an average ~1min48sec per page, while the same printer used to
> print a page at ~ 9secs.
>
> Seems like there are known problems with slow hplip printing, but it’s
> the first time I encountered it.

I have never seen any of that - but my HP understands PS natively, so
hplip hasn’t got to do much. And data is sent over the network, so
that’s taken care of by cups and the kernel.

In fact, my hp printer works fine without hplip.

Related to the launchpad link, I do know that several Linux utilities
crawl or even crash on handling postscript generated by adobe acrobat.
What I do is sanitize the postscript file with ‘ps2ps’. I don’t know if
that can be inserted automatically into cups handling.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

THANKS Carlos for your help!!! :wink:

Well…

  1. I can’t print without hplip.
    The tray printer icon flashes and instantly dissapears and nothing happens.

  2. I sanitized the PDF (with ps2ps), but nothing has changed.

Finally, I solved the problem partially.
I uninstalled the repository drivers, I installed the hplip ones (from SF.NET), and I delete the qeue with system-config-printer.
I set the paper size to A4 (with yast) and alligned the printer (with hp-toolbox).

Now seems to be OK, but the only problem is that it doesn’t print the bottom of the page (where the page numbers, are located).
Does someone, faced this problem?
G.

Did you install with hplip-3.14.6.run? You seem to have done all the right things. However, it sounds like the printer is still set to letter (8½ by 11 inches). Double click the hp icon in the task bar to start HP Device Manager. On the Print Settings tab, click the General line and confirm media size is really A4.
Regards,
Howard

On 2014-09-03 01:46, Thalassius wrote:
>
> Finally, I solved the problem partially.
> I uninstalled the repository drivers, I installed the hplip ones

Are you using the extra printing repo (I forget the name)? It has
corrected versions of some things. And maybe new problems as well.

> Now seems to be OK, but the only problem is that it doesn’t print the
> bottom of the page (where the page numbers, are located).
> Does someone, faced this problem?

American letter size is a bit smaller than A4, if I remember correctly.

Have a look at the printer options, not in YaST, but in the cups control
web page.


http://localhost:631

It is also possible that the printer thinks differently than cups; in my
case, I control it via the printer web page, not the hplip icon (which
actually I don’t have active, there was some problem).

My printer can be connected via USB cable and via Ethernet port. When I
bought it, I used the usb, till somebody told me than in Linux HP
printers worked best via network. And it turned up to be true… yes,
the hplip icon has some features I don’t have, but the overall result
and functionality is better: you don’t depend on the hplip volunteers
correctly handling your model, but instead you talk to it via the web
interface that is also available for Windows users, and thus it works
the same and is better covered.

If your printer does not have an Ethernet port… well, that’s unfortunate.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

**THANKS guys!!! ** :wink:

Indeed I run hplip-3.14.6.run and Device Manager indicates the correct (A4) size.

I tried all repository versions, including the printing one.
Only the Sourceforge version, results at normal speed printing.
Repository versions, has the additional problem of very low speed. :frowning:

Somehow, I can set a different (smaller) output, but even if it gets smaller and fits the paper, the bottom of page (the page numbers), still is not printable! :open_mouth:

And unfortunate it is, because Deskjet 1.000 is a cheap model, that has USB input only. rotfl!

What application gives this printing trouble? Do LibreOffice documents and Firefox web pages have the same trouble? It may be an application setting issue rather than a printer setting.
Howard

…and perhaps it is worth investigating the .ppd file in the /etc/cups/ppd/ directory. In particular, check the ‘*ImageableArea’ values for the paper size of interest. Maybe they are too conservative, and you can adjust them as necessary. You’ll need root privileges to edit the file, but give it a go and report back.

Hint: You can check out the imageable area (Media Dimensions) reported when you print a CUPS test page.

I tried other applications too.
Eg. Evince for PDFs.

CUPS test page:
Media Dimensions: 210X297mm.
Media Limits: 3X14 to 207X295mm

HPLIP test page:
Page Size: 203.7X280.9mm
Lower-Left: 3.2X14.5mm
Upper-Right: 206.9X295.4mm
Resolution: 300X300dpi
11781X11781dpm

/etc/cups/ppd/Deskjet_1000_J110.ppd:
*ImageableArea A4/A4 210x297mm: “9 41.040000915527 586.440002441406 837.359985351562”

Ehm…I don’t know what to do, with all those numbers. :slight_smile:
Test pages are both (CUPS and HPLIP) OK.
The entry of ppd file, seems a bit cryptic to me! :slight_smile:
G.

CUPS test page:
Media Dimensions: 210X297mm.
Media Limits: 3X14 to 207X295mm

HPLIP test page:
Page Size: 203.7X280.9mm
Lower-Left: 3.2X14.5mm
Upper-Right: 206.9X295.4mm
Resolution: 300X300dpi
11781X11781dpm

/etc/cups/ppd/Deskjet_1000_J110.ppd:
*ImageableArea A4/A4 210x297mm: “9 41.040000915527 586.440002441406 837.359985351562”

Ehm…I don’t know what to do, with all those numbers. :slight_smile:
Test pages are both (CUPS and HPLIP) OK.
The entry of ppd file, seems a bit cryptic to me! :slight_smile:
G.

Paper sizes can be measured in inches, mm, or point sizes.

http://www.printernational.org/iso-paper-sizes.php

The 'ImageableArea values appear to be point sizes, with top,left,right,bottom values defined (in that order). Comparing with the corresponding PaperDimension values, it looks like you have 9 points margin from top/bottom edges, and 41 points margin from left/right edges. That corresponds to ~3mm and 14.4mm respectively. So, maybe those values are okay after all. Anyway, I hope that’s clarified things for you.

You keep mentioning PDF. Do only PDF files print incorrectly? It looks like hplip reports the closest it can print to the bottom of the page is 14.5mm. Does the PDF file have text below that?
Howard

On 2014-09-04 23:46, Thalassius wrote:
> I tried other applications too.
> Eg. Evince for PDFs.

When I print from LibreOffice, on print dialog, printer properties,
device tab, I get below a line that says “printer language type”. I can
choose PDF or PS (3 versions). Left to automatics, it uses PDF, but I
get much better results with PS.

I don’t see that choice on other programs, though.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I don’t know about other file types!
The problematic document is PDF.
I didn’t show this error, in other types, but I don’t print frequently.

Ehm…I suppose the page number, but I’m not sure.

ΟΚ! Solved!

What was needed, is activating the option Print Settings -> Image Printing -> Fit to Page -> On.
Somehow is on by default in Windows, but the opposite (off by default) in Linux.

Switching it to “On” did the trick and now everything’s fine! lol!
THANKS!!!