HP Officejet 4500 wireless

I got the printer setup so that it prints, even wirelessly. What I am unable to do is get it to work with xsane. hp-setup is completely useless. It doesn’t even see my printer. Not on USB. Not on the network, and not wireless. I had to use YaST Printer to set it up. HPLIP is 3.10.5 downloaded directly from the hplip site.

direct hp “Unknown” “HP Printer (HPLIP)”

lsusb reveals
[43752.905073] usb 2-4: new high speed USB device using ehci_hcd and address 11
[43753.037952] usb 2-4: New USB device found, idVendor=03f0, idProduct=2e12
[43753.037964] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[43753.037969] usb 2-4: Product: Officejet 4500 G510n-z
[43753.037973] usb 2-4: Manufacturer: HP
[43753.037977] usb 2-4: SerialNumber: CN054H808J05HR
[43753.038139] usb 2-4: configuration #1 chosen from 1 choice
[43753.039410] usblp0: USB Bidirectional printer dev 11 if 1 alt 0 proto 2 vid 0x03F0 pid 0x2E12

yet the hp-setup doesn’t see the usb.
I have followed this page How to check my printer connection in Linux | HPLIP Knowledge Base and everything checks out till the end, then it doesn’t match. Which is this;
direct hp “Unknown” “HP Printer (HPLIP)”

I tried using YaST Scanner to configure the scanner. I got it to where it detects the scanner, and is in edit mode, but even when I do edit it, it doesn’t work.

Just to bring some closure to this.
I took back the Officejet 4500 wireless and exchanged it for the Officejet 6500. The 6500 is not wireless, but everything worked properly out of the box.

Glad to read the Officejet 6500 is working for you.

I have wireless scanning working on my HP All-In-One Premium C309a with openSUSE-11.2. I use xsane. I used yast to setup (where I believe YaST called hplip’s hp-setup). In my case I simply entered the printer/scanner’s IP address and it worked. I did not insist on YaST/hp-setup having to find the ip itself. Once setup I did not have to setup again.

In the case of the 4500 wireless, the usb id was wrong. I don’t know if it’s a bug with hplip or what. With the 6500, it was easy. No issues at all.

I don’t recall the USB ID being a factor when I setup my C309a. I did have to go to a manual configuration mode in the hp-setup (as it was not detected upon scan), and enter the ip address. I had a selection of many different devices (as there are many different C309a variants) with 2 different C309a’s to select from. I selected the 2nd one and it worked.

I never had to deal with USB ID until the 4500 wireless. The 6500, again, I did not have to “worry” about it.

I have a problem with a Photosmart C309g printer that is “mostly” on subject but has to do with updating the hplip application. Should I continue here? Or, start a new thread?


I recommend a new thread. Ensure you have a good subject title to get the attention/help you should be getting.