hp dv 9000 with opensuse 11.2 x86_64 does not hibernate

Hi,
I have been running 11.1 on this laptop for a year and hibernate worked great on that. I recently installed (not upgraded) 11.2. now when i try to hibernate, i get the suse hibernate screen up, the progress bar counts down some (maybe about %20) and then it seems to hang. I have to power off and start back up.
I am not sure where to look (logs etc) or what to look at, any help would be appreciated.

thanks

bump, anyone have any ideas?

I’m sure as hell no expert on the subject, but if you wan’t to check logs:
/var/log/pm-suspend.log.
Perhaps you checked already this link:
Pm-utils - openSUSE
There you should be able to find some tech info about the software that probably saves the powersuspence on your installation.
:shame:okay, that was not funny at all.

I’m having trouble myself on my PC with the hibernating function (shutting down works fine but the system crashes while starting up, so it’s definitely not the same problem as you experience) and was searching the forum.
I suspect a setting on my Nvidia graphics card (I had this issue before)
So now I’m searching for the right trick.

Good luck and keep searching. You’re probably not the first one with this problem and don’t forget to post the solution if you might find it.

ok, so, i cleared these logs out and tried to hibernate again. this is what I have…but i don’t know what it means.

pm-powersave.log

**sched policy powersave OFF
**set power mode for sound driver to 0 seconds
**wol -> enable, set flags g

pm-suspend.log

2010-01-25 10:57:54.733607364 -0500: running ‘hibernate’/‘hibernate’/’’ hooks.
===== 2010-01-25 10:57:54.774793609 running hook: /usr/lib/pm-utils/sleep.d/00clear =====
===== 2010-01-25 10:57:54.795577024 running hook: /usr/lib/pm-utils/sleep.d/01logging =====
hibernate initiated: Mon Jan 25 10:57:54 EST 2010

Linux TonyLaptop 2.6.31.8-0.1-desktop #1 SMP PREEMPT 2009-12-15 23:55:40 +0100 x86_64 x86_64 x86_64 GNU/Linux
kernel command line: ‘root=/dev/disk/by-id/ata-SAMSUNG_SSD_RBX_Series_128GB_M_DFF160S904SE904A1708-part2 resume=/dev/disk/by-id/ata-SAMSUNG_SSD_RBX_Series_128GB_M_DFF160S904SE904A1708-part1 splash=silent quiet vga=0x317’
Module Size Used by
nfs 405152 0
lockd 95636 1 nfs
fscache 52016 1 nfs
nfs_acl 4072 1 nfs
auth_rpcgss 56800 1 nfs
sunrpc 267112 5 nfs,lockd,nfs_acl,auth_rpcgss
cryptd 10832 0
crypto_wq 2064 1 cryptd
aes_x86_64 9576 1
aes_generic 29128 1 aes_x86_64
af_packet 28680 4
rfcomm 89960 4
sco 24076 2
bridge 75144 1
stp 3340 1 bridge
llc 8848 2 bridge,stp
bnep 23208 2
l2cap 50696 16 rfcomm,bnep
snd_pcm_oss 60032 0
snd_mixer_oss 22728 1 snd_pcm_oss
snd_seq 78528 0
snd_seq_device 10460 1 snd_seq
edd 13232 0
cpufreq_conservative 10360 0
cpufreq_userspace 4364 0
cpufreq_powersave 2152 0
powernow_k8 19340 1
fuse 87984 3
loop 22292 0
dm_mod 101544 0
arc4 2568 2
ecb 4168 2
cryptomgr 109904 0
snd_hda_codec_conexant 44424 1
aead 10792 1 cryptomgr
pcompress 3560 1 cryptomgr
crypto_blkcipher 18028 3 cryptd,ecb,cryptomgr
crypto_hash 17416 2 cryptd,cryptomgr
crypto_algapi 25904 10 cryptd,aes_x86_64,aes_generic,arc4,ecb,cryptomgr,aead,pcompress,crypto_blkcipher,crypto_hash
b43 175096 0
mac80211 257024 1 b43
snd_hda_intel 37184 2
snd_hda_codec 111112 2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 11216 1 snd_hda_codec
snd_pcm 117808 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 32152 2 snd_seq,snd_pcm
snd 97608 15 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
uvcvideo 74196 0
videodev 46848 1 uvcvideo
v4l1_compat 19020 2 uvcvideo,videodev
sr_mod 20964 0
amd64_edac_mod 39392 0
cfg80211 123264 2 b43,mac80211
ohci1394 38340 0
ssb 63512 1 b43
pcmcia 47292 2 b43,ssb
sdhci_pci 11048 0
sdhci 27628 1 sdhci_pci
btusb 20156 2
v4l2_compat_ioctl32 12776 1 videodev
mmc_core 83616 1 sdhci
bluetooth 122372 9 rfcomm,sco,bnep,l2cap,btusb
rfkill 28176 3 cfg80211,bluetooth
ricoh_mmc 5288 0
ieee1394 121024 1 ohci1394
joydev 14400 0
video 29156 0
pcmcia_core 50084 3 b43,ssb,pcmcia
cdrom 48232 1 sr_mod
sg 40128 0
edac_core 60788 1 amd64_edac_mod
k8temp 6440 0
snd_page_alloc 12600 2 snd_hda_intel,snd_pcm
forcedeth 68564 0
i2c_nforce2 10256 0
ac 6416 0
pcspkr 3720 0
battery 15824 0
wmi 9600 0
nvidia 9647368 41
button 8360 0
ext4 426040 1
jbd2 115616 1 ext4
crc16 2504 1 ext4
fan 6352 0
processor 56900 1 powernow_k8
ide_pci_generic 5484 0
amd74xx 8080 0
ide_core 148128 2 ide_pci_generic,amd74xx
ata_generic 6508 0
sata_nv 32084 2
pata_amd 16748 0
thermal 25160 0
thermal_sys 21888 4 video,fan,processor,thermal

         total       used       free     shared    buffers     cached

Mem: 955044 843408 111636 0 32048 333232
-/+ buffers/cache: 478128 476916
Swap: 2096472 44916 2051556

===== 2010-01-25 10:57:54.814424305 running hook: /usr/lib/pm-utils/sleep.d/02rtcwake =====
rtcwake alarm not enabled in /etc/pm/config.d/rtcwake.config, doing nothing…
===== 2010-01-25 10:57:54.821116239 running hook: /usr/lib/pm-utils/sleep.d/05led =====
===== 2010-01-25 10:57:54.826600173 running hook: /usr/lib/pm-utils/sleep.d/06autofs =====
===== 2010-01-25 10:57:54.880466545 running hook: /usr/lib/pm-utils/sleep.d/10NetworkManager =====
Error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
===== 2010-01-25 10:57:55.118284566 running hook: /usr/lib/pm-utils/sleep.d/30s2disk-check =====
INFO: checking for suspend-to-disk prerequisites…
using userspace suspend method
setting resume device to /dev/sda1
setting image size to 440084275
adding these parameters from /etc/suspend.conf:
===== 2010-01-25 10:57:55.198704920 running hook: /usr/lib/pm-utils/sleep.d/45pcmcia =====
ejecting PCMCIA cards…
===== 2010-01-25 10:57:55.296743676 running hook: /usr/lib/pm-utils/sleep.d/50modules =====
===== 2010-01-25 10:57:55.321625953 running hook: /usr/lib/pm-utils/sleep.d/80acpi-fan =====
===== 2010-01-25 10:57:55.328637595 running hook: /usr/lib/pm-utils/sleep.d/80videobios =====
===== 2010-01-25 10:57:55.333268439 running hook: /usr/lib/pm-utils/sleep.d/94cpufreq =====
===== 2010-01-25 10:57:55.383509335 running hook: /usr/lib/pm-utils/sleep.d/95led =====
===== 2010-01-25 10:57:55.403242867 running hook: /usr/lib/pm-utils/sleep.d/99Zgrub =====
INFO: running prepare-grub
Skipping grub entry #1, because it has the noresume option
running kernel is grub menu entry 0 (vmlinuz-2.6.31.8-0.1-desktop)
preparing boot-loader: selecting entry 0, kernel /boot/2.6.31.8-0.1-desktop
grub-once: saving original /boot/grub/default
running ‘/usr/sbin/grubonce 0’
Using entry #0: Desktop – openSUSE 11.2 - 2.6.31.8-0.1
time needed for sync: 0.4 seconds, time needed for grub: 0.0 seconds.
===== 2010-01-25 10:57:55.933855008 running hook: /usr/lib/pm-utils/sleep.d/99info =====
2010-01-25 10:57:55.939203147: done running hibernate/hibernate hooks.

  • /usr/sbin/s2disk --config /var/lib/s2disk.conf

also, i disabled the splash screen and i see that s2disk start to create the snapshot and it never comes back

I’ m very sorry that I lack the skills to help you.
Anyone, please?

It’s useful to post the specs of your hardware. You know: type and size of your hard drive, amount of memory (perhaps it’ s not sufficient to contain your suspended system?), gui (kde, gnome, etc.).
Perhaps that will encourage others to step in.

my system:

hp dv9000
128gig SSD
1gig ram
2gig swap partition
using gnome desktop

please let me know if any other info would be helpful

thanks

Well, it’ s not the amount of internal memory, that’s for sure.

Saw this post on the forum: maybe this is helpful, although it’s not the same brand of laptop:
Perfect Suspend to RAM on Gateway LT3114u Netbook - openSUSE Forums

Be sure to have a backup-plan when this somehow nukes your system when you try to suspend with this solution set. Unlikely to happen, but what’s wrong with a little risk management? With the installation DVD or live CD at hand, you can then fire up your laptop, mount your hard drive and open the changed file, and lose the alterations.
Perhaps you need not be warned, but better save then sorry;).

Good luck!

suse 11.2 kde 4.4.0 4gbram dell xps m1530
If I click on hibernate (suspend to disk only, suspend to ram is ok) no suspending happen, only lock of screen, why this??

I have been kind of frustrated because no one seems to have any insight on this. I still cannot hibernate to disk…anyone have any idea’s?

I found somethin here,

Restarting “dbus” is not really good, even it partially solving the problem.

The real final fix was to edit my .xinitrc file end replace
Code:

exec $WINDOWMANAGER

by
Code:

exec ck-launch-session $WINDOWMANAGER

did you tryed it???

if suspend to RAM is working - it’s not a powerdevil issue…
Did you check you have enough of swap space?.. (should be same or bigger amount as RAM to make hibernate working)

also you may try “powersave -U” from the command line as root user just to see if it works in general, or not at all…

Rgds,
-Dimitri

RAM 4GB swap 8GB

I tryed powersave -U with no results, nothing happen, as user and root:
pla@linux-dvkc:~/Documenti> powersave -U
method return sender=:1.0 -> dest=:1.152 reply_serial=2
int32 1
pla@linux-dvkc:~/Documenti> su
Password:
linux-dvkc:/home/pla/Documenti # powersave -U
method return sender=:1.0 -> dest=:1.177 reply_serial=2
int32 1
linux-dvkc:/home/pla/Documenti #

Really strange… - while suspend to RAM very often model-specific, the hibernate feature now days should work out of the box.

May you try also to execute “pm-hibernate” as root user?..

If it doesn’t work either - what is your graphic card? - I’ve got several issues with nVidia on my old Toshiba before (and seems the original post about “hp dv 9000” has a similar problem - and the solution was described here: NVidia Suspend HOWTO - openSUSE )

then you may try this howto: Suspend to disk - openSUSE and if still nothing works, probably boot with vesa/failsafe and enter into debugging…

Rgds,
-Dimitri

Yes I remember that when I was on kde3.5 it worked well, but I don’t use it frequently cause I prefer suspend on ram and I realized now.

Tryed but don’t work, no error messages only execute the command, some reaction by network switched down but no suspend occurred.

I have nvidia 8600gt, I will try that threads.
Thanks.