[HowTo:] Install Citrix Receiver for Linux 64bit on openSUSE 13.1

I am still quite new to openSUSE, been using about a week now, and am really loving it. I had to install Citrix Receiver 13 for work, and found all the information I needed but it was dispersed throughout many areas. The installation on 64bit systems can be a bit tricky since Citrix is a 32bit based product, with minimal adaptation for 64bit. I would like to make the process easier for anyone else having issues with version 13 on openSUSE 13.1. Thought I would just create a concise consolidated howto that provided all the information in one place. Hopefully someone can find this helpful!

Install required 32-bit libraries via YaST

1.] In YaST make sure to install ALL of the following libraries. I used YaST for this to visually inspect everything before installing and, YaST will find all additional dependencies required.

[li] List of 32-bit libraries to be installed is: [/li][/ul]
[INDENT=2] libX11-6-32bit
[INDENT=2] libXext6-32bit
[INDENT=2] libXrender1-32bit
[INDENT=2] libXinerama1-32bit
[INDENT=2] libpng12-0-32bit
[INDENT=2] libgthread-2_0-0-32bit
[INDENT=2] libgtk-2_0-0-32bit

Via Terminal, install the RPM package

2] In Terminal: Install RPM via Zypper as Root:

zypper install ICAClient-
      [i]Ignore the long list of warnings about missing dependencies: lib32asound2 and nspluginwrapper. The installation will work without these libraries, as they are brought in later.

[li] Select Option # 3 [/li][/ul]

3.] Check there are no missing dependencies:

 ldd /opt/Citrix/ICAClient/wfica
You should now see a long list of dependencies and their locations listed. This validates all dependecies are installed correctly.[i] If you see [b][u]not found[/u][/b] in the output:


[li]Uninstall the Citrix ICA Client: zypper remove icaclient [/li][li]Install the missing packages that were listed. [/li][li]Reinstall the Citrix ICA Client: zypper install ICAClient- [/li][/LIST]

File Associations

4.] If using KDE, edit the file association application/x-ica.

[li] Click Kicker start menu, search term “Association” and open File Associations [/li][li] In File associations search “x-ica” and click on this file type in left pane. [/li][li]Add a new application: /opt/Citrix/ICAClient/wfica.sh [/li][/ul]

Check correct file association in FireFox (not needed for chrome)

[li] If you’ve had firefox open, close and restart it. [/li][li] Go to ‘Menu>Preferences>Applications’ [/li][li] Make sure Citrix ICA settings file is set to “Use Citrix Receiver for Linux (in Firefox)” [/li][/ul]

This is all it took for me to get Citrix Client v13 up and running without a hitch. Some of the items I saw from other pages/post/etc appeared more apt to issues if the correct order was not followed during installation. I had no issues with making sure all basic dependencies were met prior to installing the RPM. I had same issues others had when I attempted installing on my workstation with Arch, so I learned a little from that experience as well.

CA-Certificates errors:[INDENT=4] [* Thanks to openSUSE user TimothyVD]
‘/usr/share/ca-certificates/mozilla’ is not available anymore. So a symbolic link to the ssl certificates directory is a workaround.

 ln -s /etc/ssl/certs/* /opt/Citrix/ICAClient/keystore/cacerts/

Citrix System Requirements
Official Citrix Receiver 13.0 Installation Guide
openSUSE Forum post by rbarsoianu
eek, a Geek! Blog- Citrix Receiver 13 on openSUSE 13.1 - Install Guide
SuperUser.com - Citrix 13 Install Guide for Debian

Download 64bit Citrix Receiver for Linux RPM

hello munkyBeatz

thank you for your post, it was very helpful


Hi Fellow Susers,
I followed the procedure, but reciever fails silently.
Are there debug logs available anywhere?


Hello, thanks for the great tutorial. I need the Citrix receiver to work as well for my job, but after following your guide I still get the SSL error:

You have not chosen to trust "thawte SSL CA - G2", the issuer of the server's security certificate (SSL error 61).

I also tried to import the certificate from Thawte website to Firefox and that does not help either.
Are there any other necessary steps to do?

Good evening, pumrel, try https://forums.opensuse.org/showthread.php/499168-Citrix-Error-61-(-quot-not-chosen-to-trust-quot-)-All-files-and-certificates-seem-to-be-correct

Thank you thank you thank you!!!

I have been trying to get this to work for 6 months. i am bookmarking this page!

hello you all

many thanks for this thread. had various issues with the installation
but i will try all your hints later the weekend.

many thanks for all - i also will bookmark this thread!

Another link where to look for solutions of error (SSL error 61) is

You have no idea how much I have looking for a solution about the certificate. You saved my day cos I was going to use Ruindows in dual boot just because the Citrix hahaha. Thanks so much

hello dear whiiiskyy

many thanks for the mail . glad that it also helped you. i am happy too

Update to the original post.

The new Citrix Receiver 13.3 does not need the 32-bit libraries anymore, download the RPM and install it with YAST. YAST will fix the dependencies necessary.
If you get the SSL 61 error you still need to create the SSL certificates sym links to the ICA clients certificate folder, as outlined in the post.