Howto escape full screen guest?

I’ve been looking all over and can’t seem to come up with the answer.

tia,

Wil

On 2015-05-24 14:36, WilNix2k wrote:
>
> I’ve been looking all over and can’t seem to come up with the answer.

What virtualization technology?


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

And what exactly are you talking about?

VMWare? VirtualBox? Anything else?
Might make a difference.

For VMWare the key combination to switch to/from full screen mode seems to be Ctrl+Alt+Enter.
For VirtualBox it should be “Host”+F, where the “Host” key normally is the right Ctrl key.

Xen using VMM

Never used that.

But this might help:
http://askubuntu.com/questions/43861/how-do-i-unmaximize-full-screen-view-in-virt-manager

Although I don’t use Xen,
If you’re using libvirt with Xen, then Guest display management should be the same as in KVM.

If you position your cursor at the top middle of your screen, a tab should drop down which enables you to manage your display, including exiting Full Screen.

TSU

Thanks TSU,

Your right it should be. However with a little testing I find when it I first the console into full screen that drop down pops up briefly, then disappears. I ran my mouse all across the top of the screen and it will not make the menu reappear. My best solution thus far has been to move the pointer into the upper left corner to display the open apps and just X out of the console, and reopen if needed which make it a window again.

Go figure;-)

Wil

Another oddity I’ve noticed is that if I minimize VMM, I can no longer restore it. I have to close it and relaunch it to get to the GUI again.

FWIW

Wil

It’s been a very, very long time since I personally experienced what you described… I think it was about 6 yrs ago… IIRC I discovered then that when I went to full screen with a Guest for whatever reason my physical monitor shifted the display slightly and some edges or sometimes the overall geometry of the display was off a few pixels… and as you’re discovering if the display doesn’t display those edge pixels, your mouse won’t activate things like that dropdown tab.

So, I recommend that once you’re in full screen mode, experiment a little bit with your monitor settings, there usually is something that makes the entire display slide left-right and up-down.

TSU

The inability to drop out of full-screen mode is a bug that has been introduced between versions 13.1 and 13.2.

Fortunately I have a dual-screen so my task bar is always available and I can follow this procedure to get it out.

  1. Right click on the task-bar icon for the VM
  2. Select More Actions -> Fullscreen

The VM now has window decorations

  1. Increase the height of the window and you can now reach the menu at the top of the VM’s window and fully drop it out of full-screen mode.

As for the VMM manager disappearing when minimised, check if you have the “Enable system tray” option set. If so the VMM icon might be in the system tray rather than on the taskbar

NOTE: I haven’t got around to submitting a bug report yet…

I assume you’re describing what I saw long ago…
When you say “increase height of window” you’re really talking about the physical display settings of your monitor. Technically speaking a “window” has a different meaning, it’s an object on the screen that can be re-sized full screen, less, and minmized.

If it has re-appeared, the relevant monitor settings are

  • adjust the height of the display
  • shift/slide the display

TSU

No, I meant increase the height of the window.

The menu is dropping down behind the guests screen instead of on top.