How use Dolphin to "open containing folder" from firefox downloads?

When I right-click on a file in my firefox downloads window and choose “open containing folder”, it opens the folder in EasyTag. I tried both of the below “solutions” and logged out and logged back in to openSUSE and it still uses EasyTag! Is it because I need a restart or is it something else?

Neither one has worked yet…
Open Containing Folder in Firefox under Linux

Even after restart, it’s still opening the folder in EasyTag. Does anyone have a solution?

I sort of finally got it to work. I renamed “/usr/share/applications/easytag.desktop” to “/usr/share/applications/easytag.desktop-old” and now it’s finally opening in dolphin. This means that somewhere there’s something still pointing to easytag to be used for opening directories! I don’t know why as I set inode/directory and x-directory/normal in “/usr/share/applications/mimeinfo.cache” and “~/.local/share/applications/mimeapps.list” to point to kde4-dolphin.desktop. Is there another place this mapping exists that I’m missing?

Here’s EasyTag’s desktop file:

[Desktop Entry]
GenericName=Audio File Tag Viewer/Editor
Comment=EasyTAG is an utility for viewing and editing tags for MP3, MP2, FLAC, Ogg Vorbis, MusePack and Monkey's Audio files, with a GTK+ GUI.
Comment[cs]=EasyTAG je utilita na prohlížení, editaci a zápis tagů do vašich MP3, MP2, FLAC, Ogg Vorbis, MusePack a Monkey Audio souborů.
Comment[da]=Et program til at vise/redigere MP3 og Ogg Vorbis tags med et GTK+ interface.
Comment[de]=EasyTAG ist ein Werkzeug zum Anschauen, Editieren und Schreiben von Tags Ihrer MP3-, MP2-, FLAC-, Ogg Vorbis-, MusePack- und  Monkey's Audio-Dateien.
Comment[es]=EasyTAG es una utilidad para ver, editar y escribir etiquetas a tus archivos MP3, MP2, FLAC y Ogg Vorbis.
Comment[fr]=EasyTAG est un utilitaire pour visualiser et éditer les tags des fichiers MP3, MP2, FLAC, Ogg Vorbis, MusePack et Monkey's Audio avec une interface GTK+.
Comment[hu]=Az EasyTAG egy GTK+-on alapuló címkenéző és -szerkesztő segédeszköz MP3, MP2, FLAC, Ogg Vorbis, MusePack és Monkey's Audio fájlokhoz.
Comment[it]=EasyTAG è programma per vedere, modificare e scrivere i tag dei file MP3, MP2, FLAC, Ogg Vorbis, MusePack e Monkey's Audio.
Comment[ja]=EasyTAG は MP3, MP2, FLAC, Ogg Vorbis, MusePack と Monkey's オーディオ・ファイルの ID3 タグを表示したり、編集するためのツールです。シンプルでクールな GTK+ インタフェースを採用しているので、GNU/Linux で簡単にタグの編集ができます。
Comment[nl]=EasyTAG is een programma voor het bewerken van tags van MP2-, MP3-, FLAC-, Ogg Vorbis, MusePack en Monkeys Audio-bestanden. Dit gebeurt in een verzorgde GTK+-omgeving.
Comment[pl]=EasyTAG jest narzędziem do przeglądania, edytowania i zapisywania tagów w plikach MP3, MP2, FLAC, Ogg Vorbis, MusePack i Monkey's Audio. Jego prosty i miły interface wykonany w GTK+ ułatwia tagowanie.
Comment[ro]=EasyTAG este un utilitar pentru afisarea, modificarea si scrierea etichtelor fisierelor MP3, MP2, FLAC, Ogg Vorbis, MusePack si Monkey Audio. Interfata sa simpla (GTK+) face etichetarea mai simpla.
Comment[ru]=EasyTAG -- это программа для просмотра и редактирования тегов в файлах MP3, MP2, FLAC, MusePack, APE и Ogg Vorbis с удобным интерфейсом GTK+ для GNU/Linux.
Comment[sv]=EasyTAG är ett verktyg för att undersöka, editera och skriva taggar för dina MP3-, MP2-, FLAC- och Ogg Vorbis-filer, och använder ett enkelt och trevligt GTK+-gränssnitt.
Comment[uk]=EasyTAG - утиліта для перегляду, редагування та запису тегів у файли MP3, MP2, FLAC, Ogg Vorbis, MusePack та Monkey's Audio. Простий та приємний інтерфейс GTK+ допоможе процесу запису тегів.
Exec=easytag %F

I don’t see where that could be registering it for opening directories either. What am I missing?

Anyone have an idea?


You can set that in the firefox preferences->applications tab. Did you try it?

On 04/01/2011 09:06 AM, 6tr6tr wrote:
> Anyone have an idea?

Not sure I understand your question. If I download something in Firefox
and save it in, say ~/Documents I just open Dolphin, go to ~/Documents
and click on the file. If I create a different folder when downloading,
I just go to that folder in Dolphin. What’s the problem you’re having?

Kevin Miller
Juneau, Alaska
“In the history of the world, no one has ever washed a rented car.”

  • Lawrence Summers

On 04/01/2011 07:06 PM, 6tr6tr wrote:
> Anyone have an idea?

it is easytag that seems to have hyjacked the system and not allow
Dolphin to do as it should, right?

so, i look in the openSUSE repos and i don’t find easytag, therefore i
can only conclude:

-it is a bad actor in openSUSE, or
-it had a faulty install, or
-after its install it was damaged in some way

how did you install easytag?
did you have any errors when you installed it?
did it ever work correctly AND not interfere with Dolphin?

Tried LibreOffice? Do that and help at
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

I installed it via YAST.

CLARIFICATION: It only uses EasyTag to open a folder when I right-click in the Firefox Downloads Window and select “Open Containing Folder…”. If I am in Dolphin, it continues using dolphin.

EasyTag has definitely taken “responsibility” for opening files that it should not be opening. But basically this is a question for anyone who understands the mime-handling of a KDE/OpenSUSE system. There seems to be some place where it’s still being “told” to use EasyTag to open folders. I changed mimeinfo.cache and mimeapps.list but still it looks for EasyTag, so I’m thinking there’s another file out there that’s consulted by the system.

No you can’t. Nowhere under that tab is a mime type for folders, and it won’t let me add anything to it.

Oh! I thought there was… Sorry… :\

6tr6tr wrote:

> Anyone have an idea?

Just WAG’s, but

Perhaps it is related to an extension? Does this also happen when you run
firefox in safemode? For a new user?

Have you searched in the “about:config” settings for something that might
seem related?


On 04/01/2011 09:23 AM, Kevin Miller wrote:
> On 04/01/2011 09:06 AM, 6tr6tr wrote:
>> Anyone have an idea?
> Not sure I understand your question. If I download something in Firefox
> and save it in, say ~/Documents I just open Dolphin, go to ~/Documents
> and click on the file. If I create a different folder when downloading,
> I just go to that folder in Dolphin. What’s the problem you’re having?
Nevermind - I jumped into the thread late. Just read the original post…

Kevin Miller -
Juneau, Alaska
In a recent survey, 7 out of 10 hard drives preferred Linux
Registered Linux User No: 307357,

That should be easy, for example, to me happen that once, my default open folder conteiner was thunar, i uninstall it, next i restart firefox and try open folder, firefox tell that had no application to open folder and ask me to select one…i put /usr/bin/dolphin…

Could be a KDE setting, try systemsettings - default applications - file manager - other
There you can add/remove applications, if there’s EasyTag on the list, remove it.

M solution to your problem, which was identical to mine, was to uninstall easytag. I also had it opening directories when I opened a directory pinned to the panel/desktop. I have no idea why it decides to do this.

Try kid3 or pinkytagger instead. I use kid3.

it really was easytag. When running update-desktop-database it recreates mimetypes. The order of applications was incorrect. You should delete smth like “inode/directory” in the “MimeType” line of /usr/share/applications/kde4/<undesired_app_name>.desktop
Where undesired_app_name is the app that you don’t want to see. For me it was gwenview :frowning:

sorry for my english.

P.S. just delete “inode/directory;”, don’t touch useful associations ;). After editing the file run update-desktop-database

look for the answer from Peter Vollebregt in this thread.

in short: create a file ~/.local/share/applications/defaults.list with this contents:
[Default Applications]

if some other application (eg gimp) opens to view PDF documents, you
can redirect this to okular by adding the following line:

At some point after upgrading from openSUSE 13.1 (fresh install) to openSUSE 13.2 (zypper upgrade) the Firefox dolphin integration was lost. Instead of dolphin the GTK file manager is started.

The proposed solution with the defaults.list file does not work for me.

Is there an updated solution for openSUSE 13.2?

There is no “Firefox dolphin integration”.
Firefox has a KDE integration, that makes it use KDE’s file dialogs e.g., but that’s totally unrelated to dolphin.

Instead of dolphin the GTK file manager is started.

You mean when you click on “open containing folder” in Downloads, as the thread’s subject says?

See those posts for workarounds:!?p=2687728#post2687728!?p=2687953#post2687953
Or uninstall nautilus, the “GTK” (GNOME actually) filemanager you probably mean.

Thanks for the hints. I did it like this and it worked:

$ locate org.freedesktop.FileManager1.service
Edit this file as root and comment out the last line:

[D-BUS Service]
# Exec=/usr/bin/nautilus --gapplication-service

Note that this has to be done everytime the file gets overwritten.[/FONT]