How to use a specific permissions file

I have created a specific permission file “/etc/permissions.custom”
As a test it contains :

/home                                                                                                                     root:root     755
/home/user_install                                                                                               user_install:users     755
/home/user_install/.config/Kate                                                                                  user_install:users     700

I have tried different command with chkstat but the permissions on the folder “/home
/home/user_install/.config/kate” does not change and stay 755

How to use a custom permissions file.

Provide the link to documentation that describes this file.


man chkstat

Have made change in first paragraph of ‘/etc/sysconfig/security’

In additions see permissions.local


I am trying to use this file in place of mine.

/etc/sysconfig/security contains :


/etc/permissions.local contains :

/home/                                                                                                                       root:root     755
/home/user_install_vb/                                                                                               user_install_vb:users     755
/home/user_install_vb/.config/                                                                                       user_install_vb:users     700
#/home/user_install_vb/.config/kate/ --> should be    user_install_vb:users     755
/home/user_install_vb/.config/kate/                                                                                  user_install_vb:users     700

all files /etc/permissions.* are 644 root:root

I got this error :

user_install_vb@localhost:~> sudo chkstat --system --set /etc/permissions.local
/etc/permissions.local: cannot verify root:root 0644 - not listed in /etc/permissions


user_install_vb@localhost:~> chkstat --system --set /etc/permissions.local
/etc/permissions.local: cannot verify root:root 0644 - not listed in /etc/permissions

It seems that the good syntax is :

user_install_vb@localhost:~> chkstat --system 
Checking permissions and ownerships - using the permissions files
setting /home/user_install_vb/.config/kate/ to user_install_vb:users 0700. (wrong permissions 0755)

Any comment is welcome

PS : from

Creating a drop-in file in the folder /etc/permissions.d/ works also if using the syntax :

chkstat --system