How to uninstall KDE and all its applications?


I’m trying to create a separate installation of openSUSE Tumbleweed that is like the GNOME Next live image ( with the latest developmental release of GNOME installed from the GNOME:Next repository. To do this I ran this command (where /opensuse is a mounted filesystem containing a complete openSUSE Tumbleweed system with KDE and GNOME desktops installed, /gnome-next is a filesystem that is to house this new Tumbleweed with GNOME:Next installed):

rsync -axHASX /opensuse/ /gnome-next

now I would like to uninstall KDE, then after that I’ll add the GNOME:Next repository. So how do I uninstall KDE? What I thought would do the job was:

zypper rm -t pattern kde

but it just gave the output:

Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following package is going to be REMOVED:

The following pattern is going to be REMOVED:

1 package to remove.
After the operation, 49.0 B will be freed.
Continue? [y/n/...? shows all options] (y): y
(1/1) Removing patterns-kde-kde-20170319-13.1.noarch .....................................[done]
There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.

After this I thought maybe running:

zypper dup

might remove it after it realizes the KDE pattern was uninstalled, but nope it just upgraded packages for me. Also tried:

zypper rm -t application "KDE Plasma Desktop"

that only removed a small number of packages. Also tried:

zypper rm "patterns-kde-kde*"

that also removed only a small number of pattern packages. So what do I need to do to remove all KDE packages?

Thanks for your time,

Tried out:

zypper rm *kde*

which removed quite a few packages, but I’m not sure if it’s all KDE-related packages.

Why do you want to remove all those packages? Just don’t use them. Or are you having not enough disk space?

Mostly just wouldn’t use it, but saving disk space isn’t a bad thing either. Must admit I do not see why you would need to know this in order to help me with it, but nonetheless if I’m wrong and it somehow does there it is. The copy (rsync) didn’t really work, when I tried to boot it I got several systemd service failures (related to the inability to mount subvolumes). Does this mean I should start a separate thread about these issues or will this thread suffice?

I think you missed a bit on how these forums work. We are users, like you, and try to help other users in their spare time. That means that some mebers will just browse through those sub-forums they think they are able to contribute for titles of new threads where they think they can help… When you thus hide a systemd (or is it rsync) question deep within a thread about KDE removal, your change is that you will not draw the attention the people of you need to help you.

Must admit I do not see why you would need to know this in order to help me

Maybe read this: Describe the goal, not the step
It is often seen that when people got a direct answer to their straight forward technical question, they were even further away from their goal then before. And fellow users that know what you are after are really better in offering you other ways to your solution.

In this particular case, there is no obvious way to just remove all things KDE. And in most cases there is no need at all doing it. When people want to try another desktop, they simply install the Pattern with YaST (when not already done) and choose the desktop they want from the login screen. Thus, seeing your, for most somewhat peculiar question, I asked for some background information. And no I do not need an answer (and no, I am not obliged to post here anything more if you do or don’t). And no, I do not know a 100% way of doing what you asked, except installing a fresh system with Gnome as the desktop (and of course never add then an application that comes from the KDE world and will perfectly run on Gnome, but draw in a lot of KDE dependencies).

Thanks for your reply. I thought it would be inappropriate, but no harm in asking eh? Anyway I found a nice, simple solution to the rsync issue. As for describing the goal, must admit I thought uninstalling KDE was the goal, but I suppose I could step further back and describe the more general goal.

Reinstalling Tumbleweed without KDE is a pretty lousy option for me, my laptop has a Broadcom BCM4352 WiFI chip and as Tumbleweed is installed from the net instead of from packages from the ISO it means I have to connect up an ethernet cable, which is irritating. That combined with the fact that Tumbleweed takes longer for me to install than any other distro makes it a choice of last resort. I actually had thought of that option before I decided to take the rsync approach, but thanks for trying to help. :slight_smile:

You could also run “zypper rm libkf5*” to remove all KDE Frameworks5 libraries, which should also remove all applications using them.
Won’t affect KDE4 applications, but you should have gotten rid of them already with your command anyway.

IMO there is no real option to remove an entire Desktop, particularly if it’s the first Desktop installed on the system.
There is a difference between a clean installation and adding an additional Desktop to an existing system… There are a number of base subsystems installed by the first Desktop installed, and every additional Desktop will use them instead of installing their own. I found this to be especially noticeable installing the Enlightenment Desktop different ways, and you’d be surprised how many different ways your configuration options on first boot can change. And, I also found some less drastic but still significant issues adding LXDE, LXQt and MATE to KDE vs any other Desktop.

So, if you <really> want a Desktop experience the way it’s supposed to be,
Although I haven’t generally found any recommendations/prescriptions, I do recommend re-installing and selecting a First Desktop with care.

As for installing Tumbleweed,
You can download the current DVD and not do a net install if you wish.


The DVD image still requires internet access to install Tumbleweed, as it installs the latest packages and in order to check for them (so it knows whether it can use those in the DVD image or whether it will need to download them) it needs the net. Leap doesn’t though, it just installs from the DVD, the old fashion way.

What you describe would have been surprising, but I decided to verify anyway.

Set up an install with an active network connection, but without access to the internet.

Installed a default XFCE using the current TW DVD image,
Everything went smoothly with no problems.
Once the system booted up for the first time, it displayed a notification that updates were needed, but otherwise the system appears to work flawlessly.


That’s surprising, I recently installed Leap and it went the way you describe but I do recall installing Tumbleweed and it required internet access. I suppose I may have mixed it up with Fedora… Thanks for correcting me though, without being correctly we cannot grow. :slight_smile: