How to switch from Radeon to amdgpu?

Hello,

currently I am running the radeon driver as seen here:

bbuske@benbuske:~$ sudo lspci -nnk |grep -A3 VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R2 Graphics] [1002:9853]
        Subsystem: Hewlett-Packard Company Device [103c:22cd]
        Kernel driver in use: radeon
        Kernel modules: radeon

How can I switch to use the amdgpu driver instead… Looks like the radeon open-source driver is causing issues with some of the Steam games and there graphics.

Thanks in advanced, cheers,

On Tue 27 Dec 2016 06:56:01 PM CST, bbuske wrote:

Hello,

currently I am running the radeon driver as seen here:

Code:

bbuske@benbuske:~$ sudo lspci -nnk |grep -A3 VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices,
Inc. [AMD/ATI] Mullins [Radeon R2 Graphics] [1002:9853] Subsystem:
Hewlett-Packard Company Device [103c:22cd] Kernel driver in use: radeon
Kernel modules: radeon

How can I switch to use the amdgpu driver instead… Looks like the
radeon open-source driver is causing issues with some of the Steam games
and there graphics.

Thanks in advanced, cheers,

Hi
You could give my AMD repo a try (I use it with a Mullins R5 GPU and
your card is present in the modinfo output);
http://download.opensuse.org/repositories/home:/malcolmlewis:/AMDgpu/openSUSE_Leap_42.2_Update/

Make sure your kernel is up to date 4.4.36-8-default and install all
three files amdgpu-4.4.36-2.1, amdgpu-kmp-default-4.4.36_k4.4.36_8-2.1
and xf86-video-amdgpu-1.2.0-2.1 reboot and see how it goes.


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hello,

thanks for the reply.
Sounds like a good plan, since you mentioned my GPU.
I do have the kernel version mentioned and I have

xf86-video-amdgpu though it is 1.1.0-1.4

I do not have however

amdgpu-4.4.36-2.1
amdgpu-kmp-default-4.4.36_k4.4.36_8-2.1

I do also have some libdrms for gpu.

Where do I get those packages? Are they part of the repository of yours?

Hi
Only need the three files, the rest are system ones and are fine, by adding the repo;


zypper ar -f -g -n "AMDgpu" http://download.opensuse.org/repositories/home:/malcolmlewis:/AMDgpu/openSUSE_Leap_42.2_Update/ AMDgpu
zypper ref
zypper dup --from AMDgpu

The kmp has the CIK switch enabled, by default for 42.2 this isn’t enabled for the older GCN cards, in Tumbleweed it is… The amdgpu package contains the blacklist and a default amdgpu configuration to get you started, see ;

The 1.1.0 xf86-video-amdgpu does not have the fixes for the mullins card they only arrived (after bug fixes) in 1.2.0, hence you need this as well.

FWIW, I have steam running on my system, seems to work fine for the few old linux games I have and a few newer demos for testing.

Ok, I have followed all the steps, including the Vendor Change to get your xf86 package installed. However, it does not work. Upon the reboot I am being thrown right into the terminal, no GUI Login.

bbuske@benbuske:~$ sudo lspci -nnk |grep -A3 VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices,
Inc. [AMD/ATI] Mullins [Radeon R2 Graphics] [1002:9853] Subsystem:
Hewlett-Packard Company Device [103c:22cd] 
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

I suppose it should now say amdgpu where it mentions the Kernel Driver in use… Otherwise the system works fine. From the console, I was able to undo the changes and get back into the system without issues.

Just speculation from my part (I don’t have this hardware), but as well as blacklisting the radeon kernel module, there should be a minimal config file to load the amdgpu module eg /etc/X11/xorg.conf.d/30-amdgpu.conf

Section "Device"
        Identifier "AMD"
        Driver "amdgpu"
EndSection

I see that the link provided by Malcolm already mentions…

Section "Device"
   Identifier "AMD Graphics Core Next GPU"
   Driver "amdgpu"
   Option "DRI" "3"
   Option "TearFree" "true"
EndSection

https://build.opensuse.org/package/v…-conf?expand=1

Rebuild your initrd … you can see what modules are currently in your initrd with “lsinitrd”

sudo lsinitrd | grep gpu

… and I’m willing to bet that its currently the radeon

Once you rebuild, the blacklisting will get applied to that as well and the amdgpu should be loaded.

Hello,

sorry for the delay. With Christmas and new year celebrations and I have been away from the computer for some days.

Thanks for what you have mentioned. The amdgpu-conf ist already there as part of the package and is exactly as what has been mentioned above.
I did not find the amdgpu-blacklist though, that is mentioned in the package. However, I have added

blacklist radeon

to the mod blacklist-conf in /modprobe.d. This did not work still. Rebooting the machine brought me back into the terminal. The GDM did not start. Had to remove amdgpu and amdgpu-kdf and it worked again.

Any more help or advice would be appreciated!

Happy new year, cheers,

Ben

Hi
There should have been a /etc/modprobe.d/50-radeon.conf file? Did you run the command mkinitrd after install the kmp and amdgpu packages?

Thanks Malcolm, that worked.

I have forgotten to do the mkinitrd. It was mentioned before and I had that in mind as well, but somehow I forgot doing it. It did the lsinitrd |grep vga but I never went ahead to rebuild it. Sorry about that… :slight_smile: Glad it works now. Thanks a lot Malcolm and the rest of you. Here is the console output:

benbuske:~ # sudo lspci -nnk |grep -A3 VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R2 Graphics] [1002:9853]
        Subsystem: Hewlett-Packard Company Device [103c:22cd]
        Kernel driver in use: amdgpu
        Kernel modules: radeon, amdgpu

Now just one question remains: When is this supposed to be coming to 42.2, without having to rely on this experimental solution?

Cheers,

Ben

Hi Ben
AFAIK it won’t… 42.3 and available now in Tumbleweed. You could raise a bug report and ask though as it needs the newer xf86-video-amdgpu driver a release above the default, then it needs the CIK enabled and the kernel rebuilt…

openSUSE:Submitting bug reports - openSUSE

Thanks for the reply once again.

Well… that sounds like a lot of trouble and work to go through… Especially since I am not sure, how many users are facing the current issue, using this line of AMD chips… My question was more out of curiosity. As long as this driver works as it is, I am absolutely fine with it. This laptop is being used for work mainly anyways and games I am playing on it are fairly old… we are talking of games such as Panzer General Assault, Starfleet Academy, etc. with some more up to date Steam Games, such as Hearts of Iron III and IV…

I do have a desktop, which is mainly used by my daughter, but it has a Nvidia chip and I have moved to use that for playing any more graphic intensive games… :slight_smile: Going to look forward to 42.3 though… or maybe if I get tempted again, I gonna give Tumbleweed a try on the desktop… I did not want to use it on my laptop, because it is my main work computer and it has a lot of important and sensitive information… I know it is reliable for the most, but knowing that AMD chips and fast paced updates sometimes don’t get along too well, I decided to play safe on that one.