How to stop screen off/standby in KDE desktop even though all settings are seemingly correct?

If anyone could help, I would be very grateful.

How can I stop the **** screen going into standby every ten minutes or so, and yes I have all settings in the ‘display’ & also ‘power management’ areas of system settings set correctly ie. screensaver disabled, dim display after… disabled, turn off display after… disabled.

It’s really annoying. Has anyone else got this happening (12.2)?

Well, a simple way to ‘practically’ disabling screen going off, is to enable ‘Dim Display’ and ‘Screen Energy Saving’ in ‘Power Management’, and set their values to something really big, like 360 minutes for example.

In KDE there is another setting that, if not present, can allow your screen to go blank. There are three places that can cause this in KDE:

  1. Screen Saver Settings: Menu / Configure Desktop / Hardware / Display and Monitor / Screen Saver
  2. Power Settings: Menu / Configure Desktop / Hardware / Power Management
  3. KDE Screen Saver Settings in kscreensaverrc:

Edit the file (in the hidden $HOME folder) ~/.kde4/share/config/kscreensaverrc as a normal user (not as root!)


Add the setting DPMS-dependent=false at the bottom to any other existing entries which will be based on your screen saver settings. This setting can apparently only be added manually as shown in this example. Log out and back into KDE for the setting to take effect immediately.

Thank You,

Thank you very much, I will do this

Please let us know if it fixed the issue for you or not.

Thank You,

it appears to have fixed this issue, thanks once again

Actually NO it hasn’t fixed the issue, I just turned the pc on after a few days and during update it is back to doing it again.

Have you made sure you are now completely up-to-date with openSUSE 12.2? There were a zillion updates after the original installation, including those from Packman cause I always add them at first as well. If you don’t know how, just ask and I will give the details of how I do it using YaST.

Thank You,

I have fully updated my system using Apper + YaST, (I started a thread about this nuisance “dual method/s”), so yes i should have everything up to date, I think this is yet another KDE bug, I have now tried enabling the ‘turn off display’ opton but have set it to 360 mins, maybe that will fix this minor but annoying bug.

Thanks for your reply

As I indicated in the ‘Blank screen in Gnome 3’ thread, caffeine should
work, else use xset to disable dpms.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 4:09, 3 users, load average: 0.01, 0.06, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I already took the advice given above and did the disabling of dpms

Caffeine is a status bar application able to temporarily prevent the activation of both the screensaver and the “sleep” power saving modes and is intended for use with Gnome and can be installed using YaST. OR, its the main ingredient in Coffee I live for and which causes you to think the blanking problem is more severe than perhaps it really is.

Thank You,

Ah it must be all due to Coffee, I see, great, and why are you thanking me?

I thank everyone. It is assumed to be for using openSUSE.

So, Thank You for using openSUSE!