How to start apache service in 12.1 ?

I installed apache with mod php5, and when i try to service apache2 restart, i got the message…

linux-q92h:~ # service apache2 start
redirecting to systemctl

then if i …
linux-q92h:~ # service apache2 status

i get

redirecting to systemctl
apache2.service - apache
Loaded: loaded (/lib/systemd/system/apache2.service; disabled)
Active: active (running) since Sat, 24 Dec 2011 15:22:46 +0200; 7min ago
Process: 23610 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=exited, status=0/SUCCESS)
Main PID: 23632 (httpd2-prefork)
CGroup: name=systemd:/system/apache2.service
├ 23632 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.con…
├ 23634 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.con…
├ 23635 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.con…
├ 23637 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.con…
├ 23638 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.con…
└ 23639 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.con…

but the service it’s never starting?why ?

~ # rcapache2 help

Thanks , it’s working now.

You may also start apache using a GUI via Yast -> System -> System Services (Runlevel ).

Notice that while the command “service” is supported (redirected), the proper way to start apache if you boot in systemd (the default now) would be:

# systemctl start apache2.service

and

# systemctl status apache2.service

Similarly, you can enable or disable the service with:


# systemctl enable apache2.service
# systemctl disable apache2.service