How to share files between 2 computers

I have Ubuntu on one machine and open SUSE on the other. Both connected with an ethernet cable to the same router. Both connect to the internet ok.
I did manage to set up 2 machines both running Ubuntu with file sharing but now I have switched one to SUSE I seem to be getting into a mess. Ubuntu sees the SUSE machine but does not open any folders. SUS does NOT see the Ubutu machine. I have looked for a beginners guide to setting up file shaing with SUSE without success.
Any help much appreciated.
(I like SUSE better because I can use my Audiophile sound card “out of the box”)
Chris

For remote mounting (file sharing is a MicroSoft expression I presume) between Unix/Linux systems NFS is used.
Can be configured server and client side with YaST.

I do not know what you mean by “(not) seeing a system”. Using an analogies like this one, as if a system has eyes, is nice, but does not tell much about the real technical issue. Systems can connect to each other over TCP/IP when they can connect to their IP addresses (and when the ports used are open for the other system *) ). Normaly one can check this with

ping <IP address>

Further, it is very nice when the other system can be called by name and thus is resolvable either by having it in /etc/hosts or by using DNS. Then you can e.g. do

ping <hostname>

But the usage of ping may be restricted by routers in between.

*) this includes
a) their being a server program that “listens” on a port;
b) no internal firewall blocking of that traffic;
c) no network router/firewall blocking that traffic between the networks.

Hello and welcome to the forums. There are two ways to share files, Samba and NFS. Which one are you using so we can zero in on your problem?

Each machine can ping the other with a response.
The Ubuntu machine shows an icon (places/network) for “SFTP File Transfer on SUSE” (I gave it the name SUSE)
When I click this icon I get the message “Unable to mount location…Connection refused by server”

The SUSE machine does not have an icon for the Ubuntu machine

I do not know how to edit the “etc/hosts” file. If i type “sudo gedit” and open gedit in Ubuntu I can locate the “etc” folder but cannot see the Hosts file listed.
If I type sudo gedit in the SUSE machine i get a message “GTK warning cannot open display”
I notice that the GEDIT program needs to be opened with the admin password o be able to change the contents of files.

I hope this explains my lack of understanding better!
Chris
ps I think it is SAMBA
CORRECTION
The SUSE machine also has an icon called "“SFTP File Transfer on SUSE” which give the same error message when opened.

If SUSE is the server you are trying to connect to, did you enable ssh in the firewall?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

There are several methods, but only for two PC y suggest you to use
sftp, you need to open the ssh port on the firewall, from a file manager
type sftp://user@otherPC/ to see the / on otherPC


VampirD
No in elenath hîlar nan hâd gîn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkwuJPQACgkQJQ+0ABWtaVkxtQCg6zXnzA/tZkcmHvqfkfZLwxFq
4MUAn3OcFn2/RFib12/WPyiO4jJgdxPC
=CtHB
-----END PGP SIGNATURE-----

SUSE machine
firewall
allowed services
Samba Server
Chris

no firewall running on Ubuntu machine
ps how do I check whether I am using Samba or NFS?

I said ssh (Secure Shell)

Secure Shell was not allowed.
There are 3 zones on the SUSE machine.
each with their own list of “allowed”
I allowed Secure Shell on the External zone and re-booted. The icon for “”“SFTP File Transfer on SUSE”"" has now disappeared on BOTH machines. I have disabled the Firewall on the SUSE machine but still no icons.
I am thinking it would be better to start again and re-install SUSE.

ps Re-booted both machines and got the above mentioned icons back on both but both still show the error message.
No firewalls running now.

I am thinking I am using 2 methods to connect.
The “Windows Network” icon on the Ubuntu machine opens up with 2 icons…
“Home” and
“Workgroup”
opening "workgroup takes me back to the shared files on the same computer.
opening “Home” takes me to “SUSE” network icon and the files shared on the SUSE machine.
When I try opening the files it asks for the username (chris) password and domain which defaults to “Workgroup”
The “password required” window keeps re-opening after filling in all the entries. I changed “workgroup” to “Home” and also “SUSE” so I am wondering what the domain name is and have I given each computer a different name?

I have now looked at the SUSE machine. The “Windows network” icon takes me to “workgroup” / “Chris-Desktop” and my shared folders WHICH I CAN NOW OPEN!!!

This was what I was trying to achieve…transferring files from Ubuntu to SUSE. I still think it’s in a muddle but at least it works. Can you tell me which “sharing” system I am actually using please? ie Samba or NFS

Thanks for your help
Chris
Chris

You’re using Samba.

FFI have a read of this, which works for openSUSE: Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x
and this, which works for Ubuntu: HowTo Set up an Ubuntu-Windows Home or Office LAN/Network. And/or Kubuntu

Thanks for all the help.
I’ll start reading now.
Chris

See you in August then lol!