how to run yum on Suse

I just moved from Fedora-Core to Suse. Then about installation and management of packages at Suse, ‘yum’ could help a lot.

So, after running Yast :: Software Management, it is easy to find the option yum-metadata-parser, which was installed yet.

Then on terminal, typed to locate yum:

find / -name yum


So, apparently yum is there - right? :beat-up:

Then, on terminal: :eek:

yum upgrade

bash: yum: command not found

Any hints?

webpin offers

You might want to consider getting to know zypper, I find it quicker.
Zypper/Usage/11.1 - openSUSE

Thanks. I tried your suggestion. It looks good.

Just selected yum.3.2.20 and clicked on install :: yast. Then, installed successfully - or almost.

Then, in the sequence, tried on terminal: :’(

yum upgrade

Traceback (most recent call last):
File “/usr/bin/yum”, line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File “”, line 229, in user_main
errcode = main(args)
File “”, line 84, in main
File “”, line 184, in getOptionsConfig
File “/usr/lib64/python2.6/site-packages/yum/”, line 175, in _getConfig
startupconf = config.readStartupConfig(fn, root)
File “/usr/lib64/python2.6/site-packages/yum/”, line 745, in readStartupConfig
confpp_obj = ConfigPreProcessor(configfile)
File “/usr/lib64/python2.6/site-packages/yum/”, line 86, in init
fo = self._pushfile( url )
File “/usr/lib64/python2.6/site-packages/yum/”, line 186, in _pushfile
fo = urlgrabber.grabber.urlopen(absurl)
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 605, in urlopen
return default_grabber.urlopen(url, **kwargs)
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 887, in urlopen
return self._retry(opts, retryfunc, url)
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 848, in _retry
r = apply(func, (opts,) + args, {})
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 886, in retryfunc
return URLGrabberFileObject(url, filename=None, opts=opts)
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 1004, in init
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 1069, in _do_open
opener = self._get_opener()
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 1060, in _get_opener
self._opener = CachedOpenerDirector(ssl_factory, *handlers)
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 1315, in CachedOpenerDirector
opener = ssl_factory.create_opener(*handlers)
File “/usr/lib64/python2.6/site-packages/urlgrabber/”, line 63, in create_opener
return m2urllib2.build_opener(self.ssl_context, *handlers)
File “/usr/lib64/python2.6/site-packages/M2Crypto/”, line 112, in build_opener
if inspect.isclass(check):
NameError: global name ‘inspect’ is not defined

Some idea? :open_mouth:

I’m not sure. I use F10 and you know the repo’s need to be configured. But in Suse, I don’t know.

su terminal and do:

zypper up

thanks. ‘zypper up’ has updated my system. but in fact what I am really interested is to have yum installed on Suse.

Any suggestions to put yum running on Suse would be highly appreciated. lol!

I find that zypper is superior to yum anyway, it has more facilities. So spend some time with zypper and save yourself the hassle. Yes, I do know yum, I have to use it on RHEL. At least yum was better than the atrocity called up2date.