How to run vlc player as root?

Hello,

When I run vlc using root account I get following error in Konsole.
in GUI mode it anyway fails to run. I havent tried running vlc in normal user mode but I use root account always.
Error >

opensuse11.2:~ # vlc
VLC is not supposed to be run as root. Sorry.
If you need to use real-time priorities and/or privileged TCP ports
you can use vlc-wrapper (make sure it is Set-UID root and
cannot be run by non-trusted users first).
opensuse11.2:~ #

I think I have installed vlc using yast2 & vlc’s own repo from non oss dir but not from packmans repo.

Regards,
Amey.

Mentioned many times around here: The root account is meant for system administration purposes only, and carries with it dangers to security (as well as possible self-inflicted unintended consequences). You should never log in to the DE as root, and vlc should not need to be executed as root either. What is your justification for this?

http://www.control-escape.com/linux/lx-postinstall.html

Similar discussion here:

http://www.linuxquestions.org/questions/linux-general-1/run-vlc-using-root-account-703319/

and here:

http://forum.videolan.org/viewtopic.php?f=13&t=48356

Agreed but using user account I many times have to change file permissions and blah blah. It keeps asking root credentials which is annoying. I am using root because it’s my home laptop. Nothing to worry if something goes wrong. :stuck_out_tongue: In Kaffeine plaayer, it plays all the movies already but vlc doesnt.

Regards,
Amey.

Please post result of

zypper lr -d

VLC Media Player How To:

VLC media player for openSUSE

It shouldn’t be necessary to alter any file permissions, as far as the application goes, but maybe you meant some source file permissions? Anyway, if you have problems with this, I would post the details here, rather than resorting to root execution.

what permissions it keeps asking? VLC shouldn’t ask for permissions stuff if the files you’re trying to play are accessible as normal user - ie, normal users are allowed to read them

And this is absurd. do not try to adopt your way of doing stuff for all that requires root access by running under root by default all the time. If you ignore that advice, you might better go back to Windows

Amey, as many as 20-30% of all PCs are bots largely due to this line of reasoning. It doesn’t just affect you, these computers are used for spam and other attacks, affecting all users. No firewall or security software will protect people from your bad decisions.

sco1984 wrote:
> I am using root because it’s my home laptop. Nothing to worry
> if something goes wrong.

your profile <http://forums.opensuse.org/member.php?userid=28970> says
that you are a Technical consultant…

i do hope you will not recommend to anyone to run any Linux/BSD/*nix
distribution as root, ever!

and, especially never do so while the machine is connected to the
internet…or any network… please!

further: i would suggest you never tell anyone that you run openSUSE
on your machine—because, i’m sure yours will be hacked, cracked,
rooted and botted, eventually…

and that would only serve to give openSUSE an undeserved bad name due
only to your unwillingness to follow safe computing practices…


palladium

  1. To the original question:

You need to download vlc(whatever).gz package, the source package from videolan.org
After you extract the files you will have to issue the command ./configure --enable-run-as-root
make
make install

That will allow you to run it as root.

  1. To others - we are all sensible people who operate our computers in a way we like to. If we wanted your directions to operate our computer, we will say so. So stop filling up space by telling us not to operate our computers as ‘root’.

  2. If Linux is so insecure that running it as ‘root’ when connected to the net will ultimately allow it to be taken over, I will as well go back to Windows. Or maybe you are ‘window’ guys, because none of you answered the question and filled up the page with replies.

navneetgaur wrote:

> 3. If Linux is so insecure that running it as ‘root’ when connected to
> the net will ultimately allow it to be taken over, I will as well go
> back to Windows. Or maybe you are ‘window’ guys, because none of you
> answered the question and filled up the page with replies.

you are misinforming the unlearned here…because yes running Linux as
root is just about exactly one of the VERY good ways to make it as
insecure as Redmonds…because SO many of the locked-in herd run full
time as administrator–pure DUMB…

Don’t do it in Redmond, and don’t do it in *nix!

now, stick to something you know about, ok?


palladium

You’re as clueless, or even more clueless, than the OP and you’re just showing this cluelessness for others enjoyment :smiley:

First, we tell you to run it like it should be, to PROTECT you from messing up the system, OR someone else messing it up. Second, you are free to ignore this advice, but don’t come back crying when something happens because your ego is too big and ignore what others advise you.

If you constantly run as root user, it’s very easy to infect your system from the Web. Suppose you go to some site, which without your knowledge, checks on what system you’re running and if it detects Linux/UNIX, downloads some evil scripts in the background to your system, without you ever knowing. If you’re running under “normal” account, those will do little damage compared to the damage they can do if you’re running as root, which has all the power on the system. They might just as well wipe your whole system and send everything to /dev/null, something they cannot do when ran under “normal” accounts, and this is just one example.

Linux is secure when you 1) have a bit of knowledge of how this security is achieved and implemented (obviously, you don’t), and 2) don’t go swimming against the stream and “do your own thing” because you think you know something what others don’t, and then ignore sound advise which has been given by many even before you were born

Moral of the story? Try educating yourself about the topic, before attacking it without having a clue about it, just trying to appear as if you do (which, btw, you failed badly at)

PS: warning at others - don’t feed the Trollolololol

As microchip says, what you recommend is just bad advice.

There are two ways to view this. One is to just answer the OP’s question, and nothing else. To disregard the security hazards that we know will happen. The other is to answer the post completely, which has been done.

To your other point, about Linux being insecure, that only shows how much you don’t understand. You don’t understand either security or Linux. Even the most secure operating system in the world can be hacked and compromised if the user subverts the security of the operating system and disregards the security advice.

Security is not just about having a secure operating system, with good security applications, its also about the user being and staying informed and practicing good security techniques. So you attempting to chew us out for providing complete answers, just shows your level of ignorance.

Part of the reason Windows is so insecure is that almost everyone runs Windows with administrator privileges. When I deal with Windows users, I always recommend that they create a restricted account with very limited access and never log into the administrator account again. I also take the time to explain why this is what they need to do.

I wont get into the other reasons why Windows is insecure, as that is way off topic. But I have given the reasons here as to why running as root/administrator in either Windows or *nix is a really bad idea and practice.

Instead of recompiling it, try the instructions here (I’m assuming of course you’re not trying to run this on some mission critical production financial systems server…)

You won’t need to recompile and you’ll still be running the player from a non previlidged account (even though you yourself would still be logged in with the root account), but it should be usable for your purposes:

VLC: VideoLAN video player: Failed to connect to the D-Bus session daemon: /bin/dbus-launch terminated abnormally with the following error: No protocol specified

HAOF