How to restart NetworkManager to get wired connection work?


There’s my situation:

  1. I’m at home, connected to my home wifi, but im also able to connect by wired home network. Everything is ok.
  2. hibernating laptop and going to work.
  3. unhibernating laptop and im trying to connect to wired network at work - impossible. Networkmanager always says that cable is not connected.

/etc/init.d/network restart doesnt change anything.

How to restart NM to get wired work?

which desktop are u working in kde or gnome and whats the os version ??

Have a look at this :

Check what is your “/var/lib/NetworkManager/NetworkManager.state” and try the solution above.

Best regards,

You have not said which version of openSUSE, nor which desktop you are using.

I experimented with NetworkManager on my desktop, and there were circumstances where rebooting the router would cause NetworkManager to fail to connect - it thought the cable was disconnected. It was probably the same issue. I went back to “ifup” after that.

However, here is what worked, in KDE: Using the NetworkManager applet, I selected “disable network”. Then, I waited for a minute. Then I enabled network. And it connected.

That was with openSUSE 11.4. I have not tried that with 12.1.

If you are using 12.1, you can also try (as root):

# cd /etc/init.d
# ./network restart

My guess is that will work. When you use “/etc/init.d/network restart”, as you did, that is intercepted by “systemd”. But that intercepting appears to be broken and doesn’t occur when you use “./network restart” in the directory. And that allows the sysvinit script to do its thing.

There’s probably a systemd command that can be used for restarting the network, but I haven’t looked into what that is.

In 12.1, NM sometimes has a problem getting the routing correctly when plugging
in the wire. You can check this with a ‘/sbin/route -n’ command. If there is no
route with the UG flags set, you can establish the correct routing by

sudo /sbin/route add default gw XXX.XXX.XXX.XXX

where the IP address represented by the X’s should be replaced by the IP address
of the router. For instance, in my case I use