How to repair file system errors?

I cannot now start openSUSE 10.2 properly (it’s been working for over a year). Looking at the start-up in verbose mode I see the message:

dev/hd6 contains a file system with errors, check forced.

[hd6 is the partition where / is mounted]

At the end of the checking I get:

fsck failed. Please repair manually and reboot. The root file system is currently mounted read-only. To remount it read-write do:
bash# mount -n -o remount,rw/

How do I repair hd6 manually?

Many thanks for help.

After it boots to this mode, you can perform the repair from there:

If you have reiserfs, use:
fsck.reiserfs /dev/hda6

If you have ext3, use:
fsck.ext3 /dev/hda6

After it’s finished, reboot.

I have the same problem. The prompt is for a root password. But it is not accepting my root password. How do I get in?

As an alternative, would it do any good to use the repair tools and reboot to the DVD?


If your at the maintenance root prompt you just hit enter for the
password. Else boot from the DVD, agin no root password.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 10:43, 2 users, load average: 0.03, 0.24, 0.32
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Hello, and thanks for the help,

I was finally able to get the root pw to take. It wouldn’t accept the blank. I’m sure I did something wrong, but don’t know what. Anyway, I’m in now. But with no success. It would not find the drive to fix with any of the commands above, or from Disk repair alternate superblocks ( Disk repair alternate superblocks - openSUSE ). The missing disk is /dev/sdb3. Is dumpe2fs installed by default? It couldn’t raise any info either, or address the partitian.

I tried using the repair tools (this is a 10.3 386 box btw), but the process failed, multiple times. I let it check the installation media, and it came back with no errors. I tried to install and then to the repair tools, but again, it fails. I am going to open the box up tonight and check all of the connections. I am afraid it may be a bad hard drive. Are there any other checks or fixes that might work?


Are you sure you have the same problem, that is, file system errors? You won’t see a file system error if the partition cannot be seen or accessed. If the problem is not the same, probably better to create a new thread with a title that describes your problem (like, “missing partition”).

I thought it was, but it may be different. I will start a new one.


thanks so much,
i had this error and using
fsck.ext3 /dev/sda1 and
fsck.ext3 /dev/sda7 i fixed it.


Yes I’m sure he has the same error. I have the same problem post-update. That’s 3 machines totally different with the same error.
Genenrally, openSUSE stops, complaining about fsck unable to complete on /, gives option Cntl-D to reboot, asks for root password, completes to errors finding files like .ICEauthority hitting enter, then proceeds to blank GUI signon screen.

Investigating. Going to provide root password next to see if fsck completes.


Provide root password and fsck (/dev/sda8 and /dev/sda1 for me). Or boot a live or install openSUSE and fsck all devices.