How to remove self compiled plasmoid

I compiled the playwolf plasmoid from which seemed to go fine.

However it didn’t show up in my plasmoids list, but what’s worse is that ever since I’ve compiled it my plasma workspace is as unstable as it can be.
End up deleting my plasma settings hourly just to be able to start plasma at all.

Commands I ran to install it are:
cmake -DCMAKE_INSTALL_PREFIX=‘kde4-config --prefix’ …
make install

Do see a cmake_uninstall.cmake file, but how do I run it? Or what should I do to get rid of it?

You should be able to uninstall using :

make uninstall

also I would recommend that when compiling source to install to the usual prefix of /usr/local as this makes things easier to manage as binaries built from source dont get mixed with those installed from the package manager. Although for some apps (kde, gnome stuff) this makes the configure/build harder.

Just followed the ‘install instructions’ and in the comments someone asks to confirm that the prefix was used by another person who didn’t have it showing up.

Thanks for the help, hope this gets rids of my unstable plasma workspace as it’s extremely annoying to have it crash every hour need a removal of the configuration files.

Also note not all source code comes with a make uninstall. If after configuring when I look at the Makefile, if I don’t find a uninstall rule I will reconfigure with a prefix that points to a single directory ala a windows install and then I just add a symlink to /usr/local/bin that point top the exe form the installer. Note though this doesn’t work so well with libs. So in the case of libraries I just install to /usr/local an dif no uninstall then you look at the Install: section of the makefile to see which files are installed and where, once you know what files it installed you can remove them.
However if it doesn’t have an uninstall it may not be wise to install in the first place as this is sometimes a sign of incomplete or immature software.