how to mount iPhone?

how can I mount my iPhone in Opensuse?after i connect my device to laptop via USB,opensuse doesn’t mount it and recognize it at first as a digital camera.

I can download my iphone pictures with my opensuse 11.1, but it works only once in a while.
There might be some hope here :
libimobiledevice - Teaching Penguins to talk to fruits
I tried to install it but it didn’t work for me.
Does anyone have a procedure to describe how to use this libimobiledevice ?

When I plug in my iPhone 3G, My KDE shows a notification for a PTP imaging interface, so that I can download photoes. (I guess you have to install ‘digikam’ ).

But I can also mount my iPhone using iFuse. search for iFuse in webpin.

It should be in FunkyM’s repo.
There are also other tools you might want to play with.
with iFuse, you can mount any iphone to any directory of your choice, (the Iphone need not to be jailbroken :slight_smile: ). just do

iFuse /your/directory/where/you/want/to/mount/your/phone

and bam you can access your iphone. You can do it as root also, but there is no need to be root.

If you have jailbroken iPhone,you can also use ssh to access your phone (both command line and gui :wink: ). And it is very easy to use “fish” protocol with dolphin for ssh’ing iPhone in gui mode. I think you have to install fish, and then go to network (from the sidebar in dolphin or just type “remote:” in the location bar and press enter) and open “Add network folder” then select ssh and follow the instructions.You will get an folder which will show you the contents of your iPhone and you can browse them like you browse your local disk.

if you want root access on your iPhone, then it needs to be jailbroken. Plus, AFC service sould be running on your iPhone.

Below is the output, when I tried for the first time:
(11.2 with Gnome)

baynaa@linux-9pfy:~> ifuse iPhone --root
Failed to start AFC service '' on the device.
This service enables access to the root filesystem of your device.
Your device needs to be jailbroken and have this service installed.
Note that PwnageTool installs it while blackra1n does not.

After installing AFC through Cydia:

baynaa@linux-9pfy:~> ifuse iPhone --root
baynaa@linux-9pfy:~> cd iPhone/
baynaa@linux-9pfy:~/iPhone> ls
Applications  boot   dev        etc  Library  private  System  User  var
bin           cores  Developer  lib  mnt      sbin     tmp     usr

You are root on your iPhone! :wink:

See also FunkyM’s comment:

on this thread → How install libimobiledevice for iPhone on OpenSUSE? - openSUSE Forums