how to make the zypper use proxy

the zypper calling aria2c download the file, but the speed is too slow, so, I want to use proxy.
the aria2 is supported to use proxy ,but I cannot find where is the config file. I want to know how the zypper pass the parameter such as file name file target and anthor option when aria2 is calling by zypper.>:(
thanks a lot

my english is very poor:|

I think the key is the /etc/zypp/zypp.conf
but anybody know the grammer of zyyp.conf

Hi!
To avoid using of aria2c, you can try to set ZYPP_ARIA2C variable value.
for example:

export ZYPP_ARIA2C=0
zypper refresh

I means make the aria2c use proxy ,so that the speed will be faster .

Which version of aria2c you use?

the version is 1.8.3

I assume that you are using openSUSE 11.2, isn’t it?
Upgrade aria2 package to version 1.9.1 from here: Index of /repositories/network:/utilities/openSUSE_11.2
Create ~/.aria2/aria2.conf file in your home directory and put your proxy settings there. You’ll can read more about settings in aria2.conf with man aria2c or in /usr/share/doc/packages/aria2/aria2c.1.html file, section “HTTP/FTP Options”.
After settings, check aria2c work (download something). If no errors (proxy settings, authorization, etc), then copy ~/.aria2/aria2.conf to /root/.aria2/aria2.conf file.
Check zypper work.
If something goes wrong, you can remove aria2.conf file.

It works :wink:
thank you very much novsan

I just set the environment varible.

export http_proxy=http://www.xxxsite.com:xxxport

Then it is ok.

On 2011-07-14 03:36, wsysuper wrote:
>
> I just set the environment varible.
>
> export http_proxy=http://www.xxxsite.com:xxxport
>
> Then it is ok.

Use /etc/sysconfig/proxy.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Ah, thanks very much for that. That’s just saved my day here!

Thank you Carlos, this was helpful.