How to know if NVIDIA drivers are installed and using it?

Hi received my new laptop, an MSI CX61. It comes with a “dual” VGA Intel+Nvidia 820M

I followed the guide for Optimus hardware and seems to work, but I would like to know if there are some way to make sure OpenSuse recognizes my NVIDIA and use it.

All in guide was ok, just snapper steps didn’t worked for me.

optirun --status return ready, and “1 application is using it” if I open steam with primusrun, but is using nouveau or NVIDIA ?

There are two things thath makes me suspect is not working.

First, nvidia-settings don’t opens, with some errors about libnvidia-gtk3 cannot open shared objet … I searched on Yast, and can’t find it.
I opened “Natural Selection 2” a game from 2012, and in menu, is giving me 8 FPS with all graphics options to low or off :open_mouth:

Some idea?

Thanks a lot.

And the openSUSE version used is ???

Sorry, 13.2

That page gives instruction on verification

Yes, and I did it, but as far as I understand, bumblebee can work with nouveau or nvidia. I want to make sure is using nvidia

optirun glxspheres

should be an indication the frame rate should be higher with NVIDIA

Also you could look in Yast software to see if the driver is installed if it is then that is what you are using. You can’t use nouveau if NVIDA is installed the NVIDIA drive will black list it.

Check which kernel driver is loaded with:

/sbin/lspci -nnk | grep '\[03' -A2

one will preclude the other

Note: this thread should have gone in the hardware section, not multimedia
[li]Multimedia: Questions about media applications, codecs (DVD, music, video, pdf) configuration (usage, bugs) [/li][li]Hardware: Questions about drivers, peripheral cabling, configuration [/li][/ul]

Ok, appears this:

01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev ff)
Kernel modules: nouveau, nvidia

Ah, okay. I’m going to guess that bbswitch has disabled the discrete (Nvidia) adapter (via unloading any drivers for it) … if a kernel driver had been loaded, that command’s output would have provided info to that effect, such as like what you see in the case of the intel adapter (i.e. “Kernel driver in use: i915”).

So I would do whatever it is you need to do in order for bumblebee to evoke usage of the discrete Nvidia adapter … seee

Check /var/log/Xorg.8.log!

Indeed, good point

Ok, seems like is using NVIDIA

giu@ko-giu:~> less /var/log/Xorg.8.log | grep nvidia
  8449.548] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
  8449.549] (++) ModulePath set to "/usr/lib64/nvidia/xorg/,/usr/lib64/xorg/modules"
  8449.553] (II) Loading /usr/lib64/nvidia/xorg/modules/extensions/
  8450.206] (II) LoadModule: "nvidia"
  8450.206] (II) Loading /usr/lib64/xorg/modules/drivers/
  8450.318] (II) Module nvidia: vendor="NVIDIA Corporation"
  8450.348] (II) Loading /usr/lib64/nvidia/xorg/modules/
  8451.190] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
  8451.213] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia