how to install unicode in openSUSE


i think i have installed most corrupted version of openSUSE 11.1

nowhere it works, everywhere problem

but samething works in Fedora…using the same method

what is this i know…

i have download the unicode conversion tools from this site

Madan Puraskar Pustakalaya - Downloads

and compile the jar file using this command

java -jar /home/vikal/Desktop/java/ConversionTools3.0/ConversionTools3.0.jar

then there will be a window

as i wanted to convert nepali font to unicode

i have tried with the nepali.txt file from my hard disk

and press conversion button

which you can also try

and there comes the message like

Conversion success

then i tried to open the conversion files

and this display the font like block block

and if i paste the same block block to here then

it will be like this

ल सरकार
कानून, न्याय तथा संसदीय व्यवस्था मन्त्रालय

same procedure and same method it works in ferora

there will be this ल सरकार
कानून, न्याय तथा संसदीय व्यवस्था मन्त्रालय

but no block there

i got so frustred

but still hoping for good

best regards


Have you a Nepali compatible font installed? If so, you probably need to select that font as the display font. KWord will display Nepali if you have a Nepali font installed that it can use.


thanks for replying

i have just download nepali font

ie preeti.ttf and copied into


and from the command i have do like this

/etc/init.d/xfs restart

and still i need to do onething

if it is debian then this command will work

dpkg-reconfigure locales

but in openSUSE it does not work

is there any other procedure to install font

if so please tell

waiting for you reply



If you are using KDE go to Configure Desktop>Font installer and check whether the fonts are present in the list; if not, use Add to add them to the list.

If they are already in the list, they should be available to all KDE applications.



i did same as you told me to do

but still block …not working yet…what to do further



The only thing I can think of is try KDE Community Forums
as this sounds like a KDE problem.

I decided to try myself and think I found the site from which you got them, the instructions for which do not apply to openSUSE.

However, the Font Installer reported a fault with the actual file and refused to install it - which could mean that there is a problem with the Font Installer or with the fonts - but it may be worth trying a different source for your fonts.

Incidentally, when I located the font on the Internet, I simply right-clicked on it to try and download/install it.

I have managed to install the Akshar font from the South Asia Language Resource Centre; this combines some Latin characters with characters from several Indian sub-continent languages along with Nepali.