How to install support for Matrox G200 card?

I want to switch my display adapter from on-board hardware to a Matrox G200 PCI card (no AGP on my motherboard and I’m not worried about 3D performance). I have spent the last 3 hours looking through HowTos and searching the fora for all entries on the G200, but nothing tells me specifically how it is done.

I tried following the installation process described in the Linux driver package available from the Matrox support site, but this fails with these messages:

Please enter the full path to your current X11R6 directory:
Example: /usr/X11R6
/usr/X11R6 line 151: test: ./xserver/Revision: binary operator expected
ERROR: The X server drivers included in this installation package
do not support the current version of your X server.

Could somebody point me to a forum thread or another document that describes the correct procedure?

On Fri, 2009-06-19 at 15:56 +0000, XEyedBear wrote:
> I want to switch my display adapter from on-board hardware to a Matrox
> G200 PCI card (no AGP on my motherboard and I’m not worried about 3D
> performance). I have spent the last 3 hours looking through HowTos and
> searching the fora for all entries on the G200, but nothing tells me
> specifically how it is done.

Have you tried using the mga driver that comes with Xorg? You shouldn’t
need anything else. I used to own a AGP G200… worked fine. Not sure
if there’s anything weird about the onboard. Maybe you just have to
force it (maybe it won’t auto-detect properly). Do a man on mga with
regards to forcing chipset selection, etc.

Not sure. I know mga isn’t just AGP because it supports the older
Millenium boards. Let us know what you find out.

yeah, I second that. Some time back, I set up a machine with a Matrox G200 with openSUSE 10.3, it worked fine without needing to download additional drivers.

I’m not all that familiar with “graphics card swaps”, but if it’s not automagically handled, I’m guessing you should just boot into runlevel 3 and run SaX2 -r (as root) to configure a new xorg.conf file for it?

Thanks for this advice. My main roblem is that I don’t know how to use it. I’m too fixed in my thinking on the Windows world to understand how to replace a display adapter under Linux. I’m looking for the same sort of approach as in Windows, but, unsurprisingly, I don’t find it. So I don’t even know where to start. How does one ‘use the mga drivers in xorg’ for instance?

I assume you already disabled your onboard graphics adapter in the BIOS, or set in the BIOS that the first graphics adapter to use is your PCI card?

If so, then you should boot your machine and when you are in the GRUB menu just type init 3. On the login screen then login as root, and start sax2 by typing sax2. You should then be able in Sax to select the mga driver and the screen resolution you desire. Then reboot and it should work!


ok, per admoel’s advice above, you need to look in your BIOS to see that it’s set to output via your card and not via onboard graphics (I guess if you see BIOS boot output on a monitor attached to your Matrox, you’re set :-P).

But what I’d personally do is to see if it is automagically handled - my openSUSE box is a production box so I don’t really want to mess with it, but practically every linux distrib I’ve used for the past few years has been able to autodetect hardware changes and launch the appropriate configurator.

But before you do that, you need to know about virtual consoles. Basically, you hold down the left Ctrl-Alt keys and then hit F1, F2, … up to F6, and you will get a text mode login prompt. This way you can get into the system even if X doesn’t work.

(err, another digression - runlevels. The system can be in various “runlevels”; runlevel 5 is “graphics mode”, runlevel 3 is "networked multiuser, but no graphics, runlevel 1 is single user mode. So if you’ve got a graphical logon showing, you’re in runlevel 5, and you can get to that with Ctrl-Alt-F7. You can use Ctrl-Alt-F1 to F6 to do text mode stuff, and switch back and forth to your “graphics mode” with Ctrl-Alt-F7. If you’re not in runlevel 5, then Ctrl-Alt-F7 won’t give you “graphics mode”).

So basically, what I’d do is, I’d just stick the card in, check the BIOS is set up right, and then boot the thing to see what happens. If it works automagically, you’re done. If it doesn’t, I’d be hitting Ctrl-Alt-Fsomething and then logging in to either run /sbin/poweroff and yank the card out, or I’ll either go to runlevel 3 and run SaX2, or, well, do something else.

Unless something else has gone very wrong, you will not be in a situation where your card is unrecognised and you cannot get a user interface AND you can’t do anything to deal with it other than to yank the power cord - you should always be able to get to a root prompt to do stuff. (Heck you can even shell in from the network and do stuff if your UI is completely frozen).

Re: “drivers” - except for cards where the manufacturers do not provide enough details (or have not been sufficiently reverse engineered by people), support for the card will “already” be in xorg , i.e. you do not need to download or install or compile anything.

All the trouble with ATI and Nvidia drivers is because the manufacturers don’t put out enough info and won’t open source it, otherwise there’s no need to worry even about having to deal with the 1-click installs etc. - re: “Windows style thinking”, it’s basically a situation where the OS has built-in drivers already. Like, say, you plug in a standard USB keyboard and you don’t need to “install drivers” for that keyboard (at least for basic functionality :-P).


Hit Cltr-Alt-F1 to get to the console.
Log in with username and password and issue commands below:

su -c ‘init 3’
Enter root passwd
Changes runlevel to 3: no X-server

su -c ‘sax2 -r’
Enter root passwd
This creates a new /etc/X11/xorg.conf

Pick Change configuration
Check new proposed settings for videocard etc.
Save and exit.

su -c ‘init 5 && exit’
Enter root passwd
Brings the runlevel to 5 (full network + X) and logs out.

You should now have a graphic login screen.

Let us know if you succeeded

Helpful advice - thanks. But this is Linux, so it doesn’t work.

I don’t have a BIOS option to disable onboard graphics - only the option to set graphics to either ‘auto’ or ‘on board’.Having chosen the auto option and with the G200 card installed, the system loads to the point of the OPenSuse banner showing, with the ‘system loading’ bar graph starting to extend across the screen. After a few seconds the screen goes blank and no combination of Ctrl+Alt keys will present a command line interface… The only option I have is to press the power off button - which immediately causes the OpewnSuse banner screen to be shown, with ehe 'system unloading bar graph starting to decrease across the screen until the system powers off.

I guess this means that the Matrox G200 is not supported. since something so basic as Ctrl-Alt-F1 does not work. Correct?

Nah, doesn’t work as stated in my reply to another post: Ctrl-Alt-F1 has no effect.

I only have the option to set the BIOS graphics card to ‘Auto’ or ‘on-board’. I get nowhere if I choose the ‘auto’ option but connect my monitor to the on board VGA connector or to the VGA connector on the G.200 card.

I looked long and hard at your advice “…when you are in the GRUB menu”. I am unable to parse it effectively so I was sure you were joking with me, playing on the words ‘grub’ and ‘menu’. However a Google search of the phrase presented a few web sites about something called Ubuntu which sounds distinctly like some nasty disease from the African continent.

One web site advised me to type “gksudo gedit /boot/grub/menu.lst” but without giving me any indication as to where I should type this. Actually, that’s all a bit irrelevant, because all I have is a blank, dark, screen. I assume that when I type Linux is typing black characters on a black background, so I can’t see it - right? But that means I have no way of knowing what is going on.

I’ve tried looking all over my Linux system, but can’t find any grub - should this perhaps be ‘bug’? Or ‘crud’ (as in create, read, update, delete)? Or if it is really grub, where it it’s menu kept?

I don’t get what do you mean with this?

to agglomerate your other posts -

grub is actually an acronym, “GRUB”, stands for Grand Unified Bootloader. It can be used to select between different operating systems on your hard disk to boot up - different iterations of linux distributions, Windows, etc. It is used by openSUSE (and as far as I can tell, all other modern linux distributions).

One of the advantages of grub is that you can use it to pass boot options to the linux kernel on a “one off” basis, i.e. you don’t need to “reinstall” anything if you want to change things. On an x86 PC with BIOS, when you power up, you get all the various BIOS boot messages (memory count, disks detected etc.) - immediately following this, should be the grub menu - you get to use the arrow keys to highlight and select what options you want to boot (one of them should be “failsafe”).

You can hit “e” and add an entry “init 3”. this should boot you to non-graphical mode.

Ubuntu is another linux distribution. It’s not a disease. The name is based on a Zulu word meaning “humanity to others”.

Forget about that first line, you’re already ending up in the console. So just login and follow the rest of instructions. Just gave somebody a call to test this and he states it works. Drivers for Matrox cards are in Xorg.

from what I understand of his post, he’s sayign that the display goes blank after seeing the boot messages, i.e. he doesn’t get to a console. am I reading him wrong?

I think it’s fair to say that I failed but those of you well informed people out there - who help confused people like me - were successful. This procedure finally worked; I was pleasantly surprised to find that Sax had made the best suggestion for resolution and colour depth. The change to the different display hardware is now complete.


One weird thing though: while using Sax I looked at the configuration for my mouse (because it appeared to be working in right handed mode even though I had previously set it up for left handed operation). I set it explicitly to left hand mode in sax,exited sax and restarted the system.

After restart the mouse operated in right hand mode even though it is listed as being in left hand mode in the Control Centre. If I set it to right hand mode in the control centre, it operates in left hand mode.

Never a dull moment in Linux…

Understandable: my apologies, I left some words out in my haste to type. What I wanted to say was that ‘this being Linux, things usually (if not predominantly) do not work for me, on my installation’

I have to say that my experience of trying to create a working Linux installation, that I can use effectively enough to ditch the Microsoft platform (on at least one of my computers), has not been good.

This is an assessment of my experience, not of Linux or the open-source concept (but with some implied criticisms).

From feedback I have had from others I have modified my expectations and mind set (for example,the open source movement being based almost almost an entirely on volunteer resource, I should not expect to get levels of support typical of commercial ‘paid for’ products). So, I have invested a lot of time reading ‘man’ and ‘info’ pages as well as taking every book on Linux from my local library - all with the objective of being able to be more self-relient and successful in my set up and use of Linux.

5 years on I still have not successfully compiled a single source package without problems.

Almost every day I find a problem on my Linux installation for which I can find neither a problem source identification procedure nor a problem resolution procedure. The merest ‘touch’ at the system exposes me to details, jargon, pre-requisites, etc. whose definitions are unknown to me and for which sources to explain them are elusive.

For example the ‘man’ and ‘info’ pages appear to have been written by some alien beings who have learned the grammar, syntax and semantics of international English from a computer - probably running Linux. Personally I find them close to being unreadable. They are certainly inscrutable - a barrier designed to keep out people like me who lack the necessary qualities of ‘geekness’. This is pretty close to emulating the entry requirements for most religions. Is it really necessary?

I am forced to rely on forums like this, which causes a significant demand on the time and patience of people who can to help people who can’t. This is a great frustration to me, having spent more than 50 years either on the periphery of or deep into computing systems design, marketing, deployment, operation and management.

Still, no use grumbling, eh? Think of all those poor souls who have no choice but to labour on under Vista…

Hi, newbie here!!! Do you guys have any information regarding IT support at Watford for internet connection? I got internet connection one month after buying laptop but now my hard drive of laptop is not working properly or there is possibility of damaging internet connection inside the ports. So, if you guys have any advice or suggestion that would be appreciated.

IT support herts