How to install openSUSE 12.1 when there is no desktop?

Hi,

I would appreciate some help with this problem; I have just made a live CD from the Gnome ISO file of openSUSE 12.1 and when I run it, all I get is a command line and an invitation to log in. There is no desktop, and typing something like ‘guest’ for the login name doesn’t work. Could someone tell me how to get round this requirement to log in, please or, preferably, how to get a desktop.

I want to install it on an external hard drive which already has Ubuntu 11.10 installed and if I succeed in installing it, I would like to know whether I could or would need to install GRUB2 into Suse which, I understand, uses Legacy GRUB, so that I get a boot menu.

It’s probably something to do with your graphics card… what is it?
Grub has nothing to do with it

kde might work better

Thanks for your reply. The graphics card is an Nvidia GE Force 9500 GT. I realise that Grub has nothing to do with this problem but I was wondering if I need to install Grub2 so as to get a boot menu. The version of Ubuntu that is installed is using Grub2.

Is there a way of installing Suse from the command line?

On 2012-03-22 21:46, chriscro wrote:

> Is there a way of installing Suse from the command line?

Yes, but I do not know if the live has it.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

http://forums.opensuse.org/english/information-new-users/unreviewed-how-faq/436916-text-mode-install-livecd.html

Did you try booting with this boot argument added:
nomodeset

AFAIK


/sbin/yast live-installer

should allow you to perform a text-based install. But I’m not sure.

Have you tried booting the livecd with “nomodeset” on the options line?

@Caf: :smiley:

Many thanks to you all. Putting ‘nomodeset’ as an option enabled me to get a desktop as well as a message saying that the graphics card is not up to the job. I was able to start installing openSUSE but have run into another problem. I created a partition for it before trying to run the live CD but the installer refuses to use it. Instead it wants to use two partitions that are already being used for something else. The partition that I had earmarked for it is /dev/sda7 and I have specified (incorrectly?) that it is the root partition by highlighting it and editing it, but the installer won’t accept it.

I think I will give openSUSE a miss for the moment until I know more about Linux and partitioning drives. Thanks for your help

It would be worth you posting

su -
fdisk -l

Hi ca14926,

Here is the output from fdisk -l

Disk /dev/sda: 320.0 GB, 320039026688 bytes
255 heads, 63 sectors/track, 38909 cylinders, total 625076224 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xea128f3b

Device Boot Start End Blocks Id System
/dev/sda1 2048 105016904 52507428+ 83 Linux
/dev/sda2 105017344 109176831 2079744 82 Linux swap / Solaris
/dev/sda3 109176832 111241215 1032192 83 Linux
/dev/sda4 * 111250123 507932671 198341274+ 5 Extended
/dev/sda5 111250125 212989769 50869822+ 83 Linux
/dev/sda6 212992000 316798975 51903488 83 Linux
/dev/sda7 317830023 507927104 95048541 83 Linux

I am not sure what is going on here; I did not set /dev/sda4 as bootable, and there was originally a /dev/sda8 which is where I wanted to install openSUSE with /dev/sda7 as the home directory. I have tried accessing /dev/sda4 to toggle the ‘*’ but it wont do it.

I expect you can see why I said it might be best to install openSUSE when I know more about partitioning in particular and Linux in general… Linux seems to have a steeper learning curve than I had anticipated.

All the formatting of the output from fdisk -l has got lost - I did not know how to keep it so the the output remains readable

openSUSE should install fine
Just use the custom partitioner and use sda7 only. You need to uncheck the box here
https://lh4.googleusercontent.com/-RIYSNmryC68/TrTSbfZ206I/AAAAAAAAAs4/GnaF9oYGXVk/s640/14_partition_edit_summary2.jpg
‘Propose separate /home partition’

Look at the complete guide here:
https://picasaweb.google.com/107564133608385811033/121_kde_LiveCD_Install

sda4 with the boot flag is correct for openSUSE
Ignore any warning at the Install summary about the bootloader being beyond the 128GB limit