How to install Creative X-Fi Titanium?

Hi. You can see my previous post here:

Crative X-Fi Titanium proprietairy drivers problem - openSUSE Forums

So I compiled and installed the driver, but i still can’t get opensuse to make it work! In yast, when I make it search for all hardware, sound card is detected as Creative Labs Audio Device.

But under sound window in yast, I get no cards - and when I click to add new card, there is a list of Creative cards, they are all very old - not the X-Fi family, but the older ones.

What can I do?

I have aX-fi Xtreme Gamer and to be honest ones the driver is compile and installed it works after rebooting.

Try this if you havent done so:

make clean
<enter root password>
make install
modprobe ctfxi

After the modprobe I had kmix in the bottom right of my KDE 4.2 install. Have a look at this thread and specifically this post in it. This was all it took for me.

Hope this helps.

Sorry, I weren’t right. When I didn’t see any cards in yast, and selecting “play sample sound” didn’t do anything, and playing something in amarok didn’t give any sound, I thought it doesn’t work. But now I can hear system sounds and youtube, so i think it works. It even sends digital-in signal through line-out, just like in windows! (I thought it would be a nightmare to set something like this in opensuse)

But although it works, it is still strange I get no soundcards in yast. (Not in the Sound dialog, at least)

Just one more thing - my keyboard has two buttons for lounder/quieter sound. Although I press them and the small bar with percent sound strenght appears, it does not have any impact on sound volume. (KMix and youtube flash player bars have)

I have no soundcards under yast - sound but everything with the card works. Kmix to adjust volumes, Skype with front panel mic, record what you hear. So I don’t need a soundcard listed under Yast :slight_smile:

About the keyboard this probably has something to do with the keyboard settings. For my keyboard, microsoft multimedia keyboard, I had to download keytouch from the packman repo. After running this I got all my multimedia keys working. Give it a try as it supports loads of different keyboards. If you get it working go under yast - system - system service (run level) and enable the keytouch-init daemon to start you configuration at startup.