How to install Cockpit on OpenSUSE 15.4?

Has any attempt the installation of Cockpit on 15.4? I have not tried since “How to install Cockpit on OpenSUSE 15.1?


would installing it from “cockpit from openSUSE:Factory project be the current way?”


which cockpit community package?

…and looking forward to “Cockpit Wicked” reaching Leap!

@nasheayahu wicked is deprecated these days, just NetworkManager…

Not tried on any Leap release, MircoOS and Tumbleweed is where I use Cockpit…

Perhaps I would add, install then disable just so that repo doesn’t pull anything else in… You can enable and update, then disable again.

Really, I’m using wicked to managed my Leap KVM Server, I don’t have the link and don’t remember the date, but the statement was it was better to use wicked on a server, does this still stand true today even after reading this “Switching from wicked to NetworkManager” just now?

I’m preparing this Leap 15.x for forward facing internet connections, should I switch to NetworkManager?

@nasheayahu it works fine, I use it here for vm’s on Tumbleweed, I have two bridges and two unassigned NICs for my vm’s. They are just text files so easy to manually create if needed.

I’m being too dramatic huh, me being a GUI guy, I forgot about what it’s actually doing. :blush: Can you use Tumbleweed for forward facing internet connections, say about 10,000 users? Because, Leap is my go to Project Server, maybe one day SUSE, and I don’t want to change just for Cockpit but I can wait until its released for Leap.

UPDATE: I just read this very interesting discussion " Tumbleweed for the server" and it appears based on your environment Tumbleweed can work as a Server. What are you using, if using a Server for users connecting and / or from the internet or do you know of any site on the internet using Tumbleweed?

…and do you have an update link for “” because its no longer present.

@nasheayahu I would stick with Leap until that expires ~2025…

This is just a development setup, I run lot’s of vm’s to play around/testing mainly with kubernetes these days.

1 Like

There is a cockpit-wicked package at Follow the and install it.

Given that a) there is no cockpit for Leap in the first place and b) wicked is deprecated and is not even installed anymore by default on Tumblweed, that is not realistic.

On Tumbleweed, I’m using wicked.