how to go to command prompt during start??

Hello members!
I can not find any helpful information about how to get to the command prompt during start up of KDE.
Can you help me?
Which button(s) do I have to press?
Thank you so much!

I can not find any helpful information about how to get to the command prompt during start up of KDE.

Not sure exactly what you mean. You can change from desktop to a virtual terminal by pressing Ctrl-Alt-F1 (or F2, F3 etc). Ctrl-Alt-F7 will return you to a desktop. You can boot into runlevel 3 (text mode) by entering ‘3’ at grub prompt as well. Hope I’m on the right track…

Thank you for the fast answer!
KDE (or Linux…) does not start so we are not able to switch to the command prompt from the desktop. I want to know what I have to do to be able to do one of the following things that I found elsewhere:

  • try logging in on the console without KDE, use a command-line login
  • boot up in safe mode and get to the command prompt. Log in as necessary.
    Type “df -h” to see how much disk space is free.
    Type “du -sh /tmp/*”. The “du” command shows you disk usage


You seem to be a bit uncertain about the terms you use.

When Linux does not start you have no running sytem at all. When that is the case, try to describe better what what happens at boot and what you do.

When Linux does start and the desktop (KDE in your case) does not start, you will see a terminal login at your screen. And that is what you asked for. So again describe more exactly what you do and see.

I agree with you completely: I have no idea what I have to do, because I am very new with Linux. So please ignore that I don’t use the correct terms.
OK, I’ll try…
I think we have something between the two cases you are describing.
KDE does start but then comes the following failure message:
$home Directory Out Of Disk Space
(or something like that, meanwhile I don’t even come to this message, now only the screen changes from dark black to light black)

As deano says, put a 3 on the GRUB prompt, this should get you to a full screen command prompt where you can login. It prevents the graphical shell from loading.

The other thing to do is press esc as soon as your machine boots away from GRUB, so you can see a bit more of what is happening. This can also be done with ‘splash=verbose’ at the GRUB prompt, or loaded permanently into your menu.lst GRUB file.

Hello there,

You have 2 options:
1st - do not attempt to login to KDE to the login window and use the shortcuts to go to CLI logins (CTRL+ALT+F1 … F4)

2nd - add to the boot loader option (see the previous tip from this thread): 3
this way will get you to runlevel 3 instead to the default runlevel 5 (the one with GUI).

There you can login with your username and password (you will need to elevate to root for deleting some files though).

The error message you receive is obvious - no more disk space so try to clean up - the suggestion was for tmp files, but also a good check would be for /var/log/

Also check your home folder (/home/yourusername)

Cheers and good luck.

If you can get booted to a command prompt, try the df command and copy the output of any line with ‘home’ in it into your post.

Please do tell more of what you have/see out of yourself. You mention this error in the 5th post instead of the first.

Do you have /home as a separate prtition?
When that partition is full you can not log in as a normal user.

Do as the others say: type a 3 (or may be even a 1) in the boot screen and tell us if you then can get to a console login.
When yes, log in as root and inspect /home.

Thank You!!!
I’ve been looking on and off for a long time and trying to remember if I ever knew… How to get to command console (by pass gui), if things are working and not dumbing you there on it’s own…

Type a 3 (for runlevel 3) in boot option… how simple…

Thanks, Спасибо,
ps. i’ve never used a ‘smillie’ before, but this get one: rotfl!